Outlook 2007 Indexing Options and Advanced Search options disabled

T

Tim

Im currently running Windows 7 RC1 Ultimate x64 and I recently started having

an issue with Outlook 2007. Somehow all of the advanced search options

(hitting the double arrow right of the "Search Inbox" field to specify From,

Body, Subject, etc) are disabled - i.e. greyed out and I cant use them. If I

go into Outlook Search options everything under the Indexing and Search

catagory is also disabled. Finally, I noticed if I go into Windows Indexing

Options > Modify, under Change selected locations "Microsoft Office Outlook"

is also greyed out and when I hover over it the tooltip says "Indexing of

Outlook email as been disabled by the System Administrator".

I have confirmed this isnt something set via group policy, because I have

several other similar PC's that this all works fine on. The only thing I can

think of is vaguely remembering changing some indexing options a while back

to supposedly increase performance, but I dont recall what or if I did this

before or after loading Win7.

Any suggestions are greatly appreciated!!
 
M

Milly Staples [MVP - Outlook]

Running any software programs on a pre-release version of any operating

system can have unexplained issues. It is also not supported.


After furious head scratching, Tim asked:

| Im currently running Windows 7 RC1 Ultimate x64 and I recently

| started having an issue with Outlook 2007. Somehow all of the

| advanced search options (hitting the double arrow right of the

| "Search Inbox" field to specify From, Body, Subject, etc) are

| disabled - i.e. greyed out and I cant use them. If I go into Outlook

| Search options everything under the Indexing and Search catagory is

| also disabled. Finally, I noticed if I go into Windows Indexing

| Options > Modify, under Change selected locations "Microsoft Office

| Outlook" is also greyed out and when I hover over it the tooltip says

| "Indexing of Outlook email as been disabled by the System

| Administrator".

|

| I have confirmed this isnt something set via group policy, because I

| have several other similar PC's that this all works fine on. The only

| thing I can think of is vaguely remembering changing some indexing

| options a while back to supposedly increase performance, but I dont

| recall what or if I did this before or after loading Win7.

|

| Any suggestions are greatly appreciated!!
 
T

Tim

Re: Outlook 2007 Indexing Options and Advanced Search options disa

I have no less than 3 other pcs running Outlook 2007 on Window 7 and they all

work without issue. I really dont think this has anything to do with Windows

7.

Are there any settings that could be changed / disabled that would cause

something like this to happen?
 
B

Balu

Re: Outlook 2007 Indexing Options and Advanced Search options disa

I faced the same issue with Windows 7 RC. Group Policy setting showed

"Not Configured" for outlook indexing. However, I also noticed that

there is a registry setting "PreventIndexingOutlook" set to "1" under

"HKLM/Policies/Software/Microsoft/Windows/Windows Search". (though i

never set it using any procedures)

Changed it to "0", forcibly set group policy for prevent outlook

indexing to "disabled". Changed the registry HKLM/Software/Microsoft/

Windows Search/SetupCompletedSuccessfully to "0" and restart

Outlook index is back!!!

Balu
 
T

Tim

Re: Outlook 2007 Indexing Options and Advanced Search options disa

Perfect! Thanks a TON Balu. I was on the verge of rebuilding I was getting so

frustrated with this.

It did take me a sec to track this down as you had a couple of your hives

mixed up. The PreventIndexingOutlook setting is actually under

HKLM\Software\Policies\Microsoft\Windows\Windows Search. I just did a find on

that key to figure out where it was.

Not sure how this setting got changed, but Im glad things are back to normal.

Thanks again!
 

dotcommie

Member
Outlook version
Outlook 2007
Email Account
Exchange Server
Re: Outlook 2007 Indexing Options and Advanced Search options disa

... your hives mixed up. The PreventIndexingOutlook setting is actually under HKLM\Software\Policies\Microsoft\Windows\Windows Search. ...
Wow! Nice catch to both of you. I can't even imagine how this setting gets created and pre-set to 1 - most likely an Office update. Thankfully, changing it to 0 had the desired effect of allowing searching properly again.
 
Top