Prevent automation UNC Resolution to mapped drives in Hyperlinks

  • Thread starter Gordon Muscroft
  • Start date Views 5,765
Status
Not open for further replies.
G

Gordon Muscroft

I want to prevent automatic resolution of mapped drives to UNC paths for

certain links in Outlook (Mail).

Is the is possible? I have tried to use the caret and double caret (<> and

<<>>) which so far has not been successful.

More details:

We are using ClearCase as a repository for design document, with all users

having custom views. These views are mapped to a common drive, but each view

has a different name: (IE: \\Person.Name\BusinesReq\...\filename.doc)

This makes the URL unique for every person, but in Outlook XP we could

e-mail the mapped drive/link between people. In Outlook 2007 the mapped drive

trys to resolve to the View Name, which is not available to anyone but the

originator of the document.

Thanks

Gord
 
N

neo [mvp outlook]

You can turn this off in AutoCorrect. Assuming Outlook 2007, start a new

message. Select the Pearl and then editor options. Proofing > AutoCorrect

Options. There are two tabs you have to visit in regards to internet/unc

paths.

"Gordon Muscroft" <Gordon Muscroft> wrote in

message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> I want to prevent automatic resolution of mapped drives to UNC paths for
> certain links in Outlook (Mail).

> Is the is possible? I have tried to use the caret and double caret (<> and
> <<>>) which so far has not been successful.

> More details:
> We are using ClearCase as a repository for design document, with all users
> having custom views. These views are mapped to a common drive, but each
> view
> has a different name: (IE: \\Person.Name\BusinesReq\...\filename.doc)

> This makes the URL unique for every person, but in Outlook XP we could
> e-mail the mapped drive/link between people. In Outlook 2007 the mapped
> drive
> trys to resolve to the View Name, which is not available to anyone but the
> originator of the document.

> Thanks
> Gord

>
 
G

Gordon Muscroft

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

This is what I tried to do, but it still seems not to work.

(I turned off (Unchecked) the "Internet and Network Paths with Hyperlink" on

the Autoformat tab in the Pearl/Proofing/Autocorrect Option--Autocorrect Tab)

FYI: Outlook 2007, SP-2

Vista SP-2

Any other sugesstions? Registry?

"neo [mvp outlook]" wrote:


> You can turn this off in AutoCorrect. Assuming Outlook 2007, start a new
> message. Select the Pearl and then editor options. Proofing > AutoCorrect
> Options. There are two tabs you have to visit in regards to internet/unc
> paths.

> "Gordon Muscroft" <Gordon Muscroft> wrote in
> message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> >I want to prevent automatic resolution of mapped drives to UNC paths for
> > certain links in Outlook (Mail).
> > Is the is possible? I have tried to use the caret and double caret (<> and
> > <<>>) which so far has not been successful.
> > More details:
> > We are using ClearCase as a repository for design document, with all users
> > having custom views. These views are mapped to a common drive, but each
> > view
> > has a different name: (IE: \\Person.Name\BusinesReq\...\filename.doc)
> > This makes the URL unique for every person, but in Outlook XP we could
> > e-mail the mapped drive/link between people. In Outlook 2007 the mapped
> > drive
> > trys to resolve to the View Name, which is not available to anyone but the
> > originator of the document.
> > Thanks
> > Gord
> >


>
 
N

neo [mvp outlook]

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

Hmm... I am not able to duplicate and I have the same configuration. Just

to make sure, after you uncheck the two boxes in question, all new messages

that you compose are still generating clickable links to Internet/UNC paths?

"Gordon Muscroft" <GordonMuscroft> wrote in

message news:5AB8B4A1-7307-46B6-A390-ED0C2B0FFA93@microsoft.com...
> This is what I tried to do, but it still seems not to work.
> (I turned off (Unchecked) the "Internet and Network Paths with Hyperlink"
> on
> the Autoformat tab in the Pearl/Proofing/Autocorrect Option--Autocorrect
> Tab)

> FYI: Outlook 2007, SP-2
> Vista SP-2

> Any other sugesstions? Registry?

> "neo [mvp outlook]" wrote:
>
> > You can turn this off in AutoCorrect. Assuming Outlook 2007, start a new
> > message. Select the Pearl and then editor options. Proofing

>> AutoCorrect
> > Options. There are two tabs you have to visit in regards to internet/unc
> > paths.
>

>> "Gordon Muscroft" <Gordon Muscroft> wrote in
> > message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> > >I want to prevent automatic resolution of mapped drives to UNC paths for
> > > certain links in Outlook (Mail).
> >> > Is the is possible? I have tried to use the caret and double caret (<
>> > and
> > > <<>>) which so far has not been successful.
> >> > More details:
> > > We are using ClearCase as a repository for design document, with all
> > > users
> > > having custom views. These views are mapped to a common drive, but each
> > > view
> > > has a different name: (IE: \\Person.Name\BusinesReq\...\filename.doc)
> >> > This makes the URL unique for every person, but in Outlook XP we could
> > > e-mail the mapped drive/link between people. In Outlook 2007 the mapped
> > > drive
> > > trys to resolve to the View Name, which is not available to anyone but
> > > the
> > > originator of the document.
> >>> > Thanks
> > > Gord
> >>>>> >

>

>>
 
G

Gordon Muscroft

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

Neo;

The links are not clickable after unchecking the box in question, IE: They

are inserted as text, but what I was looking for was a clickable link which

does not resolve to a UNC path.

Example s:\Documents\Requirements\MyDoc.doc

as opposed to a link whic resolves to:

\\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.

It looks like this behavior is the same in Word, and most likely across the

Office suite.... In most cases I would say this is a good thing, but in the

particular case I am in the resolution to a common UNC path will not work.

Thanks

Gord

"neo [mvp outlook]" wrote:


> Hmm... I am not able to duplicate and I have the same configuration. Just
> to make sure, after you uncheck the two boxes in question, all new messages
> that you compose are still generating clickable links to Internet/UNC paths?

> "Gordon Muscroft" <GordonMuscroft> wrote in
> message news:5AB8B4A1-7307-46B6-A390-ED0C2B0FFA93@microsoft.com...
> > This is what I tried to do, but it still seems not to work.
> > (I turned off (Unchecked) the "Internet and Network Paths with Hyperlink"
> > on
> > the Autoformat tab in the Pearl/Proofing/Autocorrect Option--Autocorrect
> > Tab)
> > FYI: Outlook 2007, SP-2
> > Vista SP-2
> > Any other sugesstions? Registry?
> > "neo [mvp outlook]" wrote:
> >
> >> You can turn this off in AutoCorrect. Assuming Outlook 2007, start a new
> >> message. Select the Pearl and then editor options. Proofing

> >> AutoCorrect
> >> Options. There are two tabs you have to visit in regards to internet/unc
> >> paths.
> >
> >> "Gordon Muscroft" <Gordon Muscroft> wrote in
> >> message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> >> >I want to prevent automatic resolution of mapped drives to UNC paths for
> >> > certain links in Outlook (Mail).
> >> >> > Is the is possible? I have tried to use the caret and double caret (<
> >> > and
> >> > <<>>) which so far has not been successful.
> >> >> > More details:
> >> > We are using ClearCase as a repository for design document, with all
> >> > users
> >> > having custom views. These views are mapped to a common drive, but each
> >> > view
> >> > has a different name: (IE: \\Person.Name\BusinesReq\...\filename.doc)
> >> >> > This makes the URL unique for every person, but in Outlook XP we could
> >> > e-mail the mapped drive/link between people. In Outlook 2007 the mapped
> >> > drive
> >> > trys to resolve to the View Name, which is not available to anyone but
> >> > the
> >> > originator of the document.
> >> >> >> > Thanks
> >> > Gord
> >> >> >> >> >> >
> >>


>
 

Brian Tillman

Senior Member
Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

"Gordon Muscroft" <GordonMuscroft> wrote in message

news:B64B5689-1DA0-4A3F-97C8-E9933CF9BCA5@microsoft.com...


> Example s:\Documents\Requirements\MyDoc.doc
> as opposed to a link whic resolves to:
> \\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.


If yupi use a file:// URL instead.

file://s:\Documents\Requirements\MyDoc.doc/

does that make a difference?

--
 
N

neo [mvp outlook]

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

I would have to agree with Brian at this point. Assuming the two boxes I

mentioned are unchecked, you should be able to right click on the text and

use the Hyperlink option. Just type in

file://drive_letter:\folder\folder1\filename.doc or

file://\\server\project\documents\requirements\filename.doc and it should

net you a clickable link that doesn't change on you.

"Gordon Muscroft" <GordonMuscroft> wrote in

message news:B64B5689-1DA0-4A3F-97C8-E9933CF9BCA5@microsoft.com...
> Neo;
> The links are not clickable after unchecking the box in question, IE: They
> are inserted as text, but what I was looking for was a clickable link
> which
> does not resolve to a UNC path.

> Example s:\Documents\Requirements\MyDoc.doc
> as opposed to a link whic resolves to:
> \\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.

> It looks like this behavior is the same in Word, and most likely across
> the
> Office suite.... In most cases I would say this is a good thing, but in
> the
> particular case I am in the resolution to a common UNC path will not work.

> Thanks
> Gord

> "neo [mvp outlook]" wrote:
>
> > Hmm... I am not able to duplicate and I have the same configuration.
> > Just
> > to make sure, after you uncheck the two boxes in question, all new
> > messages
> > that you compose are still generating clickable links to Internet/UNC
> > paths?
>

>> "Gordon Muscroft" <GordonMuscroft> wrote in
> > message news:5AB8B4A1-7307-46B6-A390-ED0C2B0FFA93@microsoft.com...
> > > This is what I tried to do, but it still seems not to work.
> > > (I turned off (Unchecked) the "Internet and Network Paths with
> > > Hyperlink"
> > > on
> > > the Autoformat tab in the Pearl/Proofing/Autocorrect
> > > Option--Autocorrect
> > > Tab)
> >> > FYI: Outlook 2007, SP-2
> > > Vista SP-2
> >> > Any other sugesstions? Registry?
> >>> > "neo [mvp outlook]" wrote:
> >> >> You can turn this off in AutoCorrect. Assuming Outlook 2007, start a
> > >> new
> > >> message. Select the Pearl and then editor options. Proofing

>> >> AutoCorrect
> > >> Options. There are two tabs you have to visit in regards to
> > >> internet/unc
> > >> paths.
> > >
>> >> "Gordon Muscroft" <Gordon Muscroft> wrote in
> > >> message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> > >> >I want to prevent automatic resolution of mapped drives to UNC paths
> > >> >for
> > >> > certain links in Outlook (Mail).
> > >>> >> > Is the is possible? I have tried to use the caret and double caret
> > >> > (<
>> >> > and
> > >> > <<>>) which so far has not been successful.
> > >>> >> > More details:
> > >> > We are using ClearCase as a repository for design document, with all
> > >> > users
> > >> > having custom views. These views are mapped to a common drive, but
> > >> > each
> > >> > view
> > >> > has a different name: (IE:
> > >> > \\Person.Name\BusinesReq\...\filename.doc)
> > >>> >> > This makes the URL unique for every person, but in Outlook XP we
> > >> > could
> > >> > e-mail the mapped drive/link between people. In Outlook 2007 the
> > >> > mapped
> > >> > drive
> > >> > trys to resolve to the View Name, which is not available to anyone
> > >> > but
> > >> > the
> > >> > originator of the document.
> > >>> >>> >> > Thanks
> > >> > Gord
> > >>> >>> >>> >>> >>> >
>> >>

>

>>
 
G

Gordon Muscroft

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

Guys, thanks in advance for the help.

Does not look like it will work. As soon as the OS or Office sees a link it

can resolve it tries to resolve back to UNC path.

When I use file://S:/CQCC_Dev/ZZZ/XYZ.txt it changes the hyperlink to:

file/S:/CQCC_Dev/ZZZ/XYZ.txt

When I use: file://S:\CQCC_Dev\ZZZ\XYZ.txt it reverts to:

\\view\Gordon.Muscroft_WIP_View\CQCC_Dev\ZZZ\XYZ.txt

when you close the Hyperlink edit box.

It seems to do a similar thing in Word, as well as Excel using the Excel

Hyperlink function. Interesting, as the Excel Hyperlink function saves the

correct link EG:

=HYPERLINK("S:\CQCC_Dev\ZZZ\XYZ.txt","TestLink")

but it again tries to resolve to \\view\....

Any other suggestions would be appreciated.

Thanks

Again.

"neo [mvp outlook]" wrote:


> I would have to agree with Brian at this point. Assuming the two boxes I
> mentioned are unchecked, you should be able to right click on the text and
> use the Hyperlink option. Just type in
> file://drive_letter:\folder\folder1\filename.doc or
> file://\\server\project\documents\requirements\filename.doc and it should
> net you a clickable link that doesn't change on you.

> "Gordon Muscroft" <GordonMuscroft> wrote in
> message news:B64B5689-1DA0-4A3F-97C8-E9933CF9BCA5@microsoft.com...
> > Neo;
> > The links are not clickable after unchecking the box in question, IE: They
> > are inserted as text, but what I was looking for was a clickable link
> > which
> > does not resolve to a UNC path.
> > Example s:\Documents\Requirements\MyDoc.doc
> > as opposed to a link whic resolves to:
> > \\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.
> > It looks like this behavior is the same in Word, and most likely across
> > the
> > Office suite.... In most cases I would say this is a good thing, but in
> > the
> > particular case I am in the resolution to a common UNC path will not work.
> > Thanks
> > Gord
> >

>
 
G

Gordon Muscroft

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

Guys;

I have posted a couple of replies but they seem to be getting deleted. I am

not sure what is going on. I will try later from home...

Long story. Its still failing as onced mailed the UNC tries to resolve to a

view..

Same in Excel and WOrd.

Thanks for the help

Gord

"neo [mvp outlook]" wrote:


> I would have to agree with Brian at this point. Assuming the two boxes I
> mentioned are unchecked, you should be able to right click on the text and
> use the Hyperlink option. Just type in
> file://drive_letter:\folder\folder1\filename.doc or
> file://\\server\project\documents\requirements\filename.doc and it should
> net you a clickable link that doesn't change on you.

> "Gordon Muscroft" <GordonMuscroft> wrote in
> message news:B64B5689-1DA0-4A3F-97C8-E9933CF9BCA5@microsoft.com...
> > Neo;
> > The links are not clickable after unchecking the box in question, IE: They
> > are inserted as text, but what I was looking for was a clickable link
> > which
> > does not resolve to a UNC path.
> > Example s:\Documents\Requirements\MyDoc.doc
> > as opposed to a link whic resolves to:
> > \\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.
> > It looks like this behavior is the same in Word, and most likely across
> > the
> > Office suite.... In most cases I would say this is a good thing, but in
> > the
> > particular case I am in the resolution to a common UNC path will not work.
> > Thanks
> > Gord
> > "neo [mvp outlook]" wrote:
> >
> >> Hmm... I am not able to duplicate and I have the same configuration.
> >> Just
> >> to make sure, after you uncheck the two boxes in question, all new
> >> messages
> >> that you compose are still generating clickable links to Internet/UNC
> >> paths?
> >
> >> "Gordon Muscroft" <GordonMuscroft> wrote in
> >> message news:5AB8B4A1-7307-46B6-A390-ED0C2B0FFA93@microsoft.com...
> >> > This is what I tried to do, but it still seems not to work.
> >> > (I turned off (Unchecked) the "Internet and Network Paths with
> >> > Hyperlink"
> >> > on
> >> > the Autoformat tab in the Pearl/Proofing/Autocorrect
> >> > Option--Autocorrect
> >> > Tab)
> >> >> > FYI: Outlook 2007, SP-2
> >> > Vista SP-2
> >> >> > Any other sugesstions? Registry?
> >> >> >> > "neo [mvp outlook]" wrote:
> >> >> >> You can turn this off in AutoCorrect. Assuming Outlook 2007, start a
> >> >> new
> >> >> message. Select the Pearl and then editor options. Proofing

> >> >> AutoCorrect
> >> >> Options. There are two tabs you have to visit in regards to
> >> >> internet/unc
> >> >> paths.
> >> >
> >> >> "Gordon Muscroft" <Gordon Muscroft> wrote in
> >> >> message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> >> >> >I want to prevent automatic resolution of mapped drives to UNC paths
> >> >> >for
> >> >> > certain links in Outlook (Mail).
> >> >> >> >> > Is the is possible? I have tried to use the caret and double caret
> >> >> > (<
> >> >> > and
> >> >> > <<>>) which so far has not been successful.
> >> >> >> >> > More details:
> >> >> > We are using ClearCase as a repository for design document, with all
> >> >> > users
> >> >> > having custom views. These views are mapped to a common drive, but
> >> >> > each
> >> >> > view
> >> >> > has a different name: (IE:
> >> >> > \\Person.Name\BusinesReq\...\filename.doc)
> >> >> >> >> > This makes the URL unique for every person, but in Outlook XP we
> >> >> > could
> >> >> > e-mail the mapped drive/link between people. In Outlook 2007 the
> >> >> > mapped
> >> >> > drive
> >> >> > trys to resolve to the View Name, which is not available to anyone
> >> >> > but
> >> >> > the
> >> >> > originator of the document.
> >> >> >> >> >> >> > Thanks
> >> >> > Gord
> >> >> >> >> >> >> >> >> >> >> >> >
> >> >
> >
> >>


>
 
N

neo [mvp outlook]

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

Okay, if you can expand on "tries to resolve to a..." that would be helpful

as I'm not sure you are saying that the e-mail takes longer to open because

Outlook is trying to verify the path is valid or something else.

"Gordon Muscroft" <GordonMuscroft> wrote in

message news:32B23160-565A-4D5C-8EBE-45E1D4624C39@microsoft.com...
> Guys;

> I have posted a couple of replies but they seem to be getting deleted. I
> am
> not sure what is going on. I will try later from home...
> Long story. Its still failing as onced mailed the UNC tries to resolve to
> a
> view..
> Same in Excel and WOrd.

> Thanks for the help
> Gord

> "neo [mvp outlook]" wrote:
>
> > I would have to agree with Brian at this point. Assuming the two boxes I
> > mentioned are unchecked, you should be able to right click on the text
> > and
> > use the Hyperlink option. Just type in
> > file://drive_letter:\folder\folder1\filename.doc or
> > file://\\server\project\documents\requirements\filename.doc and it should
> > net you a clickable link that doesn't change on you.
>

>> "Gordon Muscroft" <GordonMuscroft> wrote in
> > message news:B64B5689-1DA0-4A3F-97C8-E9933CF9BCA5@microsoft.com...
> > > Neo;
> > > The links are not clickable after unchecking the box in question, IE:
> > > They
> > > are inserted as text, but what I was looking for was a clickable link
> > > which
> > > does not resolve to a UNC path.
> >> > Example s:\Documents\Requirements\MyDoc.doc
> > > as opposed to a link whic resolves to:
> > > \\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.
> >> > It looks like this behavior is the same in Word, and most likely across
> > > the
> > > Office suite.... In most cases I would say this is a good thing, but
> > > in
> > > the
> > > particular case I am in the resolution to a common UNC path will not
> > > work.
> >> > Thanks
> > > Gord
> >>>>> > "neo [mvp outlook]" wrote:
> >> >> Hmm... I am not able to duplicate and I have the same configuration.
> > >> Just
> > >> to make sure, after you uncheck the two boxes in question, all new
> > >> messages
> > >> that you compose are still generating clickable links to Internet/UNC
> > >> paths?
> > >
>> >> "Gordon Muscroft" <GordonMuscroft> wrote in
> > >> message news:5AB8B4A1-7307-46B6-A390-ED0C2B0FFA93@microsoft.com...
> > >> > This is what I tried to do, but it still seems not to work.
> > >> > (I turned off (Unchecked) the "Internet and Network Paths with
> > >> > Hyperlink"
> > >> > on
> > >> > the Autoformat tab in the Pearl/Proofing/Autocorrect
> > >> > Option--Autocorrect
> > >> > Tab)
> > >>> >> > FYI: Outlook 2007, SP-2
> > >> > Vista SP-2
> > >>> >> > Any other sugesstions? Registry?
> > >>> >>> >> > "neo [mvp outlook]" wrote:
> > >>> >> >> You can turn this off in AutoCorrect. Assuming Outlook 2007, start
> > >> >> a
> > >> >> new
> > >> >> message. Select the Pearl and then editor options. Proofing

>> >> >> AutoCorrect
> > >> >> Options. There are two tabs you have to visit in regards to
> > >> >> internet/unc
> > >> >> paths.
> > >> >
>> >> >> "Gordon Muscroft" <Gordon Muscroft> wrote
> > >> >> in
> > >> >> message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> > >> >> >I want to prevent automatic resolution of mapped drives to UNC
> > >> >> >paths
> > >> >> >for
> > >> >> > certain links in Outlook (Mail).
> > >> >>> >> >> > Is the is possible? I have tried to use the caret and double
> > >> >> > caret
> > >> >> > (<
>> >> >> > and
> > >> >> > <<>>) which so far has not been successful.
> > >> >>> >> >> > More details:
> > >> >> > We are using ClearCase as a repository for design document, with
> > >> >> > all
> > >> >> > users
> > >> >> > having custom views. These views are mapped to a common drive,
> > >> >> > but
> > >> >> > each
> > >> >> > view
> > >> >> > has a different name: (IE:
> > >> >> > \\Person.Name\BusinesReq\...\filename.doc)
> > >> >>> >> >> > This makes the URL unique for every person, but in Outlook XP we
> > >> >> > could
> > >> >> > e-mail the mapped drive/link between people. In Outlook 2007 the
> > >> >> > mapped
> > >> >> > drive
> > >> >> > trys to resolve to the View Name, which is not available to
> > >> >> > anyone
> > >> >> > but
> > >> >> > the
> > >> >> > originator of the document.
> > >> >>> >> >>> >> >> > Thanks
> > >> >> > Gord
> > >> >>> >> >>> >> >>> >> >>> >> >>> >> >
>> >> >
>> >
>> >>

>

>>
 
G

Gordon Muscroft

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

Thanks again for the help. FYI my posts seem to be getting deleted. I am not

sure why. They get posted for about 15 minutes and then disappear.

The problem continues, as once you map a drive, when the location opens, it

gets resolved to a UNC address. I have even tried to use Word and Excel, but

to no avail.

To reproduce the problem, map a drive and then use insert Hyperlink in

Outlook, Word or Excel. Try to navigate from the hyperlink in the document.

The result will not be to the Mapped drive in file explorer, but the UNC path

to the hyperlink.

This is most likely by design, but are there any parameters available to

over-ride this behavior?

Thanks again

Gord

"neo [mvp outlook]" wrote:


> Okay, if you can expand on "tries to resolve to a..." that would be helpful
> as I'm not sure you are saying that the e-mail takes longer to open because
> Outlook is trying to verify the path is valid or something else.

> "Gordon Muscroft" <GordonMuscroft> wrote in
> message news:32B23160-565A-4D5C-8EBE-45E1D4624C39@microsoft.com...
> > Guys;
> > I have posted a couple of replies but they seem to be getting deleted. I
> > am
> > not sure what is going on. I will try later from home...
> > Long story. Its still failing as onced mailed the UNC tries to resolve to
> > a
> > view..
> > Same in Excel and WOrd.
> > Thanks for the help
> > Gord
> > "neo [mvp outlook]" wrote:
> >
> >> I would have to agree with Brian at this point. Assuming the two boxes I
> >> mentioned are unchecked, you should be able to right click on the text
> >> and
> >> use the Hyperlink option. Just type in
> >> file://drive_letter:\folder\folder1\filename.doc or
> >> file://\\server\project\documents\requirements\filename.doc and it should
> >> net you a clickable link that doesn't change on you.
> >
> >> "Gordon Muscroft" <GordonMuscroft> wrote in
> >> message news:B64B5689-1DA0-4A3F-97C8-E9933CF9BCA5@microsoft.com...
> >> > Neo;
> >> > The links are not clickable after unchecking the box in question, IE:
> >> > They
> >> > are inserted as text, but what I was looking for was a clickable link
> >> > which
> >> > does not resolve to a UNC path.
> >> >> > Example s:\Documents\Requirements\MyDoc.doc
> >> > as opposed to a link whic resolves to:
> >> > \\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.
> >> >> > It looks like this behavior is the same in Word, and most likely across
> >> > the
> >> > Office suite.... In most cases I would say this is a good thing, but
> >> > in
> >> > the
> >> > particular case I am in the resolution to a common UNC path will not
> >> > work.
> >> >> > Thanks
> >> > Gord
> >> >> >> >> >> > "neo [mvp outlook]" wrote:
> >> >> >> Hmm... I am not able to duplicate and I have the same configuration.
> >> >> Just
> >> >> to make sure, after you uncheck the two boxes in question, all new
> >> >> messages
> >> >> that you compose are still generating clickable links to Internet/UNC
> >> >> paths?
> >> >
> >> >> "Gordon Muscroft" <GordonMuscroft> wrote in
> >> >> message news:5AB8B4A1-7307-46B6-A390-ED0C2B0FFA93@microsoft.com...
> >> >> > This is what I tried to do, but it still seems not to work.
> >> >> > (I turned off (Unchecked) the "Internet and Network Paths with
> >> >> > Hyperlink"
> >> >> > on
> >> >> > the Autoformat tab in the Pearl/Proofing/Autocorrect
> >> >> > Option--Autocorrect
> >> >> > Tab)
> >> >> >> >> > FYI: Outlook 2007, SP-2
> >> >> > Vista SP-2
> >> >> >> >> > Any other sugesstions? Registry?
> >> >> >> >> >> >> > "neo [mvp outlook]" wrote:
> >> >> >> >> >> You can turn this off in AutoCorrect. Assuming Outlook 2007, start
> >> >> >> a
> >> >> >> new
> >> >> >> message. Select the Pearl and then editor options. Proofing

> >> >> >> AutoCorrect
> >> >> >> Options. There are two tabs you have to visit in regards to
> >> >> >> internet/unc
> >> >> >> paths.
> >> >> >
> >> >> >> "Gordon Muscroft" <Gordon Muscroft> wrote
> >> >> >> in
> >> >> >> message news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> >> >> >> >I want to prevent automatic resolution of mapped drives to UNC
> >> >> >> >paths
> >> >> >> >for
> >> >> >> > certain links in Outlook (Mail).
> >> >> >> >> >> >> > Is the is possible? I have tried to use the caret and double
> >> >> >> > caret
> >> >> >> > (<
> >> >> >> > and
> >> >> >> > <<>>) which so far has not been successful.
> >> >> >> >> >> >> > More details:
> >> >> >> > We are using ClearCase as a repository for design document, with
> >> >> >> > all
> >> >> >> > users
> >> >> >> > having custom views. These views are mapped to a common drive,
> >> >> >> > but
> >> >> >> > each
> >> >> >> > view
> >> >> >> > has a different name: (IE:
> >> >> >> > \\Person.Name\BusinesReq\...\filename.doc)
> >> >> >> >> >> >> > This makes the URL unique for every person, but in Outlook XP we
> >> >> >> > could
> >> >> >> > e-mail the mapped drive/link between people. In Outlook 2007 the
> >> >> >> > mapped
> >> >> >> > drive
> >> >> >> > trys to resolve to the View Name, which is not available to
> >> >> >> > anyone
> >> >> >> > but
> >> >> >> > the
> >> >> >> > originator of the document.
> >> >> >> >> >> >> >> >> >> > Thanks
> >> >> >> > Gord
> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >
> >> >> >
> >> >
> >> >
> >
> >>


>
 
N

neo [mvp outlook]

Re: Prevent automation UNC Resolution to mapped drives in Hyperlin

I can't find anything on whether or not Office 2007 applications use the

"DontUseUNC" registry value, but I'm still researching.

"Gordon Muscroft" <GordonMuscroft> wrote in

message news:7A1464EA-5B7D-40EE-8CFB-4BD5BEBCCC8F@microsoft.com...

Thanks again for the help. FYI my posts seem to be getting deleted. I am

not

sure why. They get posted for about 15 minutes and then disappear.

The problem continues, as once you map a drive, when the location opens, it

gets resolved to a UNC address. I have even tried to use Word and Excel, but

to no avail.

To reproduce the problem, map a drive and then use insert Hyperlink in

Outlook, Word or Excel. Try to navigate from the hyperlink in the document.

The result will not be to the Mapped drive in file explorer, but the UNC

path

to the hyperlink.

This is most likely by design, but are there any parameters available to

over-ride this behavior?

Thanks again

Gord

"neo [mvp outlook]" wrote:


> Okay, if you can expand on "tries to resolve to a..." that would be
> helpful
> as I'm not sure you are saying that the e-mail takes longer to open
> because
> Outlook is trying to verify the path is valid or something else.

> "Gordon Muscroft" <GordonMuscroft> wrote in
> message news:32B23160-565A-4D5C-8EBE-45E1D4624C39@microsoft.com...
> > Guys;
> > I have posted a couple of replies but they seem to be getting deleted. I
> > am
> > not sure what is going on. I will try later from home...
> > Long story. Its still failing as onced mailed the UNC tries to resolve
> > to
> > a
> > view..
> > Same in Excel and WOrd.
> > Thanks for the help
> > Gord
> > "neo [mvp outlook]" wrote:
> >
> >> I would have to agree with Brian at this point. Assuming the two boxes
> >> I
> >> mentioned are unchecked, you should be able to right click on the text
> >> and
> >> use the Hyperlink option. Just type in
> >> file://drive_letter:\folder\folder1\filename.doc or
> >> file://\\server\project\documents\requirements\filename.doc and it
> >> should
> >> net you a clickable link that doesn't change on you.
> >
> >> "Gordon Muscroft" <GordonMuscroft> wrote in
> >> message news:B64B5689-1DA0-4A3F-97C8-E9933CF9BCA5@microsoft.com...
> >> > Neo;
> >> > The links are not clickable after unchecking the box in question, IE:
> >> > They
> >> > are inserted as text, but what I was looking for was a clickable link
> >> > which
> >> > does not resolve to a UNC path.
> >> >> > Example s:\Documents\Requirements\MyDoc.doc
> >> > as opposed to a link whic resolves to:
> >> > \\ServerName\ProjectDirectory\Documents\Requirements\MyDoc.doc.
> >> >> > It looks like this behavior is the same in Word, and most likely
> >> > across
> >> > the
> >> > Office suite.... In most cases I would say this is a good thing,
> >> > but
> >> > in
> >> > the
> >> > particular case I am in the resolution to a common UNC path will not
> >> > work.
> >> >> > Thanks
> >> > Gord
> >> >> >> >> >> > "neo [mvp outlook]" wrote:
> >> >> >> Hmm... I am not able to duplicate and I have the same configuration.
> >> >> Just
> >> >> to make sure, after you uncheck the two boxes in question, all new
> >> >> messages
> >> >> that you compose are still generating clickable links to
> >> >> Internet/UNC
> >> >> paths?
> >> >
> >> >> "Gordon Muscroft" <GordonMuscroft> wrote
> >> >> in
> >> >> message news:5AB8B4A1-7307-46B6-A390-ED0C2B0FFA93@microsoft.com...
> >> >> > This is what I tried to do, but it still seems not to work.
> >> >> > (I turned off (Unchecked) the "Internet and Network Paths with
> >> >> > Hyperlink"
> >> >> > on
> >> >> > the Autoformat tab in the Pearl/Proofing/Autocorrect
> >> >> > Option--Autocorrect
> >> >> > Tab)
> >> >> >> >> > FYI: Outlook 2007, SP-2
> >> >> > Vista SP-2
> >> >> >> >> > Any other sugesstions? Registry?
> >> >> >> >> >> >> > "neo [mvp outlook]" wrote:
> >> >> >> >> >> You can turn this off in AutoCorrect. Assuming Outlook 2007,
> >> >> >> start
> >> >> >> a
> >> >> >> new
> >> >> >> message. Select the Pearl and then editor options. Proofing

> >> >> >> AutoCorrect
> >> >> >> Options. There are two tabs you have to visit in regards to
> >> >> >> internet/unc
> >> >> >> paths.
> >> >> >
> >> >> >> "Gordon Muscroft" <Gordon Muscroft
> >> >> >> wrote
> >> >> >> in
> >> >> >> message
> >> >> >> news:6C6D6948-6B97-4356-9299-E66EDEB76448@microsoft.com...
> >> >> >> >I want to prevent automatic resolution of mapped drives to UNC
> >> >> >> >paths
> >> >> >> >for
> >> >> >> > certain links in Outlook (Mail).
> >> >> >> >> >> >> > Is the is possible? I have tried to use the caret and double
> >> >> >> > caret
> >> >> >> > (<
> >> >> >> > and
> >> >> >> > <<>>) which so far has not been successful.
> >> >> >> >> >> >> > More details:
> >> >> >> > We are using ClearCase as a repository for design document,
> >> >> >> > with
> >> >> >> > all
> >> >> >> > users
> >> >> >> > having custom views. These views are mapped to a common drive,
> >> >> >> > but
> >> >> >> > each
> >> >> >> > view
> >> >> >> > has a different name: (IE:
> >> >> >> > \\Person.Name\BusinesReq\...\filename.doc)
> >> >> >> >> >> >> > This makes the URL unique for every person, but in Outlook XP
> >> >> >> > we
> >> >> >> > could
> >> >> >> > e-mail the mapped drive/link between people. In Outlook 2007
> >> >> >> > the
> >> >> >> > mapped
> >> >> >> > drive
> >> >> >> > trys to resolve to the View Name, which is not available to
> >> >> >> > anyone
> >> >> >> > but
> >> >> >> > the
> >> >> >> > originator of the document.
> >> >> >> >> >> >> >> >> >> > Thanks
> >> >> >> > Gord
> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >> >
> >> >> >
> >> >
> >> >
> >
> >>


>
 
Status
Not open for further replies.

Similar threads

Top