wrong icon displayed for outlook custom form

lboucher

Member
Hello,




I modified the standard contact form and its works fine, but does not show the contact icon when a new contact is created. I went back into form design and the icons that it showed were post it icons. I changed the icons to the contact icons and republished the form, but now when a new contact it created it shows an email icon, but still not the contact form. I have even removed the active form in manage forms, cleared the cache and recopied the form but still see the wrong icon when looking at the contacts in category view and other contact views.




Can anyone shed any light on what is happening and how it can be fixed?




Thanks,




Leo
 
S

Sue Mosher [MVP]

On the problem items, what value do you see for the MessageClass property?

Add it to a view if you need to.

Sue Mosher

"lboucher" <lboucher.3x6p6m@no-spam.invalid> wrote in message

news:lboucher.3x6p6m@no-spam.invalid...

> Hello,

> I modified the standard contact form and its works fine, but does not
> show the contact icon when a new contact is created. I went back into
> form design and the icons that it showed were post it icons. I changed
> the icons to the contact icons and republished the form, but now when a
> new contact it created it shows an email icon, but still not the contact
> form. I have even removed the active form in manage forms, cleared the
> cache and recopied the form but still see the wrong icon when looking at
> the contacts in category view and other contact views.

> Can anyone shed any light on what is happening and how it can be
> fixed?

> Thanks,

> Leo

> > lboucher
> https://forums.slipstick.com/
>
 

lboucher

Member
On the problem items, what value do you see for the MessageClass property?


Add it to a view if you need to.




--


Sue Mosher












"lboucher" <lboucher.3x6p6m@no-spam.invalid> wrote in message


news:lboucher.3x6p6m@no-spam.invalid...

>

> Hello,

>

> I modified the standard contact form and its works fine, but does not

> show the contact icon when a new contact is created. I went back into

> form design and the icons that it showed were post it icons. I changed

> the icons to the contact icons and republished the form, but now when a

> new contact it created it shows an email icon, but still not the contact

> form. I have even removed the active form in manage forms, cleared the

> cache and recopied the form but still see the wrong icon when looking at

> the contacts in category view and other contact views.

>

> Can anyone shed any light on what is happening and how it can be

> fixed?

>

> Thanks,

>

> Leo

>

>

> --

> lboucher

> https://forums.slipstick.com/

>





Sue, thanks for the quick reply. I see this messageclass:


IPM.Contact.custom outlook form4




Leo
 
S

Sue Mosher [MVP]

Did you use the correct icons? There are two for each type of item, one

large, one small.

Sue Mosher

"lboucher" <lboucher.3x6qsy@no-spam.invalid> wrote in message

news:lboucher.3x6qsy@no-spam.invalid...
> >> > I modified the standard contact form and its works fine, but does

> > not
> > > show the contact icon when a new contact is created. I went back

> > into
> > > form design and the icons that it showed were post it icons. I

> > changed
> > > the icons to the contact icons and republished the form, but now when

> > a
> > > new contact it created it shows an email icon, but still not the

> > contact
> > > form. I have even removed the active form in manage forms, cleared

> > the
> > > cache and recopied the form but still see the wrong icon when looking

> > at
> > > the contacts in category view and other contact views.
> > >


> Sue, thanks for the quick reply. I see this messageclass:
> IPM.Contact.custom outlook form4
 

lboucher

Member
Did you use the correct icons? There are two for each type of item, one


large, one small.




--


Sue Mosher












"lboucher" <lboucher.3x6qsy@no-spam.invalid> wrote in message


news:lboucher.3x6qsy@no-spam.invalid...

> > >

> > > I modified the standard contact form and its works fine, but does


> > not

> > > show the contact icon when a new contact is created. I went back


> > into

> > > form design and the icons that it showed were post it icons. I


> > changed

> > > the icons to the contact icons and republished the form, but now when


> > a

> > > new contact it created it shows an email icon, but still not the


> > contact

> > > form. I have even removed the active form in manage forms, cleared


> > the

> > > cache and recopied the form but still see the wrong icon when looking


> > at

> > > the contacts in category view and other contact views.

> > >


>

> Sue, thanks for the quick reply. I see this messageclass:

> IPM.Contact.custom outlook form4





I did not know where to find the Outlook icons so extracted what they were in the outlook.exe, which looks like the Outlook contact icons are all 32x32. Where can I get the Outlook contact correct large and small Outlook icons?




Leo
 
S

Sue Mosher [MVP]

C:\Program Files\Microsoft Office\Office12\FORMS\1033 or the corresponding

folder for your version of Outlook and language. You'll see contactl.ico and

contacts.ico for the large and small versions, respectively.

Sue Mosher

"lboucher" <lboucher.3x6u9y@no-spam.invalid> wrote in message

news:lboucher.3x6u9y@no-spam.invalid...

> I did not know where to find the Outlook icons so extracted what they
> were in the outlook.exe, which looks like the Outlook contact icons are
> all 32x32. Where can I get the Outlook contact correct large and small
> Outlook icons?
 

lboucher

Member
I did not know where to find the Outlook icons so extracted what they were in the outlook.exe, which looks like the Outlook contact icons are all 32x32. Where can I get the Outlook contact correct large and small Outlook icons?




Leo





It looks like I fixed it. I found the correct icons, added them to the custom form, republished it and now the icon is looking correct.




Thanks for your help,




Leo
 

Jagstyles

Member
Outlook version
Outlook 2016 32 bit
Email Account
Exchange Server
It looks like I fixed it. I found the correct icons, added them to the custom form, republished it and now the icon is looking correct.





Thanks for your help,





Leo
I'm running into this very issue. Where did you find the correct icons? When I go to the PATH provided earlier, the CONTACT.ICO and CONTACTL.ICO files show the older icons, not the ones that are in Outlook 2016. I've tried looking everywhere for the newer version of the contact icons but can't find them.

Any ideas/suggestions?

Thanks
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
2016 icons are in C:\Program Files (x86)\Microsoft Office\root\Office16\FORMS\1033 (if you have 32-bit office, which most people do). Some of the newer images are not in the ico files, they are compiled into dlls. You could extract and save them as ico's to use in the form.

Extracting Icons from Windows files - @Poremsky.com
 
Top