Mail Merge - Insert Address Block - Insert Country

  • Thread starter VistaNewbie
  • Start date Views 2,561
Status
Not open for further replies.
V

VistaNewbie

I cannot get Outlook to insert the Country on my mailing labels. I have

many labels with addresses in Ireland, Australia, Canada, Spain, etc. I am

using Outlook Contacts as the source for my labels and I have verified that

the address fields in Outlook are correctly populated with the countries

properly selected from the drop menu in the Country/Region Check Address box

in Contacts.

When setting up my labels, I am using the Insert Address Block box. I have

tried the default option for the radio button: Only include the

country/region if different then: United States and the option to Always

include the country/region. Neither produces a label with the country.

What do I need to do to get this option to work?
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
don't use the address block - use the individual fields.

"VistaNewbie" <wpla@hotmail.com> wrote in message

news:5D0EB1AF-9D29-4118-A8CE-A21249D1A914@microsoft.com...
> I cannot get Outlook to insert the Country on my mailing labels. I have
> many labels with addresses in Ireland, Australia, Canada, Spain, etc. I
> am using Outlook Contacts as the source for my labels and I have verified
> that the address fields in Outlook are correctly populated with the
> countries properly selected from the drop menu in the Country/Region Check
> Address box in Contacts.

> When setting up my labels, I am using the Insert Address Block box. I
> have tried the default option for the radio button: Only include the
> country/region if different then: United States and the option to Always
> include the country/region. Neither produces a label with the country.

> What do I need to do to get this option to work?

>
 
V

VistaNewbie

I changed my labels to use the individual fields, as shown below:

«Courtesy Title» «First Name» «Middle Name» «Last Name»

«Address 1»

«Address 2»

«City», «State» «Postal Code»

«Country or Region»

The country still does not propagate to the label.

Also, the reason I was using the Address Block is that it ignores missing

fields, e.g. in the above layout, the label for "Jane Smith" displays as "

Jane Smith". It has an extra space before the first name (for the missing

Courtesy Title) and an extra space between the first and last name (for the

missing Middle Name).

The extra spaces for every contact with no middle name makes the labels and

form letters look unprofessional.

"Diane Poremsky [MVP]" <outlookmvp@msn.com> wrote in message

news:1695E207-E1EC-4603-9E24-A5E24C219BF8@microsoft.com...
> don't use the address block - use the individual fields.

> >

> >

>

> >

> "VistaNewbie" <wpla@hotmail.com> wrote in message
> news:5D0EB1AF-9D29-4118-A8CE-A21249D1A914@microsoft.com...
> > I cannot get Outlook to insert the Country on my mailing labels. I have
> > many labels with addresses in Ireland, Australia, Canada, Spain, etc. I
> > am using Outlook Contacts as the source for my labels and I have verified
> > that the address fields in Outlook are correctly populated with the
> > countries properly selected from the drop menu in the Country/Region
> > Check Address box in Contacts.
>

>> When setting up my labels, I am using the Insert Address Block box. I
> > have tried the default option for the radio button: Only include the
> > country/region if different then: United States and the option to Always
> > include the country/region. Neither produces a label with the country.
>

>> What do I need to do to get this option to work?
>

>>
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
You can use If statements to get rid of the spaces - but the country should

populate if it exists in the contact.

Are you starting the merge from outlook or word?

"VistaNewbie" <wpla@hotmail.com> wrote in message

news:BBC799B7-C4A0-4D56-826E-47C65B3C19CD@microsoft.com...
> I changed my labels to use the individual fields, as shown below:

> «Courtesy Title» «First Name» «Middle Name» «Last Name»
> «Address 1»
> «Address 2»
> «City», «State» «Postal Code»
> «Country or Region»

> The country still does not propagate to the label.

> Also, the reason I was using the Address Block is that it ignores missing
> fields, e.g. in the above layout, the label for "Jane Smith" displays as "
> Jane Smith". It has an extra space before the first name (for the
> missing Courtesy Title) and an extra space between the first and last name
> (for the missing Middle Name).

> The extra spaces for every contact with no middle name makes the labels
> and form letters look unprofessional.

> "Diane Poremsky [MVP]" <outlookmvp@msn.com> wrote in message
> news:1695E207-E1EC-4603-9E24-A5E24C219BF8@microsoft.com...
> > don't use the address block - use the individual fields.
>

>> > >

>

>> >

>>

>

>>

>

>> > >

>

>
>> "VistaNewbie" <wpla@hotmail.com> wrote in message
> > news:5D0EB1AF-9D29-4118-A8CE-A21249D1A914@microsoft.com...
> >> I cannot get Outlook to insert the Country on my mailing labels. I have
> >> many labels with addresses in Ireland, Australia, Canada, Spain, etc. I
> >> am using Outlook Contacts as the source for my labels and I have
> >> verified that the address fields in Outlook are correctly populated with
> >> the countries properly selected from the drop menu in the Country/Region
> >> Check Address box in Contacts.
> >
>>> When setting up my labels, I am using the Insert Address Block box. I
> >> have tried the default option for the radio button: Only include the
> >> country/region if different then: United States and the option to Always
> >> include the country/region. Neither produces a label with the country.
> >
>>> What do I need to do to get this option to work?
> >
>>>
 
V

VistaNewbie

I will look into the use of the IF statements.

As I mentioned in my original post, every Contacts record in Outlook has the

country in it. The US contacts default to United States of America. The

others have specific country names, e.g. Ireland, France, etc.

Yes, I start the Mail Merge from Outlook.

After changing the layout to use the individual fields, as indicated in my

reply to your post, I expected to see the country for all the contacts,

including the US addresses but none display.

"Diane Poremsky [MVP]" <outlookmvp@msn.com> wrote in message

news:184D6883-2FC8-49AC-8B33-8CEEAC2328CA@microsoft.com...
> You can use If statements to get rid of the spaces - but the country
> should populate if it exists in the contact.

> Are you starting the merge from outlook or word?

> >



> "VistaNewbie" <wpla@hotmail.com> wrote in message
> news:BBC799B7-C4A0-4D56-826E-47C65B3C19CD@microsoft.com...
> > I changed my labels to use the individual fields, as shown below:
>

>> «Courtesy Title» «First Name» «Middle Name» «Last Name»
> > «Address 1»
> > «Address 2»
> > «City», «State» «Postal Code»
> > «Country or Region»
>

>> The country still does not propagate to the label.
>

>> Also, the reason I was using the Address Block is that it ignores missing
> > fields, e.g. in the above layout, the label for "Jane Smith" displays as
> > " Jane Smith". It has an extra space before the first name (for the
> > missing Courtesy Title) and an extra space between the first and last
> > name (for the missing Middle Name).
>

>> The extra spaces for every contact with no middle name makes the labels
> > and form letters look unprofessional.
>

>> "Diane Poremsky [MVP]" <outlookmvp@msn.com> wrote in message
> > news:1695E207-E1EC-4603-9E24-A5E24C219BF8@microsoft.com...
> >> don't use the address block - use the individual fields.
> >
>>> > >>

> >
>>> > >
>>>

> >>
>>>

> >>
>>> > >>

> >
>>
>>> "VistaNewbie" <wpla@hotmail.com> wrote in message
> >> news:5D0EB1AF-9D29-4118-A8CE-A21249D1A914@microsoft.com...
> >>> I cannot get Outlook to insert the Country on my mailing labels. I
> >>> have many labels with addresses in Ireland, Australia, Canada, Spain,
> >>> etc. I am using Outlook Contacts as the source for my labels and I
> >>> have verified that the address fields in Outlook are correctly
> >>> populated with the countries properly selected from the drop menu in
> >>> the Country/Region Check Address box in Contacts.
> >>
>>>> When setting up my labels, I am using the Insert Address Block box. I
> >>> have tried the default option for the radio button: Only include the
> >>> country/region if different then: United States and the option to
> >>> Always include the country/region. Neither produces a label with the
> >>> country.
> >>
>>>> What do I need to do to get this option to work?
> >>
>>>>
 
Status
Not open for further replies.
Top