Hyperlink opens to IE home page rather than actual link

  • Thread starter lisansaunders
  • Start date Views 3,440
L

lisansaunders

Affecting Outlook 2003, Windows XP SP3: Several users are attempting to

follow a link embedded in Outlook. After clicking the link, they are

prompted to "Locate link browser". They can browse to the IE executable

without problems. If they try to follow the link again, IE will open to

their home page, but not to the link itself. Further, if they hover over the

link it states "blocked::yadayadayada" Any ideas?
 
V

VanguardLH

lisansaunders wrote:


> Affecting Outlook 2003, Windows XP SP3: Several users are attempting to
> follow a link embedded in Outlook. After clicking the link, they are
> prompted to "Locate link browser". They can browse to the IE executable
> without problems. If they try to follow the link again, IE will open to
> their home page, but not to the link itself.


From a Google search:

http://www.google.com/search?q=%2B"internet+explorer"+%2Bfirefox+%2B"locate+link+browser"

Do you have Firefox installed? Read:

http://www.howtogeek.com/howto/windows/troubleshooting-prevent-locate-link-browser-popup-dialog-when-clicking-on-links-in-outlook/


> Further, if they hover over the
> link it states "blocked::yadayadayada" Any ideas?


Different symptom. Perhaps the e-mail is in your Junk folder where links

get disabled because they're unlikely to be safe considering why the e-mail

got junked. Have you tried moving the e-mail out of the Junk folder and

into another email-type folder (Inbox or another email folder you create)?

Or perhaps the sender pasted the link from somewhere else rather than enter

their own hyperlink text. Try the following:

- Copy the URL string from the e-mail and paste into the address bar in

the web browser and edit out the "blocked:" prefix.

- See if viewing the HTML-formatted e-mail in the Internet security zone

eliminates the problem (View -> View in Internet Zone).

*WARNING: Be aware that you will be viewing that HTML-formatted e-mail

with far less restrictions which means you are more

vulnerable to its content.

Also see: http://www.slipstick.com/mail1/blocked.htm
 
L

lisansaunders

Hi Vanguard,

Firefox is not installed, users are on IE only. The email is not in the

Junk folder and is sitting in the Inbox. The hyperlink was auto-generated

from one of our internal systems. The hyperlink says "Click here to view the

Work Ticket details", with "Click Here" as the hyperlink. When you hover

over that, it shows "blocked::yadayadayada". As such, I cannot copy the link

from the email straight into a browser. I have also already tried to view

the email in the Internet Security Zone with the same results. Every time I

click on the link, it goes straight to the user's IE home page.

Interestingly enough, Outlook 2007 and 2010 users can follow the link

without problems; it opens right to the webpage. Hovering over the link

shows the website with a nice little "click to follow link" message.

Thanks.

"VanguardLH" wrote:


> lisansaunders wrote:
>
> > Affecting Outlook 2003, Windows XP SP3: Several users are attempting to
> > follow a link embedded in Outlook. After clicking the link, they are
> > prompted to "Locate link browser". They can browse to the IE executable
> > without problems. If they try to follow the link again, IE will open to
> > their home page, but not to the link itself.


> From a Google search:
> http://www.google.com/search?q=%2B"internet+explorer"+%2Bfirefox+%2B"locate+link+browser"

> Do you have Firefox installed? Read:
> http://www.howtogeek.com/howto/windows/troubleshooting-prevent-locate-link-browser-popup-dialog-when-clicking-on-links-in-outlook/
>
> > Further, if they hover over the
> > link it states "blocked::yadayadayada" Any ideas?


> Different symptom. Perhaps the e-mail is in your Junk folder where links
> get disabled because they're unlikely to be safe considering why the e-mail
> got junked. Have you tried moving the e-mail out of the Junk folder and
> into another email-type folder (Inbox or another email folder you create)?

> Or perhaps the sender pasted the link from somewhere else rather than enter
> their own hyperlink text. Try the following:

> - Copy the URL string from the e-mail and paste into the address bar in
> the web browser and edit out the "blocked:" prefix.

> - See if viewing the HTML-formatted e-mail in the Internet security zone
> eliminates the problem (View -> View in Internet Zone).
> *WARNING: Be aware that you will be viewing that HTML-formatted e-mail
> with far less restrictions which means you are more
> vulnerable to its content.

> Also see: http://www.slipstick.com/mail1/blocked.htm
> .
>
 
L

lisansaunders

Hi Brian,

I tried every option listed on that page, all to no avail. The link still

opens to IE's home page rather than the actual site.

Thanks.

"" wrote:


> "lisansaunders" <lisansaunders> wrote in message
> news:8B69DA49-D906-4AE4-BC1C-ED7FC9CC48F9@microsoft.com...
>
> > When you hover over that, it shows "blocked::yadayadayada".


> See if this helps: http://www.slipstick.com/mail1/blocked.htm
> >

> .
>
 
V

VanguardLH

lisansaunders wrote:


> I tried every option listed on that page, all to no avail. The link still
> opens to IE's home page rather than the actual site.


Then it sounds like the DDE transfer of the parameter specifying the URL is

not getting transferred. First see if using Internet Options -> Advanced

tab -> Reset gets IE working again for URL links inside of e-mails.

If that doesn't help, go to Folder Options -> File Types

(NONE) URL: HyperText Transfer Protocol

If the Change button is enabled then something else inserted itself as the

URL scheme handler at some time. See if you can change back to the

defaults; otherwise, go under Advanced and check the following settings to

edit the action(s):

Action:

Open

Application used to perform action:

"C:\Program Files\Internet Explorer\IEXPLORE.EXE" -nohome

Use DDE:

Enabled

DDE Message:

"%1",,-1,0,,,,

Application:

IExplore

DDE Application Not Running:

(blank)

Topic:

WWW_OpenURL

The open action will result in opening IE with no home page. You're

interested in how the DDE association is defined to have IE used as the

handler for the URL HTTP scheme. If, for example, the %1 was missing from

the DDE message passed from the client (e-mail program) to the server (IE)

then the server will load but have no parameter specifying what URL to load.

The %1 replaceable parameter would be the value of the URL string on which

you clicked in the e-mail.
 
L

lisansaunders

Hi Vanguard,

I have reset IE to the defaults, did not fix the problem.

I have also gone the route of changing the File Type info; the Change button

has been greyed out, so I cannot change what program to open with, and I have

confirmed that all of the advanced settings are the same as you previously

outlined. Sadly, this did not fix the problem either.

Thanks!

Lisa

"VanguardLH" wrote:


> lisansaunders wrote:
>
> > I tried every option listed on that page, all to no avail. The link still
> > opens to IE's home page rather than the actual site.


> Then it sounds like the DDE transfer of the parameter specifying the URL is
> not getting transferred. First see if using Internet Options -> Advanced
> tab -> Reset gets IE working again for URL links inside of e-mails.

> If that doesn't help, go to Folder Options -> File Types
> (NONE) URL: HyperText Transfer Protocol

> If the Change button is enabled then something else inserted itself as the
> URL scheme handler at some time. See if you can change back to the
> defaults; otherwise, go under Advanced and check the following settings to
> edit the action(s):

> Action:
> Open
> Application used to perform action:
> "C:\Program Files\Internet Explorer\IEXPLORE.EXE" -nohome
> Use DDE:
> Enabled
> DDE Message:
> "%1",,-1,0,,,,
> Application:
> IExplore
> DDE Application Not Running:
> (blank)
> Topic:
> WWW_OpenURL

> The open action will result in opening IE with no home page. You're
> interested in how the DDE association is defined to have IE used as the
> handler for the URL HTTP scheme. If, for example, the %1 was missing from
> the DDE message passed from the client (e-mail program) to the server (IE)
> then the server will load but have no parameter specifying what URL to load.
> The %1 replaceable parameter would be the value of the URL string on which
> you clicked in the e-mail.
> .
>
 
V

VanguardLH

lisansaunders wrote:


> I have reset IE to the defaults, did not fix the problem.

> I have also gone the route of changing the File Type info; the Change button
> has been greyed out, so I cannot change what program to open with, and I have
> confirmed that all of the advanced settings are the same as you previously
> outlined. Sadly, this did not fix the problem either.


Have you tried rebooting into Windows' Safe Mode (with networking) and

retest URL links in e-mails to see if that web page opens in IE? You might

have security software that is interferring with the use of IE.
 
L

lisansaunders

Rebooting to Safe Mode w/ Networking does not resolve the problem. Hovering

over the link still shows "blocked::yadayadayada", and click the link still

takes me to my home page.

"VanguardLH" wrote:


> Have you tried rebooting into Windows' Safe Mode (with networking) and
> retest URL links in e-mails to see if that web page opens in IE? You might
> have security software that is interferring with the use of IE.
> .
>
 

Top