Can't search emails in Outlook 2010

  • Thread starter BillyQ63
  • Start date Views 11,314
Status
Not open for further replies.
B

BillyQ63

Outlook does not give me any answers when I search for emails. it just tells me " No matches found for"

I have tried to re build the index, but it does not seem to do it.

However, Outlook does tell me perfectly unread emails, etc, whcih I guess are also searches.
 
R

Ruchi Bisht

Try the steps mentioned below:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows.

1) Press the Windows Key + R on your keyboard, and type “REGEDIT”. This will open the Windows Registry Editor.

2) Browse to the following: " HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search"

3) You will manually have to reset the value of “Prevent Indexing Outlook” to “0” (without the quotes). To do this, right click on the “Prevent Indexing Outlook” key, select “Modify…”, then change the value data to “0”.

4) Close the registry editor.

For more information on this check the link given below:

http://blogs.msdn.com/outlook/archive/2009/06/17/google-apps-sync-disables-outlook-search.aspx

Ruchi Bisht, Microsoft Answers Support Engineer.
• We appreciate your participation in MS Forums, Help us understand your needs better. To share your valuable Feedback please Click here.
 
B

BillyQ63

Thanks Ruchi,

I followed your instructions, but I do not have a " Windows Search" on the Registry. I followed " HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search" .

at " Windows\" , it has items such as CurrentVersion, IPSec, Network Connections, etc.

any ideas?

thanks very much by the way!!!
 
G

Guruprasad Ra

Open Outlook click on File > Options > Search > Indexing options > Modify > Uncheck Outlook

Click on OK then close and restart Outlook to check if search results fetch correctly.

Guruprasad Ra, Microsoft Answers Support Engineer.
• We appreciate your participation in MS Forums, Help us understand your needs better. To share your valuable Feedback please Click here.
 
T

Tracul

I have the exact same problem. It was working fine until I resintalled Outlook 2010. BTW: I don't see anyplace to " Uncheck Outlook"
 
B

Ben M. Schorr [MVP]

I have the exact same problem. It was working fine until I resintalled Outlook 2010. BTW: I don't see anyplace to " Uncheck Outlook"

Did you go to File | Options | Search | Indexing Options | Modify?

 
T

Tracul

I followed your instructions, but I do not have a " Windows Search" on the Registry either.
 
G

Gil11

Hi, i installed office 2010 last week. Great stuff but i use the social connector a lot because all mails of that contact are easy to find. But now for some people i don't have all te mail and just have te notice: There are no items to show in this view! Normally there are 80 mails that should be in there. Can someone help me.

The Windows Search is installed and works fine.
 
E

Eriq07

I have the exact same problem. It was working fine until I resintalled Outlook 2010. BTW: I don't see anyplace to " Uncheck Outlook"

Did you go to File | Options | Search | Indexing Options | Modify?

I also have this problem. No option to " uncheck" Outlook. It's just shown, but I have no ability to right-click on it and unselect, or see a checkbox next to it. I have been troubleshooting this issue for months now and it's driving me crazy.
 
M

MassachusettsSean

An I also have this problem describe by the previous reply. There is no option to uncheck Outlook. We've been evaluating the product for our organizational deployment. I am about ready to give up on Outlook 2010 and recommend that my organization do the same. Could someone at Microsoft PLEASE document the solution (if there is one) and publish a kbase article? This is EXTREMELY FRUSTRATING.
 
L

Loukas nr1

same problem here

There is no option to uncheck Outlook

this kind of bugs is unaceptable

if you want us to propose this garbage to our customers please provide an adequate solution
 
M

MassachusettsSean

Ok - I can search now. None of the above solutions worked for me. Here's what i did. I don't if this is really related so this might not work for you.

I noticed that there were 2 versions of the office beta installed on my machine. I had upgraded from Office 2007 Premium Pro, but to a lesser version. Looking at installed programs both the lesser (sorry, I don't remember which - maybe the student version) - and the Premium Pro beta of Office 2010 were installed - the version numbers were different.

I uninstalled both of them, then reinstalled just the Premium Pro version. The dialog box is now different, now i CAN uncheck outlook - this was not possible before. Now when I press Modify on the Indexing Options dialog I get a Indexed Locations dialog that let's me select or deselect Outlook or specific accounts/data files I've set up in Outlook.

I'm wondering if Search was somehow reduced in functionality in some of the lesser versions of Office (just speculation on my part).

After removing and reinstalling I was able to rebuild the index in the 2010 Premium Pro version - at least that part is working. I have not installed the released version yet, although will soon, so I can't say if there's a difference between the beta and the released version in this regard.

Good luck - I know I was pretty frustrated and there was no help or interest in providing real help out there for a problem that multiple people are experiencing.
 
C

chasmcg

I can't search my emails with Outlook 2010 (Windows 7 Ultimate 64 bit). I need to search the body. None on the 'fixes' listed above even apply to me. The stuff you're telling me to do doesn't even exist in Outlook or the Registry. I would like this fixed. I am frustrated to no end. It's ridiculous.
 
E

Eriq07

Will someone (BillyQ63) please UNMARK Guruprasad Ra <abbr class=" affil" /> 's answer as the resolution??? His response does NOT work for many of us as we cannot " uncheck" Outlook from the Indexing Options CP. The checkbox does NOT appear.

With this question being marked as " answered" I would guess that Microsoft support team is not paying attention to this anymore.

Still waiting for resolution. Highly frustrated by this issue and no one seems to have a working answer.

The only work around I've found is to disable Windows Search ENTIRELY (resulting in missing search box in the Start Menu as well).With Windows Search disabled entirely, I can search for emails in Outlook because it uses the older/slow method of search instead of Windows instant search. It takes a while for search results to appear but at least they appear nonetheless. It's just frustrating that I have to sacrifice the ability to search for everything else outside of Outlook in exchange for the ability to search for stuff inside outlook.

Go figure.....
 
C

chasmcg

My search seems to be working again. I never use Outlook search for anything except searching bodies of email.

I went to Control Panel. Programs and features. Highlighted Microsoft Office Professional Plus 2010. Clicked Change at the top. And did a Repair.

Mine is currently working. HTH.
 
E

Eriq07

Well unfortunately someone needs to start a brand new thread concerning this same problem I guess. There are other unresolved threads where the actions you suggested aren't doing anything--in fact they can't even be performed because either the registry keys aren't available or the checkbox is missing. I've tried a repair at least 5 or 6 times and uninstalled/reinstalled more times than that. Rebuilding the index never fixed it also.
 
Status
Not open for further replies.
Top