Hyperlinks blocked in outlook

Status
Not open for further replies.
A

abraxastv



Hi Guys,

I am currently using microsoft office 10 beta, when ever I receive an email with links and I try to view that link, I'm block and asked to see the administrator, (thats me) I have gone through the settings and allowed everthing I can find that would block hyperlink in messages, I just can find the correct setting to allow me to operate outlook correctly, there are also some things that are blocked in word which stop me preforming certain operations, can anyone help me with this matter, gb
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange


This is a problem with IE, its not an Outlook error. You need to reset your internet settings in IE's Tools, Internet Options, Advanced tab. (Or Control panel, Internet options, Advanced tab).

See http://slipstick.me/restrict for the latest information.
 
A

abraxastv

Hi Diane, Yes have tried that and also making Microsoft the default program... still comes up with the same Admin warning... I'm using Vista Ultimate...
 
F

F-O-F



Hi,

1)open Notepad

2) copy the below code and paste in the notepad:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.htm]
"PerceivedType"="text"
@="htmlfile"
"Content Type"="text/html"

[HKEY_CLASSES_ROOT\.htm\OpenWithList]

[HKEY_CLASSES_ROOT\.htm\OpenWithList\notepad.exe]

[HKEY_CLASSES_ROOT\.htm\OpenWithList\WINWORD.EXE]

[HKEY_CLASSES_ROOT\.htm\PersistentHandler]
@="{eec97550-47a9-11cf-b952-00aa0051fe20}"

[HKEY_CLASSES_ROOT\.html]
"PerceivedType"="text"
@="htmlfile"
"Content Type"="text/html"

[HKEY_CLASSES_ROOT\.html\PersistentHandler]
@="{eec97550-47a9-11cf-b952-00aa0051fe20}"

[HKEY_CLASSES_ROOT\htmlfile]
@="HTML Document"

[HKEY_CLASSES_ROOT\htmlfile\BrowseInPlace]
@=""

[HKEY_CLASSES_ROOT\htmlfile\CLSID]
@="{25336920-03F9-11cf-8FD0-00AA00686F13}"

[HKEY_CLASSES_ROOT\htmlfile\DefaultIcon]
@="\"%1\""

[HKEY_CLASSES_ROOT\htmlfile\ScriptHostEncode]
@="{0CF774D0-F077-11D1-B1BC-00C04F86C324}"

[HKEY_CLASSES_ROOT\htmlfile\shell]
@="opennew"

[HKEY_CLASSES_ROOT\htmlfile\shell\Edit]
@="&Edit"

[HKEY_CLASSES_ROOT\htmlfile\shell\Edit\command]
@="\"C:\\Program Files\\Microsoft Office\\Office10\\msohtmed.exe\" %1"

[HKEY_CLASSES_ROOT\htmlfile\shell\open]
@="Open in S&ame Window"

[HKEY_CLASSES_ROOT\htmlfile\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"

[HKEY_CLASSES_ROOT\htmlfile\shell\open\ddeexec]
@="\"file://%1\",,-1,,,,,"
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\htmlfile\shell\open\ddeexec\Application]
@="IExplore"

[HKEY_CLASSES_ROOT\htmlfile\shell\open\ddeexec\Topic]
@="WWW_OpenURL"

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew]
@="&Open"

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" %1"

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\ddeexec]
@="\"%1\",,-1,0,,,,"
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\ddeexec\Application]
@="IExplore"

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\ddeexec\IfExec]
@="*"

[HKEY_CLASSES_ROOT\htmlfile\shell\opennew\ddeexec\Topic]
@="WWW_OpenURLNewWindow"

[HKEY_CLASSES_ROOT\htmlfile\shell\Print]
@="&Print"

[HKEY_CLASSES_ROOT\htmlfile\shell\Print\command]
@="\"C:\\Program Files\\Microsoft Office\\Office10\\msohtmed.exe\" /p %1"

[HKEY_CLASSES_ROOT\htmlfile\shell\printto]

[HKEY_CLASSES_ROOT\htmlfile\shell\printto\command]
@=hex(2):72,00,75,00,6e,00,64,00,6c,00,6c,00,33,00,32,00,2e,00,65,00,78,00,65,\
00,20,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,\
25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,73,\
00,68,00,74,00,6d,00,6c,00,2e,00,64,00,6c,00,6c,00,2c,00,50,00,72,00,69,00,\
6e,00,74,00,48,00,54,00,4d,00,4c,00,20,00,22,00,25,00,31,00,22,00,20,00,22,\
00,25,00,32,00,22,00,20,00,22,00,25,00,33,00,22,00,20,00,22,00,25,00,34,00,\
22,00,00,00

[HKEY_CLASSES_ROOT\htmlfile\ShellEx]

[HKEY_CLASSES_ROOT\htmlfile\ShellEx\IconHandler]
@="{42042206-2D85-11D3-8CFF-005004838597}"

3) Click on File Tab in notepad> save as> select save as type as "All Files" > type file name as hyperlinkfix.reg and save it on your Desktop

4) close notepad and go to desktop and double click on the hyperlinkfix.reg and add the registry key to the registry

Try to open the hyperlinks in Outlook.
 
1

123HelpMe123

I tried this and this is what my computer is now saying...Cannot import. The specified file is not a registry script.
 
A

Accipitral



I had the same problem with Outlook 2003 on Vista. All hyperlinks blocked.

I tried user account control on and off

I tried resetting my internet settings in IE's Tools, Internet Options, Advanced tab. (Or Control panel, Internet options, Advanced tab

I tried F-O-F's script and got the same response as 123helpMe123.

I succeeded after

Retrying in a different text editor (Author) Removing extra line breaks and spaces from the beginning and end of the scriptRe-saving the hyperlinkfix.reg file and double clicking it Restarting Outlook
 
D

D51



Accipitral

Could you possibly paste the corrected version in here please so that you can help everyone else.

Thanks in advance
 
A

abraxastv



Hi All,

I was sent this info by MS and it fixed the issue, I checked all these points and I know the one that worked for me was step 1, the reason this issue normally happens if you have installed and then uninstalled a 3rd party web browser such as Mozilla Firefox, Google Chrome, Apple Safari or Opera.
Below are four steps which may be able to resolve the issue, the first step was the one causing my problems:-

STEP 1: SET INTERNET EXPLORER AS DEFAULT WEB BROWSER

a. Click on the Start button > Default Programs

b. Click on Set your default programs

c. On the left panel, select Internet Explorer

d. Click on Set this program as default

e. Click on Ok

STEP 2: CHECK PROTOCOL ASSOCIATION

a. Click on the Start button > Default Program

b. Click on Associate a file type or protocol with a program

c. Scroll to the bottom of the page and look for the HTTP and HTTPS protocols

d. If Internet Explorer is not the default application for these two protocols, click on the Change program button

e. Click on Close

STEP 3: RESET INTERNET EXPLORER SETTINGS

a. Click on the Start button > Control Panel

b. Switch to Classic View

c. Double-click on Internet Options

d. Go to the Advanced tab

e. Click on Reset > Reset > Close

f. Launch Internet Explorer and complete the setup

STEP 4: CHECK WINDOWS REGISTRY

a. Click on the Start button > All Programs > Accessories > Run

b. Type regedit > Click on Ok

c. Navigate to HKEY_CLASSES_ROOT\.htm

d. With .htm highlighted, look on the right panel and double-click on Default

e. Make sure the value data is htmlfile and click on Ok

f. Navigate to HKEY_CLASSES_ROOT\.html

g. With .html highlighted, look on the right panel and double-click on Default

h. Make sure the value data is htmlfile and click on Ok

i. Navigate to HKEY_LOCAL_MACHINE\Software\Classes\.htm

j. With .htm highlighted, look on the right panel and double-click on Default

k. Make sure the value data is htmlfile and click on Ok

l. Navigate to HKEY_LOCAL_MACHINE\Software\Classes\.html

m. With .html highlighted, look on the right panel and double-click on Default

n. Make sure the value data is htmlfile and click on Ok

o. Exit Registry Editor and restart the computer

I trust this will help you all, I know how annoying this can be... cheers, gb
 
Status
Not open for further replies.
Top