Problem with restore-mailbox command on Exchange2010 RC

  • Thread starter Lasse Ingwersen
  • Start date Views 595
Status
Not open for further replies.
L

Lasse Ingwersen

Hi,
First, Exchange2010 is GREAT, looking forward to RTM :)

I can restore a mailbox, using a recovery Database, and merging into the same mailbox, using this command:

Restore-Mailbox -Identity test-lvi -RecoveryDatabase recoverDB2

StatusMessage                    : This mailbox in the recovery database has been restored to the target user mailbox.

But, if I want to recover to a subfolder to the same or another mailbox, it does not work.
Trying with this command:

[PS] D:\recover2\D_\Database>Restore-Mailbox -Identity test-lvi -RecoveryDatabase recoverDB2 -RecoveryMailbox "test-lvi" -TargetFolder restored

Mailbox "test-lvi" doesn't exist on database "recoverDB2".

    + CategoryInfo          : NotSpecified: (0:Int32) [Restore-Mailbox], ManagementObjectNotFoundException

    + FullyQualifiedErrorId : D282D54D,Microsoft.Exchange.Management.RecipientTasks.RestoreMailbox


Is it me doing somethin wrong, or is there a bug?

Regards
Lasse

 
 
A

Amit Tank [MVP]

Do you get the same error when you try to restore the data into a folder of another mailbox? Can you try it?

Like, restoring John's mailbox content into Scott's mailbox under the Recovery folder.

Restore-Mailbox -Identity Scott -RecoveryDatabase RecoverDB2 -RecoveryMailbox John -TargetFolder Restored

Amit Tank | MVP " Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com
 
L

Lasse Ingwersen

Hi Amit,

Thanks for the quick response.

Yes, same error if I try to restore to another account.

Regards
Lasse
 
Status
Not open for further replies.
Top