Exchange Management Console - Initializtion failed on Logon Failure: unknown username or bad passwor

Status
Not open for further replies.
L

Leo2308

Installed Exchange 2010 RC1 on a new 2008 server last week (just got it, not used for anything yet just testing stuff so far). All was running smoothly until the EMC decided not to allow me access to view 'Organisation Configuration', telling me I don't have sufficient permission to view this data.
I posted a message here and I was instructed to add administrator account into Organization Management and Server Management, which I tried and this did not solve the problem. Soon afterwards (after trying some member/permission settings within Microsoft Exchange Security Groups...) I managed to somehow break it further :-(
Now when launching EMC, I get:
The following error occurred when searching for On-Premesis Exchange server:
[" servername.domian" ] Connecting to remote server failed with the following error message : Logon failure: unknown username or bad password. It was running the command 'Discover-ExchangeServer -UseWIA $true -SuppressError $true
I am logged into the server with the same administrator account used for installing everything.
I pretty much gave up trying to resolve the issue and was ready to re-install Exchange 2010 from scratch, however when trying to, I am unable to uninstall it as it produces an error in the readiness checks under hub transport role prerequisites:
Setup encountered a problem while validating the state of Active Directory: Active Directory operation failed on " Servername.domian" . The supplied credential for " Domain\Administrator" on Bind operation is invalid. Error Code: 0x31.
This is most likely related, and is probably something really simple...if its possible to salvage this installation of Exchange that would be great, but I dont mind re-installing it (if I could!) any help/ideas would be appreciated.
At the moment I am unable to do much other than re-install Windows Server 2008, which is something I really want to avoid.
Thanks
 
J

Joel Gallay

Have you tried using the RunAs in 2008 this is usually the problem. Right mouse click on the Exchange Management Console program choice and use the RunAs to start the Console with Administrator privilages.
 
B

Brian Day MCITP [MVP]

You have to hold down shift then right-click to get the Run As. On R2 you also have to start the " Secondary Logon Credentials" service, which I think is off by default to be able to use RunAs.Brian Day / MCSA / CCNA, Exchange/AD geek.
 
L

Leo2308

Yep I've tried these, unfortunately I still get the same errors.
I've given up and am re-installing Exchange after having deleted the program files Exchange folder.., and removed Exchange registry entries.
Thanks for the help anyway.
 

James Chikanga

New Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server 2010
Log onto the Exchange Server, go to Control Panel, Credential Manager, Windows Vault, Remove All Accounts from Windows Credentials
 
Status
Not open for further replies.
Top