Exchange 2010 & Apple Mail / iPhone Mail via IMAP - Server Unavailable

  • Thread starter Sam Bacsa
  • Start date Views 698
S

Sam Bacsa

OK so I have a really weird issue.  I've set up a test environment for Exchange 2010 RC in order to test upgrade and operability with our current Exchange 2007 platform, and I encountered an interesting issue with the IMAP service when utilizing Apple Mail (via OS X) or the mail app in iPhone.

What happens is, on a freshly-started IMAP service, both Apple Mail and iPhone Mail connect and begin downloading messages.  They make quite a few connections (about a dozen), but I set up the connection limit to 200 per user to combat this.  After less than ten seconds, they both are greeted with the server message "Server unavailable. 15" and then can no longer connect or authenticate with the server.

This does not happen if I use a non-Apple client, like Mozilla Thunderbird (both in OS X and on Windows), or Outlook.

Even stranger is, it appears to actually lock out that account, which means that if I try to access the account after it receives the "Server unavailable" message, even from Thunderbird or Outlook (or even Telnet), I get the same error and cannot proceed.

Other accounts continue to work fine through IMAP.

On top of that, if the same locked-out account is accessed through Web App or Outlook Exchange, it successfully authenticates and works.

Once the IMAP server is restarted, things work fine once again, until the same action is performed (syncing via Apple Mail or iPhone Mail).  Rinse, repeat.

So, my conclusion is that because of the huge amount of connections being created by Apple Mail/iPhone Mail, the IMAP server is locking out access to that user account (at least temporarily, but I've not been able to test whether or not it is temporary).  I've looked at all the possible configuration settings, including the ImapService.config file, and tried tweaking various settings, but nothing as succeeded thus far.  I set max connections to 200, max command size to 16k (the limit), throttle timeout to 0, etc., all of it to no avail.

So what I guess my question is: is this intended?  If it is, is there a config value I can alter to stop this?  Since a lot of people in our office use Mac Mail and iPhones (via IMAP, since some want to be able to access other Exchange servers instead), this would definitely be a showstopper in terms of upgrading to Exchange 2010.  I love the improvements in that platform, and I terribly want to do it, but this just needs to work.  I never had this problem in 2007.

Someone please advise :)

Thank you!

PS - If this turns out to be a bug, I'll be happy to file a bug report with the diagnostic information you need.  Please let me know where to, if this is the case!
 
R

robsiii-dotx

For what it's worth, I'm seeing *exactly* the same behavior on MacOS 10.5.x and 10.6.1 and of course, on iPhones.
 
S

Sam Bacsa

For what it's worth, I'm seeing *exactly* the same behavior on MacOS 10.5.x and 10.6.1 and of course, on iPhones. Well on one hand it's good to know I'm not alone, on the other hand it sucks this problem exists in the first place.

Hopefully someone can shed some insight on this in the next couple of days... otherwise, maybe it will be worthwhile for me to submit a bug report just in case... perhaps someone can point me in the right direction in that regard.  Something tells me this isn't the desired functionality of the IMAP server.
 
N

n808

Not that it's worth anything, but after they upgraded us to Exchange at my workplace, my IMAP access keep getting locked out. I am not an admin, and don't even know which exchange server they are running. However, the admin has no idea as to what the problem is and isn't showing any interest in resolving it either, since it appears I am the only one with the problem...

And I use only Thunderbird ... but the behavior is exactly as described in the first post. Once locked out, I can not access IMAP for hours (I don't know if they restart the Exchange server). I have tried manual login, fails, while POP3, Exchange and web access continues to work.

I will try to reduce the number of connections in Tbird, but it's set to only 5 (default, I think).
 

Top