Problems with WinRM and Exchange Server 2010

  • Thread starter shadowman123
  • Start date Views 1,366
S

shadowman123

Hello,
When I open up the Exchange Management Shell, I'm seeing these errors:
Welcome to the Exchange Management Shell!
Full list of cmdlets: get -command
Only Exchange cmdlets: get -excommand
Cmdlets for a specific role: get -help -role *UM* or *Mailbox*
Get general help: help
Get help for a cmdlet: help <cmdlet-name> or <cmdlet-name> -?
Show quick reference guide: quickref
Exchange team blog: get -exblog
Show full output for a cmd: <cmd> | format-list
Tip of the day #20:
Access the event log from the Exchange Management Shell. To retrieve the whole
vent log, run:
Get -EventLog Application | Format-List
To retrieve all Exchange-related events, run:
Get -EventLog Application | Where { $_.Source -Ilike "*Exchange*" }
VERBOSE: Connecting to
**** New -PSSession : [****] Connecting to remote server
failed with the following error message : The WinRM client sent a request to an
HTTP server and got a response saying the requested HTTP URL was not available
. This is usually returned by a HTTP server that does not support the WS-Manage
ment protocol.
At C:\Program Files\Microsoft\Exchange Server\V14\bin\ConnectFunctions.ps1:154
char :28
+ $global:r = new -pssession <<<< -connectionURI https://$fqdn/powershe
ll -ConfigurationName Microsoft.Exchange -Authentication NegotiateWithImplicitC
redential -SessionOption $sessionOption #-erroraction silentlycontinue
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:Re
moteRunspace) [New -PSSession], PSRemotingTransportException
+ FullyQualifiedErrorId : RemoteRunspaceOpenFailed
VERBOSE: Connecting to
**** New -PSSession : [win-gimug9rzzpf.van-brakel.local] Connecting to remote server
failed with the following error message : The WinRM client sent a request to an
HTTP server and got a response saying the requested HTTP URL was not available
. This is usually returned by a HTTP server that does not support the WS-Manage
ment protocol.
At C:\Program Files\Microsoft\Exchange Server\V14\bin\ConnectFunctions.ps1:154
char :28
+ $global:r = new -pssession <<<< -connectionURI https://$fqdn/powershe
ll -ConfigurationName Microsoft.Exchange -Authentication NegotiateWithImplicitC
redential -SessionOption $sessionOption #-erroraction silentlycontinue
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:Re
moteRunspace) [New -PSSession], PSRemotingTransportException
+ FullyQualifiedErrorId : RemoteRunspaceOpenFailed
VERBOSE: Connecting to ****New -PSSession : [****] Connecting to remote server
failed with the following error message : The WinRM client sent a request to an
HTTP server and got a response saying the requested HTTP URL was not available
. This is usually returned by a HTTP server that does not support the WS-Manage
ment protocol.
At C:\Program Files\Microsoft\Exchange Server\V14\bin\ConnectFunctions.ps1:154
char :28
+ $global:r = new -pssession <<<< -connectionURI https://$fqdn/powershe
ll -ConfigurationName Microsoft.Exchange -Authentication NegotiateWithImplicitC
redential -SessionOption $sessionOption #-erroraction silentlycontinue
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:Re
moteRunspace) [New -PSSession], PSRemotingTransportException
+ FullyQualifiedErrorId : RemoteRunspaceOpenFailed

**** = Confidential / Secret (hostnames)
This is my WinRM configuration:
Listener
Address = *
Transport = HTTP
Port = 80
Hostname
Enabled = true
URLPrefix = wsman
CertificateThumbprint
ListeningOn = 127.0.0.1, 192.168.1.125, ::1, fe80::100:7f:fffe%11, fe80::5ef
e:192.168.1.125%12, fe80::2db4:6f23:af15:c315%10
Listener
Address = *
Transport = HTTPS
Port = 443
Hostname = ****
Enabled = true
URLPrefix = wsman
CertificateThumbprint = ****
 ListeningOn = 127.0.0.1, 192.168.1.125, ::1, fe80::100:7f:fffe%11, fe80::5ef e:192.168.1.125%12, fe80::2db4:6f23:af15:c315%10
What is going wrong, and how do I fix this?
Certifications: MCSA 2003 MCSE 2003
 
S

shadowman123

I'm now seeing this error (I just installed the latest version as you suggested)
Picture

Any ideas how to fix this? Certifications: MCSA 2003 MCSE 2003
 
O

Omid Abdollahpour

Hi,
Are you running Exch 2010 on Windows Server 2008 R2?
In this case, could you please check if "WinRM IIS Extension" is installed or not?
Own experience, before an Exch 2010 installation, I also installed WinRM IIS Extension, but could not open Exchange 2010 management shell as you did even if I could open the OWA and logon with Administrator without any problem... Well, created a brand new lab environment and I DIDN'T install WinRM IIS Extension on Exchange server, it just worked fine...
If you are running Windows Server 2008, please check your IIS7 if Exchange created required Virtual Folders properly during the installation...

MCITP Windows Server 2008 Enterprise - MCITP Exchange Server 2007 - MCTS Windows Server Virtualization - MCTS System Center Virtual Machine Manager - MCTS Windows Vista Client
 
G

Garrett Lynch

Also ran into the same problem upgrading from RC to RTM.  Everything was perfect before the upgrade, WinRM IIS extensions were not installed, ran the upgrade, OWA broke, IIS broke, and EMC broke, installed WinRM IIS extensions with no success.  I took a look at the bindings as well as that's what broke the RC install and looked good too.

I also noticed that every Exchange 2010 service was disabled.  I re-enabled the services and started them up as well.

Running '08 R2.  Hopefully someone will throw an idea or two.

Garrett Lynch, Lynch Research Group, LLC.
 
O

ON-IT Consulting

Garrett saw the same issue as well. Escalated the case within PSS and am waiting for a callback.
At least I can receive mail for the moment, but cannot send at all. This is crazy
 
G

Garrett Lynch

Thanks for keeping me in the loop and I hope they can help resolve the issue.  Least you've got mail flowing in, mine turned over and died...Garrett Lynch, Lynch Research Group, LLC.
 
O

Omid Abdollahpour



I haven't tried to upgrade RC to RTM in place as you did, but personally I wouldn't do that either...

If you have the opportunity, start with a new server with clean installation, then install Exch 2010... After that, let the Exch 2010 synchronize mailboxes and than retire the old one...

MCITP Windows Server 2008 Enterprise - MCITP Exchange Server 2007 - MCTS Windows Server Virtualization - MCTS System Center Virtual Machine Manager - MCTS Windows Vista Client
 
O

ON-IT Consulting

Omid-
Apparently this is actually correct. Even though an in-place upgrade is an option for some reason, I just received a message from a Microsoft escalation engineer specializing in Setup. He stated that an in-place upgrade is not supported and that they're only recommended solution for moving from RC to RTM is to spin up a new RTM server and move all of the mailboxes/config over.
Very strange that this is the case since in-place upgrade is an option, very counter-intuitive
 
G

Garrett Lynch

I agree this is very strange as especially in that it was quoted that RC to RTM upgrade path was supported.  I ended up creating a new 2010 VM and running a recovery install and moving over the DB's, worked well and learned a little about 2010's recovery processes.Garrett Lynch, Lynch Research Group, LLC.
 
D

Duane A Purcell



I experienced these issues on a fresh install of RTM Exchange 2010 on Server 2008 R2.  The solution was to change bindings on default website to listen on "All Unassigned".  I had previously changed to specific IP addresses in anticipation for new Autodiscover web site on seperate IP address.
 
L

Lars Holte

Almost similar to Duane, i had a host header name set to a specific host on the default website. Removed this and the PS "The WinRM client sent a request to an
HTTP server and got a response saying the requested HTTP URL was not available." error was gone and could connect to the server correctly.
 
F

Fertje



This resolves the issue for me. similar thing after making the autodiscover changes...

Thank you.
 
D

donniemit

Did you add a host name in the Bindings? As soon as I did that I received the same errors, removed the custom host name from http in the bindings, it fixed it!
 
Top