New Exchange 2010 RTM installation error - Fails to extend Active Directory Schema

  • Thread starter MA-Admin
  • Start date Views 1,252
Status
Not open for further replies.
M

MA-Admin



I have a production domain with two Windows 2008 R2 domain controllers. Forest and Domain are at the Windows 2008 R2 level. Domain used to have Exchange 2007 running in it but e-mail was recently put on Exchange Online (BPOS). All Exchange servers were properly removed from the domain by a former administrator.

When trying to install the FIRST new Exchange 2010 RTM that was released  today - I get the following error message when trying to extend the schema attributes:

W:\>Setup/PrepareSchema

Welcome to Microsoft Exchange Server 2010 Unattended Setup

By continuing the installation process, you agree to the license terms of
Microsoft Exchange Server 2010. If you don't accept these license terms,
please cancel the installation. To review these license terms, please go to
http://go.microsoft.com/fwlink/?LinkId=150127&clcid=0x409/

Press any key to cancel setup................
No key presses were detected.  Setup will continue.
Preparing Exchange Setup

    Copying Setup Files              ......................... COMPLETED

No server roles will be installed

Performing Microsoft Exchange Server Prerequisite Check

    Organization Checks              ......................... COMPLETED

Configuring Microsoft Exchange Server

    Extending Active Directory schema
    Progress                         ......................... FAILED
     The following error was generated when "$error.Clear(); if ($RoleDomain -ne $null) { initialize-ExchangeLegacyPermissions -Domain $RoleDomain -DomainController $RoleDomainController; } else { initialize-ExchangeLegacyPermissions -AllDomains:$true -DomainController $RoleDomainController; }" was run: "Object reference not set to an instance of an object.".

The Exchange Server setup operation did not complete. Visit http://support.microsoft.com and enter the Error ID to find more information.

Exchange Server setup encountered an error.

While looking for this on the internet - I found the following URL:
http://exchangeshare.wordpress.com/2009/05/03/exchange-2010-beta1-bunch-of-faqs-tips-known-issues/

4.4 You may get below error while installing additional Mailbox Server in Exchange 2010 Beta1 environment.


"Object reference not set to an instance of an object"


~ This might be due to "Admin Audit Log Agent" Cmdlet Extension Agents enabled in your environment. This will be resolved in later builds but current Workaround for this problem is disable Admin Audit Log Agent with below cmdlet.

          Disable-CmdletExtensionAgent "Admin Audit Log Agent"

References:

Understanding Cmdlet Extension Agents

Disable a Cmdlet Extension Agent

Of course the above does not work for me since I do not have any Exchange Servers installed yet?

I am not using Exchange 2010 Beta - I am using the new RTM version released today. The Exchange server that I am using is Windows 2008 R2 Enterprise Edition and I am doing a custom installation for CAS, MB and HT on this server.

Any help would be appreciated. My thoughts at this point are that there may be entries left in the AD Schema from the previous Exchange 2007 implementation. I have used many of the Microsoft and Technet docs to make sure schema updates and original organizational names have been deleted.

Suggestions???
 
S

Sean van Osnabrugge



You should not be removing any entries from the Schema.  Schema updates are a one-way process and it is fully supported to upgrade a forest that contains schema entries for Exchange 2007 to Exchange 2010.  However, being that there is a previous installation of Exchange 2007 that has been removed, you should ensure that your configuration partition is clean of anything under:

CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com

As well as the following OUs in your domain parition:

OU=Microsoft Exchange Security Groups,DC=domain,DC=com
CN=Microsoft Exchange System Objects,DC=domain,DC=com

If those OUs are gone and the error still pursists, then check you ExchangeSetup.log and post the error messages contained within to this thread.

Sean | http://seanv.wordpress.com
 
B

Brian Day MCITP [MVP]

Did you remember to launch setup from within an elevated command prompt?Brian Day: MCSA 2000/2003, CCNA, MCTS: Microsoft Exchange Server 2010 Configuration, Overall Exchange/AD Geek.
 
M

MA-Admin

Thanks for the reply Sean,

Just so that we are clear - all Exchange 2007 servers were previously removed using Microsoft's documentation for removing Exchange and the last Exchange 2007 server from the domain. All I did was verify that the major attributes were removed and never removed any on my own since this is a production environment.

As far as your suggestions:

1. Configuration Partition - CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=domain,DC=com (did not exist which is good)
2. Domain Partition - OU=Microsoft Exchange Security Groups,DC=domain,DC=com (did not exist which is good also)
3. Domain Partiton - CN=Microsoft Exchange System Objects,DC=domain,DC=com (has the following entries)

Number 3 (above) has a subfolder : CN=Exchange Install Domain Servers - the class = group (and there are NO entries in the folder)
Number 3 (above) also has 3 entries at the CN=Microsoft Exchange System Objects,DC=domain,DC=com level in the review pane
CN=Offline Address Book...................
CN=Offline Address Book - First Administrative Group.................
CN=Schedule + Free Busy Information - First Administrative Group..............
All three of these entries have a class of "Public Folder"

What is the best way to proceed:
Do I delete the three keys listed above and the sub-folder for "Exchange Install Domain Servers"
or do i delete "CN=Microsoft Exchange System Objects,DC=domain,DC=com" object with ALL of its contents

Thank you ahead of time for pointing me in the right direction.
 
M

MA-Admin

Yes - command prompt was elevated - and the account had Domain Admin - Schema Admin and Enterprise Admin permissions.
 
M

MA-Admin

Update Tuesday 11-10-09 2:45EST

So first I tried to rename the object: CN=Microsoft Exchange System Objects,DC=domain,DC=com thinking it would be less intrusive then deleting the object. Re-ran Setup /PrepareSchema and got the same results as in the beginning.

Second try - deleted the object above with its subkeys - Re-ran Setup /PrepareSchema and still get the same results.

Have tried even running this command directly on the W2K8 R2 Schema Master Domain Controller - but always get the same erorr noted in my first post.

Anyone with any ideas????
 
S

Sean van Osnabrugge



MA-Admin and myself took this thread offline (to avoid posting Exchange Setup Logs publicly).

We discovered that the following AD Security Groups still existed:
Exchange Domain Servers Exchange Enterprise Servers

Once these were removed, Exchange was successfully installed.

Sean | http://seanv.wordpress.com
 
Status
Not open for further replies.
Top