Problems with Discovery Search Mailbox

Status
Not open for further replies.
R

RBO_SEC

Recently implemented Exchange 2010. Everything works like a charm, except for the Discovery Search Mailbox.

My account is member of (other accounts who are a member of the Dicovery Management group have this problem as well):

Discovery Management
Discovery Management Enterprise Admins

So far so good. I login to my webmail. Select options --> my organisation --> reports.. Then i get the following message:

An internal error has occurred when trying to access the Discovery system mailbox, which contains internal information about pending and completed searches. Ensure that this mailbox is online.

In the Event Viewer the following message appears:

(PID 9620, Thread 3) Task Get-MailboxSearch writing error when processing record of index 0. Error: Microsoft.Exchange.Configuration.Tasks.TaskException: An internal error has occurred when trying to access the Discovery system mailbox, which contains internal information about pending and completed searches. Ensure that this mailbox is online. ---> Microsoft.Exchange.Data.Storage.UserHasNoMailboxException: De gebruiker heeft geen Exchange-postvak. at Microsoft.Exchange.Data.Storage.ExchangePrincipal.InternalFromADUser(ADUser user, ADObjectId mdb, DatabaseLocationInfo databaseLocationInfo, Boolean ignoreSiteBoundary) at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore.OpenMailboxSession(ADUser adUser) at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore..ctor(ADUser adUser) at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.OpenMailboxStore() at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.FindPaged[T](QueryFilter filter, ObjectId rootId, Boolean deepSearch, SortBy sortBy, Int32 pageSize) at Microsoft.Exchange.Configuration.Tasks.GetTaskBase`1.GetPagedData() at Microsoft.Exchange.Configuration.Tasks.GetTaskBase`1.InternalProcessRecord() at Microsoft.Exchange.Configuration.Tasks.GetObjectWithIdentityTaskBase`2.InternalProcessRecord() at Microsoft.Exchange.Management.Tasks.GetMailboxSearch.InternalProcessRecord() --- End of inner exception stack trace -
Unfortinatly this doesn't 'allow' me to use this feature. Which would come in handy in our organisation.

With the command line i get the following message:

The user does not have an Exchange mailbox. + CategoryInfo : ObjectNotFound: :)) [], UserHasNoMailboxException + FullyQualifiedErrorId : 513CEBE7

No mather on what mailbox i do the search on. I even made a new Discovery Search Mailbox, unfortinatly this has the same result.

I'm using Exchange 2010 on Windows 2008 Enterprise. En the Active Directory is a Windows 2003 server.

The Internet doesn't provide me with an awnser, hopefully some of you will.
 
T

Twigs-n-Berries

I am having the same issue as Rbo. Can anyone point us in the right direction?

Thanks!
 
D

Daniel Past

Anyone ever find out what's wrong w/ the discovery mailbox? If anything?
 
B

Bharani.Billapati

Does the user who is a member of Discovery management role has a mailbox on the Exchange server? If so Can you try to give him full permissions on Discovery search mailbox and see what happens?

Thanks

Bharani
 
T

Twigs-n-Berries

I tried that, but it didn't make a difference. I ended up re-installing and the problem seemed to be fixed.
 
B

Brian Desmond -MVP-

I'd start with creating a new Discovery Mailbox. You can do this with the New/Enable-Mailbox cmdlets with the addition of the " -Discovery" parameter.Active Directory, 4th Edition - www.briandesmond.com/ad4/
 
D

DongYingtao_MVP

Looks like the mailbox database hosting the discovery arbitration mailbox is missing. The way to fix it is to run following cmdlets:

disable-mailbox -arbitration -Identity " SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}"

enable-mailbox -arbitration -Identity " SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}"

After that, the arbitration mailbox will have a database to host it.
 
J

Jason-Palermo

I have the same issue as the original poster.

when I enter the first command...

disable-mailbox -arbitration -Identity " SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}"

I get:

Exchange can't disable the arbitration mailbox " SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}" because it's the last one in the organization.
+ CategoryInfo : InvalidOperation: (all-tex.net/Use...8-e6c29d823ed9}:ADObjectId) [Disable-Mailbox], Inva
lidOperationException
+ FullyQualifiedErrorId : 785D9DD3,Microsoft.Exchange.Management.RecipientTasks.DisableMailbox

and...

enable-mailbox -arbitration -Identity " SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}"

I get:

This task does not support recipients of this type. The specified recipient all-tex.net/Users/SystemMailbox{e0dc1c29-89c3-4034-b678-e6c29d823ed9}is of type UserMailbox. Please make sure that this recipient matches the required recipient type for this task.
+ CategoryInfo : InvalidArgument: (all-tex.net/Use...8-e6c29d823ed9}:RecipientIdParameter) [Enable-Mailbo
x], RecipientTaskException
+ FullyQualifiedErrorId : C54497CF,Microsoft.Exchange.Management.RecipientTasks.EnableMailbox
 
S

SACIT

I am having a similar problem.

I can see the System Mailbox in AD but I couldn't see it on the EMC. I went ahead and created another discovery mailbox but when I attempt to use it I recieve this error message:

Unable to execute the task. Reason: The discovery mailbox, a hidden default mailbox that is required to search mailboxes, can't be found. It may have been inadvertently deleted. This mailbox must be re-created before you can search mailboxes.
Should I delete the new discovery mailbox and try to add the original discovery mailbox that was created when I first installed Exchange?
 
B

BobbyD10

Did anyone find a resolution to this problem? I too am having problems with the discovery mailbox. I created a new discovery mailbox, added it to the Discovery Role Group. When I do a search it comes up with " The user does not have an Exchange mailbox." I can access the mailbox using OWA. Does anyone have any ideas? I don't want to re-install a production exchange server if I can avoid it.
 
M

MPetrovich

Were you able to resolve this issue? I am in the same boat with a production exchange server.
 
Status
Not open for further replies.
Top