File Share Witness Question

Status
Not open for further replies.
R

rdsoxfn

I have just setup a 3 node DAG. In the config I set the File Share Witness to be one of my CAS/HUB servers. The directory is created, shared, and I have added the DAG cluster name (DAG$) as the computer name account with full permissions to the share.

However, when I go into the cluster manager and open the cluster core resources the FSW shows:

File Share Witness: L<not configured> Failed

Is this because I have an odd number of nodes and thus I am running in Node Majority?

If not any advice on how to bring the FSW into an online state.
 
M

Milind Naphade

You dont need to create any folder for FSW manually. It is automatically created on the hub transport server when you install DAG on mailbox servers. If you you want to use a non exchange 2010 server to host your FSW then the Exchange Trusted Subsystem group must be a member of the local administrators group on that computer. See http://technet.microsoft.com/en-us/library/dd298065.aspx#Cr for detailed information on DAG.

Milind Naphade | MCTS:M (Exchange 2007 and 2010) | http://www.msexchangegeek.com http://www.msexchangegeek.com/?feed=rss
 
J

jader3rd

If the Dag has an odd number of nodes it should have changed the Quorum type to Node Majority when adding the last Dag member. Do Set-DatabaseAvailabilityGroup <Dag Name> and see if it fixes it up.
 
R

rdsoxfn

Jader3rd:

Here is the error I get when running set-databaseavailbilitygroup <dag name>

Warning: Unable to access file shares on witness server <server name>. Until this problem is corrected the DAG may be more vulnerable to failures. You can use the Set-databaseavailabilitygroup cmdlet to try the operation again. Error: The network path was not found WARNING: The command completed successfully but no settings of 'DAG' have been modified.

When I originally created the DAG and set the server and file location it did not create the FSW directory or the share. I had to do this manually.

When in the cluster failover manager and I try to bring the FSW online I get the following error:

An error occurred while attempting to bring the resource 'File Share Witness (\\server\share) online.

Error Code: 0x80070057

The parameter is incorrect

The cluster Quorum type is currently set to Node Majority. Everything else is setup. The databases are online and copies have been sent to the other two nodes. The cluster networks are up and replication enabled on the correct networks. This is the one piece that has me stumped.
 
J

jader3rd

What is the number of Dag members listed in (Get-DatabaseAvailabilityGroup <dag name>).Servers.Count? If Set-Dag was trying to modify the FSW it sounds like there is an even number of Dag members.
 
R

rdsoxfn

All 3 DAG members are listed under member servers, but there is nothing listed under Operational Servers.
 
J

jader3rd

The OperationalServer field only gets filled in when -Status is specified. You mentioned that the quourm type is Node Majority. A Node Majority shouldn't have a way of having an FSW resource. Something really funky is up. Can you delete the FSW resource?
 
R

rdsoxfn

And I really think that begs my question b/c of my 3 node cluster and the FSW wasn't created during first configuration. The directory was created manually as well as the share and its permissions. With that said then in a 3 node configuration I don't need a FSW, obviously I would if it was a 2 or 4 node b/c of voting conflict that could arise in the Qourum, but b/c there will always be a " winner" in a voting situation then the FSW is not needed in my opinion. Please correct me if you think this is not proper thinking.
 
R

rdsoxfn

Thanks all for your assistance. Good to know it was configured correctly.
 
Status
Not open for further replies.
Top