EMC - Launching RBAC Editor getting errors

  • Thread starter Aaron Firouz
  • Start date Views 2,008
Status
Not open for further replies.
A

Aaron Firouz

Hey all,
I'm getting a strange error from the EMC when I try to launch the RBAC User Editor (under " Toolbox" ). I've tried it with several user accounts (all part of the " Organization Administration" role), and get the same error. I can't post a screenshot, but it pops up a message box with the text:
Cannot index into a null array. It was running the command 'Discover-EcpVirtualDirectoryForEmc -CurrentVersion 'Version 14.0 (Build 639.21)' -UseWIA $true'.

Web/forum searches turn up nothing for this error, or for the particular command " Discover-EcpVirtualDirectoryForEmc" , but I am assuming it tries to enumerate the ECP instances in the org and use the closest one based on site (or something).

ECP works fine, and performing the RBAC operations completes successfully; it just appears to be a problem with launching it from the EMC. This is a new multi-server Exchange 2010 (with Rollup 4) on 2008R2 in a multi-domain Windows 2003 environment. Everything else appears to be working fine; just this one thing.

Any ideas on this would be greatly appreciated. Thanks!
 
L

Laeeq Qazi

Do u have a legacy server in your cluster, which is turned off? If so, then turn it on and then check.

Regards,

Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
 
A

Aaron Firouz

Hi Laeeq,
Thanks for the reply. No, all servers in the org are up and running. I should have mentioned that this is actually a mixed environment, 2003 and 2010, but I didn't think the 2003 environment would matter.
Thanks!
 
J

JGibby20

I am getting the exact same error. My environment is all 2010. We did have a 2007 server that had all of it's roles removed and decomissioned.
 
L

Laeeq Qazi

Hi,

Can u confirm that decommissioned ex2007 server doesn't exist at:

CN=Configuration

CN=Services

CN=Microsoft Exchange

CN= First Organization [This is name of your Exch Org]

CN=Exchange Administrative Group

CN=Exchange Administrative Group (FYDIBOHF23SPDLT)

CN=Servers

Remove if it is there.

You can check it using any AD Editor tool like ADSIEdit.msc.

Regards,

Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com
 
Z

Zamim

Hi.

Even we are getting the same err while opening Message Tracking logs. Please update if you got the solution
 
W

Will1506

We are still getting the same error with 2003 co existing. I remember it working fine when I built the first Exchange 2010 server. However when I built the second node was when it stopped working.

We have 2 Exchagne 2010 servers with (CAS, HUB, and Mail). Both the servers have the same problem. There's very little information on the internet about this. Has anyone resolved it yet? Furthmore when you run message tracking in OWA you receive
" The delivery report for this message can't be accessed. This may be because the message isn't supported or its delivery information no longer exists."

But clearly when I navigate to the path of the Exchange Message tracking logs I see all logs logging properly.

Did anyone find a solution yet?
 
Status
Not open for further replies.
Top