Outlook 2007 Clients Prompt For Password When Opening

Status
Not open for further replies.
J

JamesV

I am running Exchange 2007 Standard. New outlook 07 clients prompt for password each time it is opened. Older clients do not prompt for password. Is there any way for outlook 07 to not prompt for password? Users already logged into domain, should their credentials not be recognized automatically like with outlook 03?
 
R

redsoxvandal

Try looking at the account properties - it sounds like you have basic authentication selected in the account when you really want to have NTLM.
 
J

JamesV

Under Outlook properties I have checked to be sure that it is using NTLM, however this has no effect on the prompting. This is very annoying and after days of searching blogs, I still have no solution.
 
R

redsoxvandal

Are you on a LAN or using Outlook Anywhere?

Within Outlook 2k7 do you have the option checked on the Security tab for always prompt for user credentials?
 
J

JamesV

Found it, the problem was under IIS on the Exchange server. Under Autodiscover properties> Directory Security> Authentication Methods> I checked " Integrated Windows Authentication" . This solved the problem.
 
B

balletit

Can you expand on where in IIS this is?

I have Outlook 2003 clients starting to promt for authentication.
 
J

JamesV

Open IIS on your Exchange server. Expand " your computer name" then expand " Web Sites" then expand " Default Web Site. From here you should see the " Autodiscover" . Right click on " Autodiscover" and select " Properties" , from here select the " Directory Security Tab" and then click the " Authentication and access control Edit button" . A popup page for " Authentication Methods" will be visible. be sure to select the " Integrated Windows authentication" check box.
 
B

balletit

I don't have an Autodiscover.

I'm running Exchange 2003.

I have:

Exadmin

Exchange

ExchWeb

OMA
 
P

PW Webb

Hi

I have this problem as well we have E2K7 on Server 2008 I have followed this article to try and resolve the certificate problem but am now geeting password prompts on Outlook 2007 only

http://support.microsoft.com/kb/940726

Intergrated windows authentication is enabled for the autodiscover site on IIS

Thanks in advance

PW
 
M

Muff_Diver

JamesV wrote:

Open IIS on your Exchange server. Expand " your computer name" then expand " Web Sites" then expand " Default Web Site. From here you should see the " Autodiscover" . Right click on " Autodiscover" and select " Properties" , from here select the " Directory Security Tab" and then click the " Authentication and access control Edit button" . A popup page for " Authentication Methods" will be visible. be sure to select the " Integrated Windows authentication" check box.

HUH?

A simpler path would be:

On your Exchange server,

Start > Administrative Tools (or All Programs > Administrative Tools) > IIS > Expand server name > Expand " Web Sites" > Right-Click " Default Web Site" > Choose Properties > Click " Directory Security" tab > Click " Edit" button under " Authentication and Access Control" > Ensure " Integrated Windows authentication" is checkmarked.
 
C

civanescu

Hi,

I've tried all the stuff you presented here.

My configuration is:

Outlook 2007, Exchange 2007, Windows Server 2008 (all standard).

Actually the outlook is working, but all the time is asking for password and present " Need password" in the down right part of the window.

Thank you in advance
 
J

JamesV

Thanks for the post. All in all it takes you to the same place. btw, classic display name. Muff_Diver
 
R

rioka

hello

we have all the suggested fixes enabled on the exchange server and the correct setting on the client machines as suggested.

however we still get the same password prompts which we can cancel, mail works ok but get the message " Need Password" in bottom right status bar of Outlook 2007.

my os is vista ultimate if that matters.

thanks

rioka
 
G

gareth2799

Same problem here, have fixed all the IIS settings and clients configured to use NTLM, still getting prompted both when on local lan using direct connection and outlook anywhere clients using RPC over HTTPS...
 
B

beno.com

Hi Rioka...

We have the Same issue here... Did you ever Solve your problem?

Thanks

Ben
 
J

JJClements

Hi guys - I just had this issue. I remembered that when I was looking at configuring RPC-HTTPS for Outlook clients I had to set a regkey to force authentication to use NTLMv2 only:
http://www.jjclements.co.uk/index.php/2009/08/07/kixtart-script-to-enable-outlook-anywhere-or-rpc-https
The following article describes the issue:
http://support.microsoft.com/kb/820281
On my clients I have just (very quickly) tested changing the following regkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\
Value= lmcompatibilitylevel (REG_DWORD) from 0 to 3
Like I said I have only just very quickly tested this on one client which was running Windows XP but it seems to have resolved the issue for me.
James
 
H

hghghghghg

This problems happens after a Windows Update where the update seems to cahnge the settings on Autodiscover virtual directory. Microsoft should be looking at this issue as it happened to us right after Windows Updates were completed and upon Server restart the users are prompted with Username and Password and even if they enter it is not accepted.
 
C

CD Shriver

We've been experiencing simmilar issues, but sporadically and without any real patterns. Users get prompted for a logon prompt, but the prompt points them at the Exchange server. Consequently, they put their domain credentials in and are rejected. They end up needing to enter it in a " DOMAIN\USERNAME" style before it will work.

I'm trying the above fixes to see if this has any affect, but it's difficult to determine since I have to look for an ABSENCE of problems. No idea how to replicate the issue manually.
 
G

grabber_blue

I don't have an Autodiscover.
I'm running Exchange 2003.
I have:
Exadmin
Exchange
ExchWeb
OMA
Same here. I made the same change but in RPC properties and it worked.

IIS Manager, Web Sites, Default Web Site, RPC properties> Directory Security> Authentication Methods> and check " Integrated Windows Authentication"
 
M

Martin Vyroubal

Greetings,

I have the same problem. I put Integrated Windows Auth. to Autodiscover,EWS,OAB and RPC, but Outlook is still asking for password again and again. If i set up Outlook 2010 then start it, it askes for password, I put it there and tadaa, its working. But Outlook 2003 and 2007 are asking for password till the end of the world.

Any idea what should be wrong?

Thanks,
M. Vyroubal

M.Vyroubal
 
Status
Not open for further replies.
Top