How do i configure Exchange 2010 to receive mails from sms alert applicaion for onward distribution

  • Thread starter Adewumi007
  • Start date Views 512
Status
Not open for further replies.
A

Adewumi007



There is a third party application in my organization that sends transaction alerts to users. The problem is that my exchange 2010 server does not deliver these messages to the receipents. I think it has something to do with the receive connector, though i am not sure. Could anybody kindly put me through the process of allowing a third party application send mail through Exchange server 2010 pls
 
M

Michel de Rooij



The default connectors does not accept unencrypted mail and checks addresses against AD. I'd suggest creating a specific receive connector for 3rd party applications.
Exchange Management Console, go to Server Config > Hub Transport; Select the server to host the connector, right click then New Receive connecor; Give it a proper name, select intended use Custom. Next; Configure a specific IP / port combination for this connector. Can't use original IP:port, there's already a connector listening on that combination. Provide FQDN. Next; Provide the IP number or IP range of the 3rd party application(s) authorized to use this connector. Next; Click New. Of course you can also reconfigure the existing connectors for this purpose but that may open up or restrict it to much. What you want to, make sure to set the "receive mail from" IP number/range and set Permission Groups to include Anonymous users.

Michel de Rooij,
MCITP Ent.Msg 2007+2010| MCTS W2008, Ex2007+2010 Conf | MCSE+Msg2k3 | MCSE+Inet2k3 | Prince2 Fnd | ITIL
I blog on http://eightwone.wordpress.com/ and tweet on http://twitter.com/mderooij
 
T

Tamer Sherif Mahmoud



if you want this application to send to external users that doesn"t exist in your organization you will need to the follow the exact steps stated by Michel in addition to adding an extended right to anonymous users permission using the following powershell cmdlet:

Get-ReceiveConnector "Connector name" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

Tamer Sherif Mahmoud
 
A

Adewumi007



Thanks Michel,
i have tried this but its still not working. The part i dont undertand is the configuration of the specific IP /Port combination for the connector. Right now i am using the original IP:port configuration. Please how do i go about creating a new one
 
Status
Not open for further replies.
Top