how to copy a list of email contacts and paste them only as names (not names + email address)

R

RPMM

In Outlook 2007 when I copied a list of email addresses from the " To" field in an email and then pasted it in the email body, it would paste only a list of names, without email addresses.

But in Outlook 2010, there seems to be no way to replicate that functionality. Now, the paste option pastes the list as name along with email address like:

Tom Smith <tom_smith@company.com>; Albert Shaw <al_shaw@company.com>

How can I paste so that I see only: Tom Smith; Albert Shaw
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
You are copying from the message's To field?

What do you see in the body if you hit Reply or Forward?

ie, in the header block:

From: name [mailto:address]

Sent: Wednesday, August 25, 2010 6:15 PM

To: Diane; Can; Andrew

Subject: RE: now that you are back

 
R

RPMM

You are copying from the message's To field?

What do you see in the body if you hit Reply or Forward?

ie, in the header block:

From:name [mailto:address]

Sent: Wednesday, August 25, 2010 6:15 PM

To: Diane; Can; Andrew

Subject: RE: now that you are back

Yes, I am copying from the To field. My specific use case is I send an email to a certain group of people, and I put their names within the body saying " the following people were requesting such-and-such" . So I enter everyone's names in the To field and earlier I was able to copy the entire list from the To field and paste it in the body and it was pasting only the names.

With Outlook 2010, it is pasting name <email>; name <email>
 
G

Ganesh Kumar N

If you click on "To field" it will select the name and email address. Try to double click on the address in "to" field and copy only the name and then paste it in the new message window.

Ganesh Kumar N
 
R

RPMM

If you click on "To field" it will select the name and email address. Try to double click on the address in "to" field and copy only the name and then paste it in the new message window.

Ganesh Kumar N

But I have several names in the To field. If I have to manually get the names, it will be too time-consuming. Why isn't there a Paste Special-type of functionality to paste name only or paste name+email?
 
M

Mr. Freezie

I would like a solution to this annoying problem as well. I've looked all over and cannot find a setting to change this behavior. It seems to just take the name when pasting between e-mail recipient fields but in anything else includes the smtp address in carets as well. It would appear outlook is copying the name as a multivalued string instead of a single value that you see on the string and includes the hidden smtp information for use in addressing new emails. Any help would be appreciated.
 
V

vr6jet

I too have this problem, It would be great if Microsoft could provide an answer to this problem.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
In Outlook 2010, copying from the To field should include the display name and email address. In older versions, you need to get the display names/addresses from the message header.

See http://www.slipstick.com/tutorials/create/dl.asp - use the first section to get the display name and addresses - or use this method to get the names and not the addresses.

 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Yes, I am copying from the To field. My specific use case is I send an email to a certain group of people, and I put their names within the body saying " the following people were requesting such-and-such" . So I enter everyone's names in the To field and earlier I was able to copy the entire list from the To field and paste it in the body and it was pasting only the names.

With Outlook 2010, it is pasting name <email>; name <email>

Hit Forward or Reply - you'll have a block like this in the body - copy and paste the names where ever you want:

Sent: Thursday, September 16, 2010 9:42 PM

To: Tony; Angela; Heather; Mary Mitchell; Janet (home); Frank & Jeni; Diane Poremsky;

Subject: New Address

 
V

vr6jet

Thank you for the reply Diane, however it would seem to me that this is only a work around to a larger problem eg: 2010 Design change by Microsoft affecting user behavior.
 

acsgen

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Re: how to copy a list of email contacts and paste them only as names (not nam

I found a workaround... I printed the email (unsent) to PDF. I then copied the list as text from the email and got my list of names without the email addresses inserted. I did find that my text reader in Acrobat missed some spaces between last and first name, so I pasted the list in Word and the did a replace all of "," with ", " (adding a space). I found that an extra space was better than no space, and if I copied/pasted the list back to Outlook, the names resolved with an extra space.
 

Jeff Wilson

New Member
Outlook version
Outlook 2010 32 bit
Email Account
Exchange Server
That is a good workaround, acsgen, but it is utterly annoying that the functionality changed. You can't even post into notepad as a workaround which is usually tried and true.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
The names aren't in the To block if you hit Reply All?

This is from a message I received this morning, with the last names removed for privacy:

To: Peter; John
Cc: Bob; Daniel; Jim; Mary
Subject: Re: Question
 
Top