Exchange 2010 Journaling Issue

Not open for further replies.

Chris J Heacock

We are running Exchange 2010 and Are trying to validate a journaling architecture. In order to do this, we have created several mailboxes, all of which forward to a blackhole distro list in Exchange.

All of those mailboxes are in a journaling-enables group and journaling is in force for that group.

The problem is that the emails sent to those mailboxes are not journaled unless a copy of the email stays in the mailbox. As we are going to test using a high volume of messages, we do *not* want to kep a copy of the received mail in the test users mailbox, we want those to disappear into the ether (hence the blackhole address they all forward to).

The issue is that unless we check the box that keeps a copy and forward a copy, the messages are *not* journaled. This seems to me that if one could circumvent journaling by forwarding a journaled mailbox to a non-journaled mailbox which would be a pretty big issue.

Can someone help me sort this out?



mitch roberson

How are you setting up journaling. If you have standard licensing then you can only do journaling by database. and the journaling is set specifically on the database. If you have enterprise licensing then you set the journaling per user. If true journaling is enabled it actually splits the message at the hub transport so deleting the message in the inbox should have no affect.Mitch Roberson |MCITP:Enterprise Server Admin, Messaging 2007, 2010 |MCTS:OCS with Voice Achievement |MCT |MCSE 2000\2003 |MCSE Messaging 2000\2003

Chris J Heacock

We are running Enterprise edition, and the user is in a distribution list that has journaling enabled. As I said, if a copy of the mail stays in the mailbox it journals fine. The issue is that the if the user has forwarding enabled and does not keep a copy of the forwarded message, no journal is recorded.


Hi Chris,
It is by design, the journaling enabled on the storage level, and the forward setting enabled with outh a copy, it would not go through the journaling feature.
Not open for further replies.