Error when installing Exchange 2010 SP1 at Mailbox role

  • Thread starter DayMare71
  • Start date Views 3,747
D

DayMare71

I have 6 Exchange 2010 servers with a 3 member DAG, Exchange 2010 SP1 installed without issue on all except for the last DAG server. It fails once it reaches the mailbox role with this error:

Exchange Server component Mailbox Role failed.

Error: Error:

The following error was generated when " $error.Clear();

$fullPath = [System.IO.Path]::Combine($RoleInstallPath, " bin\microsoft.Exchange.PowerShell.configuration.dll" );

precompile-ManagedBinary -BinaryName $fullPath;

" was run: " Process execution failed with exit code -1." .

Process execution failed with exit code -1.

I haven't been able to find a solution, any help would be appreciated.
 
D

DayMare71

Here is the setup log where the mailbox role install starts:

[08/27/2010 19:58:07.0306] [0] Setup will run the task 'Install-MailboxRole'
[08/27/2010 19:58:07.0306] [1] Setup launched task 'Install-MailboxRole -DomainController '' -UpdatesDir '\Install\Updates''
[08/27/2010 19:58:07.0322] [1] Active Directory session settings for 'Install-MailboxRole' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:07.0322] [1] Beginning processing Install-MailboxRole -DomainController:'' -UpdatesDir:'Updates'
[08/27/2010 19:58:07.0509] [1] Attempting Install for MailboxRole.
[08/27/2010 19:58:07.0509] [1] The following roles are current:
[08/27/2010 19:58:08.0445] [1] Reading components for the role 'MailboxRole' from 'res://MailboxRoleDefinition.xml'
[08/27/2010 19:58:08.0445] [1] Found 41 components
[08/27/2010 19:58:08.0461] [1] Loaded component 'All Roles Common First - Run Once' with 2 task information blocks from 'res://AllRolesCommonFirst_RunOnce.xml'
[08/27/2010 19:58:08.0461] [1] Loaded component 'All Roles Common First' with 8 task information blocks from 'res://AllRolesCommonFirst.xml'
[08/27/2010 19:58:08.0461] [1] Loaded component 'All Roles Precompile Management Binaries' with 36 task information blocks from 'res://AllRolesPrecompileManagementBinaries.xml'
[08/27/2010 19:58:08.0477] [1] Loaded component 'Mailbox Permissions Configuration' with 1 task information blocks from 'res://MailboxLocalPermissionsComponent.xml'
[08/27/2010 19:58:08.0492] [1] Loaded component 'Common Perf Counters ' with 4 task information blocks from 'res://CommonPerfCountersComponent.xml'
[08/27/2010 19:58:08.0492] [1] Loaded component 'Provision Server' with 10 task information blocks from 'res://ProvisionServerComponent.xml'
[08/27/2010 19:58:08.0508] [1] Loaded component 'All Active-Directory Roles Common' with 10 task information blocks from 'res://AllADRolesCommon.xml'
[08/27/2010 19:58:08.0508] [1] Loaded component 'Exchange 2003 Registry Configuration' with 1 task information blocks from 'res://LegacyRegistryMarkersComponent.xml'
[08/27/2010 19:58:08.0508] [1] Loaded component 'Mailbox Service Control (First)' with 7 task information blocks from 'res://MailboxServiceControlFirst.xml'
[08/27/2010 19:58:08.0508] [1] Loaded component 'Exchange 2003 Core Configuration' with 3 task information blocks from 'res://LegacyCoreComponent.xml'
[08/27/2010 19:58:08.0523] [1] Loaded component 'Exchange 2003 Pseudo-MTA Configuration' with 1 task information blocks from 'res://LegacyMTAComponent.xml'
[08/27/2010 19:58:08.0523] [1] Loaded component 'Exchange 2003 MDB Configuration' with 5 task information blocks from 'res://LegacyMDBComponent.xml'
[08/27/2010 19:58:08.0523] [1] Loaded component 'Datacenter Server License' with 1 task information blocks from 'res://DatacenterLicenseServer.xml'
[08/27/2010 19:58:08.0523] [1] Loaded component 'Mailbox Perf Counters' with 30 task information blocks from 'res://MailboxPerfCountersComponent.xml'
[08/27/2010 19:58:08.0539] [1] Loaded component 'Mailbox Configuration' with 27 task information blocks from 'res://MailboxComponent.xml'
[08/27/2010 19:58:08.0601] [1] Loaded component 'Enable RPC-EPMAP firewall exception' with 1 task information blocks from 'res://RpcEpmapFirewallException.xml'
[08/27/2010 19:58:08.0601] [1] Loaded component 'Enable Remote IIS Admin RPC firewall exception' with 1 task information blocks from 'res://RemoteIISAdminFirewallException.xml'
[08/27/2010 19:58:08.0617] [1] Loaded component 'Transport Log Search Service' with 2 task information blocks from 'res://TransportLogSearchServiceComponent.xml'
[08/27/2010 19:58:08.0617] [1] Loaded component 'Exchange 2003 Miscellaneous Configuration' with 4 task information blocks from 'res://LegacyMailboxComponent.xml'
[08/27/2010 19:58:08.0617] [1] Loaded component 'InfoWorker Configuration' with 4 task information blocks from 'res://InfoWorkerComponent.xml'
[08/27/2010 19:58:08.0617] [1] Loaded component 'Content Indexing Configuration' with 3 task information blocks from 'res://ContentIndexComponent.xml'
[08/27/2010 19:58:08.0633] [1] Loaded component 'Mail Submission Service Configuration' with 9 task information blocks from 'res://MailSubmissionServiceComponent.xml'
[08/27/2010 19:58:08.0633] [1] Loaded component 'Replay Service Configuration' with 3 task information blocks from 'res://ReplayServiceComponent.xml'
[08/27/2010 19:58:08.0633] [1] Loaded component 'Service Host Configuration' with 3 task information blocks from 'res://ServiceHostComponent.xml'
[08/27/2010 19:58:08.0633] [1] Loaded component 'RPC Client Access Service Configuration' with 4 task information blocks from 'res://RpcClientAccessComponent.xml'
[08/27/2010 19:58:08.0648] [1] Loaded component 'Monitoring Service Configuration' with 5 task information blocks from 'res://MonitoringComponent.xml'
[08/27/2010 19:58:08.0648] [1] Loaded component 'MailboxExchangeCertificate' with 1 task information blocks from 'res://MailboxExchangeCertificate.xml'
[08/27/2010 19:58:08.0648] [1] Loaded component 'PowerShell Configuration' with 4 task information blocks from 'res://PowerShellComponent.xml'
[08/27/2010 19:58:08.0664] [1] Loaded component 'WSMan IIS Hosting Configuration' with 1 task information blocks from 'res://WSManIISHostingConfigurationComponent.xml'
[08/27/2010 19:58:08.0664] [1] Loaded component 'Active Directory Topology Service Configuration' with 3 task information blocks from 'res://AllADRolesCommonServiceControl.xml'
[08/27/2010 19:58:08.0679] [1] Loaded component 'Mailbox System Attendant Dependent Tasks' with 13 task information blocks from 'res://SystemAttendantDependent.xml'
[08/27/2010 19:58:08.0679] [1] Loaded component 'Transport Common Service Control' with 1 task information blocks from 'res://TransportCommonServiceControl.xml'
[08/27/2010 19:58:08.0679] [1] Loaded component 'Service Host Service Control' with 1 task information blocks from 'res://ServiceHostServiceControl.xml'
[08/27/2010 19:58:08.0695] [1] Loaded component 'Mailbox Service Control (Last)' with 21 task information blocks from 'res://MailboxServiceControlLast.xml'
[08/27/2010 19:58:08.0695] [1] Loaded component 'Datacenter Common Configuration' with 6 task information blocks from 'res://DatacenterAllRolesCommonFirst.xml'
[08/27/2010 19:58:08.0711] [1] Loaded component 'Datacenter Mailbox Configuration' with 9 task information blocks from 'res://DatacenterMailboxComponent.xml'
[08/27/2010 19:58:08.0711] [1] Loaded component 'Datacenter Mailbox Perf Counters' with 6 task information blocks from 'res://DatacenterMailboxPerfCountersComponent.xml'
[08/27/2010 19:58:08.0711] [1] Loaded component 'Datacenter Common Configuration Last' with 3 task information blocks from 'res://DatacenterAllRolesCommonLast.xml'
[08/27/2010 19:58:08.0726] [1] Loaded component 'All Roles Common Last' with 6 task information blocks from 'res://AllRolesCommonLast.xml'
[08/27/2010 19:58:08.0726] [1] Loaded component 'Mailbox SBS Configuration' with 2 task information blocks from 'res://SbsMailboxComponent.xml'
[08/27/2010 19:58:08.0726] [1] Loaded component 'Common SBS Configuration' with 1 task information blocks from 'res://SbsAllRolesCommonLast.xml'
[08/27/2010 19:58:08.0742] [1] The following roles are installed: MailboxRole AdminToolsRole
[08/27/2010 19:58:08.0742] [1] Loaded 7 parameters from the configuration file " \\*\Common\bin\EnterpriseServiceEndpointsConfig.xml" .
[08/27/2010 19:58:08.0742] [1] Writing informational script to 'C:\ExchangeSetupLogs\Install-MailboxRole-20100827-14580807421001210134.ps1'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleBinPath = 'C:\Program Files\Microsoft\Exchange Server\V14\Bin'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleCreatePublicFolderDatabase = $True
[08/27/2010 19:58:08.0742] [1] Executing: $RoleCustomerFeedbackEnabled = $null
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterPath = 'C:\Program Files\Microsoft\Exchange Server\V14\Datacenter'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterServiceEndpointABCHContactService = '<ServiceEndpoint><Url>http://pvt-contacts.msn.com/abservice/abservice.asmx</Url></ServiceEndpoint>'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterServiceEndpointDomainPartnerManageDelegation = '<ServiceEndpoint><Url>https://domains.live.com/service/managedelegation.asmx</Url></ServiceEndpoint>'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterServiceEndpointDomainPartnerManageDelegation2 = '<ServiceEndpoint><Url>https://domains.live.com/service/managedelegation2.asmx</Url></ServiceEndpoint>'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterServiceEndpointLiveFederationMetadata = '<ServiceEndpoint><Url>https://nexus.passport.com/FederationMetadata/2006-12/FederationMetadata.xml</Url></ServiceEndpoint>'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterServiceEndpointLiveGetUserRealm = '<ServiceEndpoint><Url>https://login.live.com/GetUserRealm.srf</Url></ServiceEndpoint>'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterServiceEndpointLiveServiceLogin2 = '<ServiceEndpoint><Url>https://login.live.com/RST2.srf</Url></ServiceEndpoint>'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDatacenterServiceEndpointMsoFederationMetadata = '<ServiceEndpoint><Url>https://nexus.microsoftonline-p.com/FederationMetadata/2006-12/FederationMetadata.xml</Url></ServiceEndpoint>'
[08/27/2010 19:58:08.0742] [1] Executing: $RoleDbFilePath = $null
[08/27/2010 19:58:08.0757] [1] Executing: $RoleDomainController = ''
[08/27/2010 19:58:08.0757] [1] Executing: $RoleFqdnOrName = ''
[08/27/2010 19:58:08.0757] [1] Executing: $RoleInstallationMode = 'BuildToBuildUpgrade'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleInstallPath = 'C:\Program Files\Microsoft\Exchange Server\V14\'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleInvocationID = '20100827-14580807421001210134'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleIsAdminToolsRoleInstalled = $True
[08/27/2010 19:58:08.0757] [1] Executing: $RoleIsDatacenter = $False
[08/27/2010 19:58:08.0757] [1] Executing: $RoleIsMailboxRoleInstalled = $True
[08/27/2010 19:58:08.0757] [1] Executing: $RoleIsPartnerHosted = $False
[08/27/2010 19:58:08.0757] [1] Executing: $RoleIsServerSbs = $False
[08/27/2010 19:58:08.0757] [1] Executing: $RoleLanguagePacksPath = '\Exchange 2010 SP1\Install\'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleLogFolderPath = $null
[08/27/2010 19:58:08.0757] [1] Executing: $RoleLoggedOnUser = ''
[08/27/2010 19:58:08.0757] [1] Executing: $RoleLoggingPath = 'C:\Program Files\Microsoft\Exchange Server\V14\Logging'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleMailboxDatabaseName = 'Mailbox Database'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleMdbName = $null
[08/27/2010 19:58:08.0757] [1] Executing: $RoleNetBIOSName = ''
[08/27/2010 19:58:08.0757] [1] Executing: $RolePreviousVersion = '14.00.0639.021'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleProductPlatform = 'amd64'
[08/27/2010 19:58:08.0757] [1] Executing: $RolePublicFolderDatabaseName = 'Public Folder Database'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleRoleName = 'MailboxRole'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleRoles = 'MailboxRole,AdminToolsRole'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleSetupLoggingPath = 'C:\ExchangeSetupLogs'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleTargetVersion = '14.01.0218.015'
[08/27/2010 19:58:08.0757] [1] Executing: $RoleUpdatesDir = '\Exchange 2010 SP1\Install\Updates'
[08/27/2010 19:58:08.0773] [1] 195 tasks were found to execute.
[08/27/2010 19:58:08.0773] [1] Processing component 'All Roles Common First - Run Once' (Configuring the server.).
[08/27/2010 19:58:08.0773] [1] Executing:
Set-WERRegistryMarkers;

[08/27/2010 19:58:08.0773] [2] Active Directory session settings for 'Set-WERRegistryMarkers' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:08.0773] [2] Beginning processing Set-WERRegistryMarkers
[08/27/2010 19:58:10.0224] [2] Ending processing Set-WERRegistryMarkers
[08/27/2010 19:58:10.0224] [1] Executing:
Set-EnvironmentVariable -Name " ExchangeInstallPath" -Value " $RoleInstallPath" -Target Machine;

[08/27/2010 19:58:10.0224] [2] Active Directory session settings for 'Set-EnvironmentVariable' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:10.0224] [2] Beginning processing Set-EnvironmentVariable -Name:'ExchangeInstallPath' -Value:'C:\Program Files\Microsoft\Exchange Server\V14\' -Target:'Machine'
[08/27/2010 19:58:15.0372] [2] Ending processing Set-EnvironmentVariable
[08/27/2010 19:58:15.0372] [1] Processing component 'All Roles Common First' (Creating the Exchange server configuration object in Active Directory.).
[08/27/2010 19:58:15.0372] [1] Executing:
& $RoleBinPath\ServiceControl.ps1 EnableServices $RoleRoleName.Replace('Role','')

[08/27/2010 19:58:15.0434] [2] [ServiceControl.ps1] --------------- [08/27/2010 19:58:15.0434] [2] [ServiceControl.ps1] * ServiceControl.ps1: 8/27/2010 2:58:15 PM
[08/27/2010 19:58:15.0434] [2] [ServiceControl.ps1] Performing service control with options:
[08/27/2010 19:58:15.0434] [2] [ServiceControl.ps1] Mailbox is a known role
[08/27/2010 19:58:15.0450] [2] [ServiceControl.ps1] Will enable services for the roles: Mailbox.
[08/27/2010 19:58:15.0450] [2] [ServiceControl.ps1] Enabling services for 'Mailbox'...
[08/27/2010 19:58:15.0450] [2] [ServiceControl.ps1] Reading service registry data from 'C:\ExchangeSetupLogs\ServiceStartupMode14.01.0218.015.xml'
[08/27/2010 19:58:15.0466] [2] [ServiceControl.ps1] Loaded state for 147 services registry
[08/27/2010 19:58:15.0544] [2] [ServiceControl.ps1] Enabling service 'IISAdmin'.
[08/27/2010 19:58:15.0575] [2] [ServiceControl.ps1] Enabling service 'MSExchangeADTopology'.
[08/27/2010 19:58:15.0590] [2] [ServiceControl.ps1] Enabling service 'MSExchangeIS'.
[08/27/2010 19:58:15.0606] [2] [ServiceControl.ps1] Enabling service 'MSExchangeMailboxAssistants'.
[08/27/2010 19:58:15.0622] [2] [ServiceControl.ps1] Enabling service 'MSExchangeMailSubmission'.
[08/27/2010 19:58:15.0637] [2] [ServiceControl.ps1] Enabling service 'MSExchangeMonitoring'.
[08/27/2010 19:58:15.0653] [2] [ServiceControl.ps1] Enabling service 'MSExchangeRepl'.
[08/27/2010 19:58:15.0668] [2] [ServiceControl.ps1] Enabling service 'MSExchangeRPC'.
[08/27/2010 19:58:15.0684] [2] [ServiceControl.ps1] Enabling service 'MSExchangeSA'.
[08/27/2010 19:58:15.0715] [2] [ServiceControl.ps1] Enabling service 'MSExchangeSearch'.
[08/27/2010 19:58:15.0731] [2] [ServiceControl.ps1] Enabling service 'MSExchangeServiceHost'.
[08/27/2010 19:58:15.0746] [2] [ServiceControl.ps1] Enabling service 'MSExchangeThrottling'.
[08/27/2010 19:58:15.0762] [2] [ServiceControl.ps1] Enabling service 'MSExchangeTransportLogSearch'.
[08/27/2010 19:58:15.0778] [2] [ServiceControl.ps1] Enabling service 'MSFTESQL-Exchange'.
[08/27/2010 19:58:15.0793] [2] [ServiceControl.ps1] Enabling service 'RemoteRegistry'.
[08/27/2010 19:58:15.0809] [2] [ServiceControl.ps1] Enabling service 'W3Svc'.
[08/27/2010 19:58:15.0824] [2] [ServiceControl.ps1] Enabling service 'WinMgmt'.
[08/27/2010 19:58:15.0840] [2] [ServiceControl.ps1] Enabling service 'wsbexchange'.
[08/27/2010 19:58:15.0856] [2] [ServiceControl.ps1] Script completed succesfully.
[08/27/2010 19:58:15.0856] [1] Executing:
if ($RoleRoles)
{
& $RoleBinPath\ServiceControl.ps1 EnableServices $RoleRoles.Replace('Role','').Split(',')
}

[08/27/2010 19:58:15.0902] [2] [ServiceControl.ps1] --------------- [08/27/2010 19:58:15.0918] [2] [ServiceControl.ps1] * ServiceControl.ps1: 8/27/2010 2:58:15 PM
[08/27/2010 19:58:15.0918] [2] [ServiceControl.ps1] Performing service control with options:
[08/27/2010 19:58:15.0918] [2] [ServiceControl.ps1] Mailbox is a known role
[08/27/2010 19:58:15.0918] [2] [ServiceControl.ps1] AdminTools is a known role
[08/27/2010 19:58:15.0918] [2] [ServiceControl.ps1] Will enable services for the roles: Mailbox AdminTools.
[08/27/2010 19:58:15.0934] [2] [ServiceControl.ps1] Enabling services for 'Mailbox AdminTools'...
[08/27/2010 19:58:15.0934] [2] [ServiceControl.ps1] Reading service registry data from 'C:\ExchangeSetupLogs\ServiceStartupMode14.01.0218.015.xml'
[08/27/2010 19:58:15.0934] [2] [ServiceControl.ps1] Loaded state for 147 services registry
[08/27/2010 19:58:16.0012] [2] [ServiceControl.ps1] Enabling service 'IISAdmin'.
[08/27/2010 19:58:16.0027] [2] [ServiceControl.ps1] Enabling service 'MSExchangeADTopology'.
[08/27/2010 19:58:16.0043] [2] [ServiceControl.ps1] Enabling service 'MSExchangeIS'.
[08/27/2010 19:58:16.0058] [2] [ServiceControl.ps1] Enabling service 'MSExchangeMailboxAssistants'.
[08/27/2010 19:58:16.0074] [2] [ServiceControl.ps1] Enabling service 'MSExchangeMailSubmission'.
[08/27/2010 19:58:16.0090] [2] [ServiceControl.ps1] Enabling service 'MSExchangeMonitoring'.
[08/27/2010 19:58:16.0105] [2] [ServiceControl.ps1] Enabling service 'MSExchangeRepl'.
[08/27/2010 19:58:16.0121] [2] [ServiceControl.ps1] Enabling service 'MSExchangeRPC'.
[08/27/2010 19:58:16.0136] [2] [ServiceControl.ps1] Enabling service 'MSExchangeSA'.
[08/27/2010 19:58:16.0152] [2] [ServiceControl.ps1] Enabling service 'MSExchangeSearch'.
[08/27/2010 19:58:16.0168] [2] [ServiceControl.ps1] Enabling service 'MSExchangeServiceHost'.
[08/27/2010 19:58:16.0183] [2] [ServiceControl.ps1] Enabling service 'MSExchangeThrottling'.
[08/27/2010 19:58:16.0199] [2] [ServiceControl.ps1] Enabling service 'MSExchangeTransportLogSearch'.
[08/27/2010 19:58:16.0214] [2] [ServiceControl.ps1] Enabling service 'MSFTESQL-Exchange'.
[08/27/2010 19:58:16.0230] [2] [ServiceControl.ps1] Enabling service 'RemoteRegistry'.
[08/27/2010 19:58:16.0246] [2] [ServiceControl.ps1] Enabling service 'W3Svc'.
[08/27/2010 19:58:16.0261] [2] [ServiceControl.ps1] Enabling service 'WinMgmt'.
[08/27/2010 19:58:16.0277] [2] [ServiceControl.ps1] Enabling service 'wsbexchange'.
[08/27/2010 19:58:16.0292] [2] [ServiceControl.ps1] Script completed succesfully.
[08/27/2010 19:58:16.0292] [1] Executing:
Start-SetupService -ServiceName RemoteRegistry
[08/27/2010 19:58:16.0308] [2] Active Directory session settings for 'start-SetupService' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:16.0308] [2] Beginning processing Start-SetupService -ServiceName:'RemoteRegistry'
[08/27/2010 19:58:16.0308] [2] Ending processing Start-SetupService
[08/27/2010 19:58:16.0308] [1] Executing:
if(Get-Service winmgmt* | ?{ $_.Name -ieq " winmgmt" })
{
Start-SetupService -ServiceName winmgmt
}

[08/27/2010 19:58:16.0308] [2] Active Directory session settings for 'start-SetupService' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:16.0308] [2] Beginning processing Start-SetupService -ServiceName:'winmgmt'
[08/27/2010 19:58:16.0308] [2] Ending processing Start-SetupService
[08/27/2010 19:58:16.0308] [1] Executing:
Set-LocalPermissions
[08/27/2010 19:58:16.0339] [2] Active Directory session settings for 'Set-LocalPermissions' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:16.0339] [2] Beginning processing Set-LocalPermissions
[08/27/2010 19:58:19.0865] [2] Ending processing Set-LocalPermissions
[08/27/2010 19:58:19.0865] [1] Executing (non-critical):
$mofFilePath = ($RoleInstallPath + " bin\Exchange.MOF" );
$mflFilePath = ($RoleInstallPath + " bin\en\Exchange.MFL" );
compile-moffile -MofFilePath:$mofFilePath;
compile-moffile -MofFilePath:$mflFilePath;

[08/27/2010 19:58:19.0865] [2] Active Directory session settings for 'compile-moffile' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:19.0865] [2] Beginning processing compile-moffile -MofFilePath:'C:\Program Files\Microsoft\Exchange Server\V14\bin\Exchange.MOF'
[08/27/2010 19:58:19.0896] [2] Exchange tracing provider was installed successfully.
[08/27/2010 19:58:19.0896] [2] Ending processing compile-moffile
[08/27/2010 19:58:19.0896] [2] Active Directory session settings for 'compile-moffile' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:19.0896] [2] Beginning processing compile-moffile -MofFilePath:'C:\Program Files\Microsoft\Exchange Server\V14\bin\en\Exchange.MFL'
[08/27/2010 19:58:20.0286] [2] Exchange tracing provider was installed successfully.
[08/27/2010 19:58:20.0286] [2] Ending processing compile-moffile
[08/27/2010 19:58:20.0286] [1] Executing:
Add-FirewallException -FirewallRule (New-Object Microsoft.Exchange.Security.WindowsFirewall.MSExchangeRPCByPortRule)

[08/27/2010 19:58:20.0364] [2] Active Directory session settings for 'add-firewallexception' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:20.0364] [2] Beginning processing Add-FirewallException -FirewallRule:'Microsoft.Exchange.Security.WindowsFirewall.MSExchangeRPCByPortRule'
[08/27/2010 19:58:20.0427] [2] Ending processing Add-FirewallException
[08/27/2010 19:58:20.0427] [1] Executing:
Add-FirewallException -FirewallRule (New-Object Microsoft.Exchange.Security.WindowsFirewall.MSExchangeRPCEPMapByPortRule)

[08/27/2010 19:58:20.0442] [2] Active Directory session settings for 'add-firewallexception' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:20.0442] [2] Beginning processing Add-FirewallException -FirewallRule:'Microsoft.Exchange.Security.WindowsFirewall.MSExchangeRPCEPMapByPortRule'
[08/27/2010 19:58:20.0442] [2] Ending processing Add-FirewallException
[08/27/2010 19:58:20.0442] [1] Processing component 'All Roles Precompile Management Binaries' (Pre-compiling management binaries.).
[08/27/2010 19:58:20.0442] [1] Executing:
$fullPath = [System.IO.Path]::Combine($RoleInstallPath, " bin\microsoft.Exchange.PowerShell.configuration.dll" );
precompile-ManagedBinary -BinaryName $fullPath;

[08/27/2010 19:58:20.0458] [2] Active Directory session settings for 'precompile-ManagedBinary' are: View Entire Forest: 'True', Configuration Domain Controller: '', Preferred Global Catalog: '', Preferred Domain Controllers: '{ }'
[08/27/2010 19:58:20.0458] [2] Beginning processing precompile-ManagedBinary -BinaryName:'C:\Program Files\Microsoft\Exchange Server\V14\bin\microsoft.Exchange.PowerShell.configuration.dll'
[08/27/2010 19:58:20.0458] [2] Starting: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\ngen.exe with arguments: install " C:\Program Files\Microsoft\Exchange Server\V14\bin\microsoft.Exchange.PowerShell.configuration.dll" /queue /nologo /verbose
[08/27/2010 19:58:20.0801] [2] Process standard output: Installing assembly C:\Program Files\Microsoft\Exchange Server\V14\bin\microsoft.Exchange.PowerShell.configuration.dll
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. (Exception from HRESULT: 0x80070422)

[08/27/2010 19:58:20.0801] [2] Process standard error:
[08/27/2010 19:58:20.0848] [2] [ERROR] Unexpected Error
[08/27/2010 19:58:20.0848] [2] [ERROR] Process execution failed with exit code -1.
[08/27/2010 19:58:20.0879] [2] Ending processing precompile-ManagedBinary
[08/27/2010 19:58:20.0926] [1] The following 1 error(s) occurred during task execution:
[08/27/2010 19:58:20.0926] [1] 0. ErrorRecord: Process execution failed with exit code -1.
[08/27/2010 19:58:20.0926] [1] 0. ErrorRecord: Microsoft.Exchange.Configuration.Tasks.TaskException: Process execution failed with exit code -1.
[08/27/2010 19:58:20.0973] [1] [ERROR] The following error was generated when " $error.Clear();
$fullPath = [System.IO.Path]::Combine($RoleInstallPath, " bin\microsoft.Exchange.PowerShell.configuration.dll" );
precompile-ManagedBinary -BinaryName $fullPath;
" was run: " Process execution failed with exit code -1." .
[08/27/2010 19:58:20.0973] [1] [ERROR] Process execution failed with exit code -1.
[08/27/2010 19:58:20.0973] [1] [ERROR-REFERENCE] Id=AllRolesPrecompileManagementBinaries___922e3423e7724c0e8892fe798af5ca08 Component=EXCHANGE14:\Current\Release\Shared\Datacenter\Setup
[08/27/2010 19:58:20.0973] [1] Setup is stopping now because of one or more critical errors.
[08/27/2010 19:58:20.0973] [1] Finished executing component tasks.
[08/27/2010 19:58:21.0004] [1] Ending processing Install-MailboxRole
[08/27/2010 20:07:08.0421] [0] End of Setup
[08/27/2010 20:07:08.0421] [0] **********************************************
 
N

Novak Wu

Hi,

Based on my research, this error can occur by corrupted .Net Framework components. At this stage, I suggest you uninstall .Net Framework 3.5 and .Net Framework 3.5 Service Pack 1, and then reinstall them for a test.

To install .Net Framework 3.5, please refer to the following article:

Install Exchange 2010 Using the Custom Installation Type

Thanks.

Novak Wu
 
G

Gulab Mallah

Hi,

I agree with Novak, it could be the problem with .Net framework.

I have a question, " The Drive used to configure the Exchange Server is it shared between other Servers " ?

If yes than remove the share from the drive.

Cheers,
-Gulab
 
D

DayMare71

Hi Again,

I removed .Net framework and re-installed it, however the SP1 still fails with the same error. No shares.

Thanks
 
N

Novak Wu

Hi,

To assure the corrupted .Net Framework components is removed completely, please uninstall them again. Then, please navigate to the following folder: C:\Windows\Microsoft.NET and clear all items under the folder. Then, please reinstall .Net Framework 3.5 and update Exchange 2010 SP1.

If the issue persists, please also try the following steps. The issue also can occur by missing registry values under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\

1. Click Start menu and type Notepad.

2. Copy the following contents to the Notepad and click Save as.

3. Save the file as the new.reg file.

4. Backup the whole computer registry file.

5. Double click the new.reg file and click Yes to import to the machine.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1]

" Install" =dword:00000001

" PID" =" 89383-100-0001260-04309"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\0409]

" Install" =dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine]

" ApplicationBase" =" C:\\Windows\\System32\\WindowsPowerShell\\v1.0"

" PSCompatibleVersion" =" 1.0, 2.0"

" RuntimeVersion" =" v2.0.50727"

" ConsoleHostAssemblyName" =" Microsoft.PowerShell.ConsoleHost, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=msil"

" ConsoleHostModuleName" =" C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\Microsoft.PowerShell.ConsoleHost.dll"

" PowerShellVersion" =" 2.0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns]

@=" "

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microsoft.Exchange.Management.PowerShell.E2010]

" CustomPSSnapInType" =" Microsoft.Exchange.Management.PowerShell.AdminPSSnapIn"

" ApplicationBase" =" C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin"

" AssemblyName" =" Microsoft.Exchange.PowerShell.Configuration, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

" Description" =" Admin Tasks for the Exchange Server"

" ModuleName" =" C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin\\Microsoft.Exchange.PowerShell.Configuration.dll"

" PowerShellVersion" =" 1.0"

" Vendor" =" Microsoft Corporation"

" Version" =" 14.0.0.0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microsoft.Exchange.Management.PowerShell.Setup]

" CustomPSSnapInType" =" Microsoft.Exchange.Management.PowerShell.SetupPSSnapIn"

" ApplicationBase" =" C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin"

" AssemblyName" =" Microsoft.Exchange.PowerShell.Configuration, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

" Description" =" Setup Tasks for the Exchange Server"

" ModuleName" =" C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin\\Microsoft.Exchange.PowerShell.configuration.dll"

" PowerShellVersion" =" 1.0"

" Vendor" =" Microsoft"

" Version" =" 14.0.0.0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellSnapIns\Microsoft.Exchange.Management.Powershell.Support]

" CustomPSSnapInType" =" Microsoft.Exchange.Management.Powershell.Support.SupportPSSnapIn"

" ApplicationBase" =" C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin"

" AssemblyName" =" Microsoft.Exchange.Management.Powershell.Support, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"

" Description" =" Support Tasks for the Exchange Server"

" ModuleName" =" C:\\Program Files\\Microsoft\\Exchange Server\\V14\\bin\\Microsoft.Exchange.Management.Powershell.Support.dll"

" PowerShellVersion" =" 1.0"

" Vendor" =" Microsoft Corporation"

" Version" =" 14.0.0.0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PSConfigurationProviders]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PSConfigurationProviders\Microsoft.PowerShell]

" ApplicationBase" =" C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\"

" AssemblyName" =" System.Management.Automation, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, ProcessorArchitecture=msil"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds\Microsoft.PowerShell]

" ExecutionPolicy" =" RemoteSigned"

" Path" =" C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\powershell.exe"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds\ScriptedDiagnostics]

" ExecutionPolicy" =" Unrestricted"

Hope this helps.

Novak Wu
 
D

DayMare71

Unfortunately it did not resolve the issue. I have opened a support call with Microsoft at this point. Thanks for your assistance.
 
B

Brian Day MCITP

Good luck. Please let us know of the outcome if you can.Microsoft Premier Field Engineer, Exchange
MCSA 2000/2003, CCNA
MCITP: Enterprise Messaging Administrator 2010
Former Microsoft MVP, Exchange Server
My posts are provided "AS IS" with no guarantees, no warranties, and they confer no rights.
 
C

Chan Ouyang

Hi,

Do you get answer from Microsoft? I get the same error on the same installation. Thanks.
 
L

lukval

Enabling Microsoft .NET Framework NGEN v2.0.50727_X64 (clr_optimization_v2.0.50727_64) service helps.

My first result was:
--------- Hub Transport Role
Failed

Error:
The following error was generated when " $error.Clear();
$fullPath = [System.IO.Path]::Combine($RoleInstallPath, " bin\microsoft.Exchange.PowerShell.configuration.dll" );
precompile-ManagedBinary -BinaryName $fullPath;
" was run: " Process execution failed with exit code -1." .

Process execution failed with exit code -1.
Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp

Elapsed Time: 00:00:18
---------I had ngen service disabled because Security Configuration Wizard...

After SCW ngen config the installation ended succesfully.

Thank you Chan Ouyang !

----- Lukas -----
 

Top