Free Busy Not Working...

  • Thread starter mholzer54
  • Start date Views 3,119
Status
Not open for further replies.
M

mholzer54

I am having problems where the apparently the old server's Free Busy is still connected even though it is off now and I cannot get free/busy info in Outlook. Any ideas on how to fix this? Here is the status I receive:

[PS] C:\Windows\system32>get-publicfolder -Identity " \NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY" -Recurse | fl name,Replicas
Name : SCHEDULE+ FREE BUSY
Replicas : {}

Name : EX:/o=APPINC/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)
Replicas : {Public Folder Database 1271002183}

Name : EX:/o=APPINC/ou=first administrative group
Replicas : {APPDC01\First Storage Group\Public Folder Store (APPDC01)}
 
B

Brian Day MCITP

What version of Outlook? Does it work in OWA?Microsoft Premier Field Engineer, Exchange
MCSA 2000/2003, CCNA
MCITP: Enterprise Messaging Administrator 2010
Former Microsoft MVP, Exchange Server
My posts are provided "AS IS" with no guarantees, no warranties, and they confer no rights.
 
J

James-Luo

Please use the example below to change the replica from old server to current server

Set-PublicFolder " \My Public Folder" -Replicas " Server02\PFDatabase02" ," Server03\PFDatabase03"

Configure Public Folder Replication

Please also confirm that outlook version is lower than 2007, because you don"t have to use public folder to retrieve free/busy information on outlook 2007 and later version

James Luo

 
J

Jonas Andersson [MCITP]

Hi

Before removing the old server, make sure you replicate and move the folders and hierarchy to the new one..

This will add replica of public folders on Exchange Server 2003 to Exchange Server 2010. This is the simplest way to add replica of all PFs to Exchange 2010 PF database.

C:\Program Files\Microsoft\Exchange Server\V14\Scripts>.\AddReplicaToPFRecursive.ps1 -TopPublicFolder " \" -ServerToAdd " exchange2010"

Once the replica is added the next step is to move the replica from Exchange 2003 to Exchange 2010. To do this, jump to scripts directory and run following command.

C:\Program Files\Microsoft\Exchange Server\V14\Scripts>.\MoveAllReplicas.ps1 -Server " Exchange2003" -NewServer " Exchange2010"

Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
 
M

mholzer54

Outlook 2010. And I get no free busy info either on OWA. The guy who " helped" me with the migration really screwed me up with this.
 
B

Brian Day MCITP

And I get no free busy info either on OWA.

This is the key piece of information because OWA uses the Availability Service and only goes back to PFs if the user it is trying to find is on Exchange 2003.

Are all of the users on 2010 now?

Microsoft Premier Field Engineer, Exchange
MCSA 2000/2003, CCNA
MCITP: Enterprise Messaging Administrator 2010
Former Microsoft MVP, Exchange Server
My posts are provided "AS IS" with no guarantees, no warranties, and they confer no rights.
 
M

mholzer54

Yes... We did a complete refresh of all the machines to Office 2010.
 
B

Brian Day MCITP

Sorry, I meant are all of the user mailboxes moved to Exchange 2010 servers now?

Are the users able to modify inbox rules?

Did you configure your Web Services Virtual Directories appropriately?

Get/Set-WebServicesVirtualDirectory is the cmdlet to use if you do it through EMS.

Microsoft Premier Field Engineer, Exchange
MCSA 2000/2003, CCNA
MCITP: Enterprise Messaging Administrator 2010
Former Microsoft MVP, Exchange Server
My posts are provided "AS IS" with no guarantees, no warranties, and they confer no rights.
 
M

mholzer54

All mailboxes are on 2010 Exchange now. I will check the EMS command again.
 
M

mholzer54

Sorry - forgot to mention that I created and tested an inbox rule and it worked perfectly.
 
M

mholzer54

Tried Set-Webservices... Got the following result:

Set-WebServicesVirtualDirectory -Identity " EXCSRV.domain.com\EWS(default Web site)" -ExternalUrl https://mail1.domain.com/EWS/exchange.asmx -BasicAuthentication $true -InternalUrl https://https://excsrv.domain.local/EWS/exchange.asmx

The operation couldn't be performed because object 'EXCSRV.domain.com\EWS(default Web site)' couldn't be found on 'MSSRV.domain.local'.
+ CategoryInfo : NotSpecified: (0:Int32) [Set-WebServicesVirtualDirectory], ManagementObjectNotFoundException
+ FullyQualifiedErrorId : 76AC1EB4,Microsoft.Exchange.Management.SystemConfigurationTasks.SetWebServicesVirtualDirectory
 
J

James-Luo

Please post the output of “Get-WebServicesVirtualDirectory”

Please verify if the EWS virtual directory is working by accessing the URL below, you shall see a lot of XML info. If the error returns from IE, please refer to KB 943891

HTTPS://<Exchange 2010 CAS FQDN>/EWS/Exchange.asmx

The value of &ldquo;Identity&rdquo; parameter of the &ldquo;Set-WebServicesVirtualDirectory&rdquo; cmdlet should look like &ldquo;ServerNetBIOSName\EWS(default Web site)&rdquo;

And please don"t enable basic authentication, which is &ldquo;false&rdquo; by default

James Luo

 
M

mholzer54

[PS] C:\Windows\system32>Get-WebServicesVirtualDirectory -Identity " EXCSRV\EWS(default Web site)"
The operation couldn't be performed because object 'EXCSRV\EWS(default Web site)' couldn't be found on 'MSSRV.domain.local'.
+ CategoryInfo : NotSpecified: :)) [Get-WebServicesVirtualDirectory], ManagementObjectNotFoundException
+ FullyQualifiedErrorId : 27896D19,Microsoft.Exchange.Management.SystemConfigurationTasks.GetWebServicesVirtualDirectory
 
M

mholzer54

By the way, thanks for all the help.

Here is the error I receive from that link:

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.
Parser Error Message: The element 'buildProviders' cannot be defined below the application level.
Source Error:


Line 2573: Line 2574: <compilation> Line 2575: <buildProviders> Line 2576: <remove extension=" .asmx" /> Line 2577: <add extension=" .asmx"

Source File: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\exchweb\ews\web.config Line: 2575


Version Information: Microsoft .NET Framework Version:2.0.50727.4952; ASP.NET Version:2.0.50727.4927
Server Error in '/' Application. Configuration Error
 
J

James-Luo

Sorry, I didn"t add the space in the cmdlet above. There"s a space break between &ldquo;EWS&rdquo; and &ldquo;(default Web site)&rdquo;, otherwise, same error information will appear

ServerNetBIOSName\EWS (default Web site)

James Luo

 
M

mholzer54

Same error. I am trying to understand why it is saying that it cannot find it on my domain controller. Why is it looking there?

The operation couldn't be performed because object 'ExCSRV\EWS(default Web site)' couldn't be found on 'MSSRV.domain.local'. MSSRV is my Domain Controller and FSMO owner. Exchange 2010 and its associated IIS controls are on my EXCSRV server. I would so love to reinstall but this is a live exchange and it otherwise is passing e-mails, etc. Just OOF and FreeBusy info are not working.
 
Status
Not open for further replies.
Top