Exchange 2010 Queue viewer Problem

  • Thread starter Moaffak
  • Start date Views 3,137
M

Moaffak

Hi ...

when i open queue viewer i get error massage " the query produced too many result . to reduce the number of result , use more restrictive filter .... "

before i was able to open queue viewer and found very big number of objects !!!

also when i open performance tab from task manager the ram all the time is busy

if i send any mail to outside it take long time to deliver ?

this is tow screen shot from my issues

1: queue viewer

2 : Server performance

please i need help ASAP
 
K

ktolik_iname.com

How many users/mailboxes you have on the Exchange server? How many Exchange servers in the organization? Do you have any other roles installed on the server in question (DNS, File server, DC etc)?
 
A

Aivar75

hi
what about using powershell and using command get-queue -resultsize unlimited and piping it out to a txt file or so.
then you could look whats in the queue without having server to do extra work showing it in screen.

other thing you could check is use perfmon and netstat (netstat pipe out to txt file, easier to read afterwards)
 
M

Moaffak

i have only 90 users , and i have just one exchange server , No i don't have any other roles
 
M

Moaffak

i have update in my problem ,, now i can open queue viewer when i changed the queue directory from EdgeTransport.exe.config file ... and also i found very big number of objects more than 200,000 i think its SPAM mails , if i change queue directory its gone for sometimes and everything work fine but the spam massages comeback again after one or tow hours and my system hang

PLEASE HELP ME !!!
 
M

Moaffak

Thank you Gavin-Zhang for your feedback ..
i installed forefront for exchange and configured but still i have big numbers of massages in queue viewer with strange (from address - subject) ... and in queue tab also i have big number of strange domains ...

how i can protect my exchange from this massages i installed anti Spam Script from shill and installed forefront for exchange ..

i have 90 users all users use outlook to connect exchange server through POP & IMAP
 
K

ktolik_iname.com

As mentioned above, make sure you enabled Anti-Spam features. Once you have the Anti-Spam tab under Organization Configuration/Hub Transport, click on it, go to Recepient Filtering properties, and under Blocked Recepients, make sure " Block messages sent to recipients that do not exist in the directory" option is checked.
 
J

Jonas Andersson [MCITP]

I can recommend Forefront for Exchange, it works really well !

Or else go with a 3rd part or appliance solution

Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
 

Similar threads

Top