Outlook 2007 & Attachment Previewers in a Terminal Services Environment

Status
Not open for further replies.
M

Mr 1JZ

Hi guys, I'm really hoping some of you can help me out on this one as I am completely stumped. I am having an issue with the basic file previewers in Outlook 2007. The server is running Windows Server 2008 Standard 32-bit.

When attempting to preview an attachment (such as an Excel or PDF file), I get a message stating This file cannot be previewed because the following previewer has been disabled .

If the user goes into Trust Centre > Attachment Handling > Attachment and Document Previewers > the user cannot turn on any of the previewers in there as they are greyed out. I've tried searching everywhere on the web, trawled through Group Policy, used Process Monitor to see if I could find an associated registry key which could be causing this but nothing.

I've tried re-installing Office, installed MSDN previewers, and even added a test user to the local Administrators group but nothing seems to enable me to enable these file previewers.

I have a feeling it's a Group Policy Object which is causing all this but I can't figure out which one. Any assistance would be greatly appreciated.
 
H

Harry Yuan

Hi,

Please verify if the issue occur to all the users.

Please check if the connection has been set on the terminal server.

Please try to create a new windows profile and outlook profile to check the issue again.

Please check if other outlook users(not access outlook from terminal) have the issue.

Also please check the event viewer to see if any error event have been logged there. Please post the detail error information here.

Besides, please check the article below and try to add the register to see if the issue will disappear.

Error message when you start Outlook 2007 to configure an Exchange 2003 mailbox if the AutoDiscover\'ZeroConfigExchange' policy is set: " The connection to Microsoft Exchange is unavailable"

http://support.microsoft.com/default.aspx/kb/927481

Error messages when you try to connect Outlook 2007 to Exchange Server: " The action cannot be completed" or " Your Microsoft Exchange Server is unavailable" or " Cannot start Microsoft Office Outlook"

http://support.microsoft.com/kb/913843

Regards,

Harry
 
M

Mr 1JZ

Hi Harry.

Thanks for the reply. I have found a resolution to this issue through the process of elimination. I will answer your questions above anyway.

Please verify if the issue occur to all users : Yes, the issue occurs for all users on the same Terminal Server.

Please check if the connection has been set on the terminal server : I am not sure what you mean by this question, sorry.

Please try to create a new windows profile and outlook profile to check the issue again : I did this multiple times, it did not fix the problem.

Also please check the event viewer to see if any error event have been logged there. Please post the detail error information here : There was nothing in the Event Logs as the user is not experiencing any actual error messages. The Outlook previewers were just all greyed out in the Trust Centre.

Besides, please check the article below and try to add the register to see if the issue will disappear : We are running an Exchange 2007 environment, so the first article is not relevant. Users are not receiving any error messages either, so the second article is also not relevant.

Onto the answer. We have a base Windows Server 2008 Terminal Services Group Policy we use to lock the servers down. I created a test account and disabled all policies from running for this test account by denying the user account permissions to the policies. Upon logging into the problematic TS with the test account (which had a new profile as well), I was able to manually turn off and on each Outlook preview handler. So I surmised it was something in our policy which was causing this issue.

After about an hour, I found the Group Policy object Allow only per user or approved shell extensions was the cause of the issue (found in User Configuration > Policies > Administrative Templates > Windows Components > Windows Explorer ). If this policy was set to Enabled , the Outlook preview handlers become greyed out. This is because the preview handlers (also known as shell extensions) needed to be added as entries to the HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved\ area in the registry. Adding each of the preview handler's shell extension GUID's to this part of the registry resolved the problem for me. Please note that Microsoft say the GUID's can also be added in the same location in the HKEY_CURRENT_USER hive but I wasn't able to get this working properly.

Problem resolved!
 
Status
Not open for further replies.
Top