Archive settings are missing from the file menu and the options/other tab.

Not open for further replies.


All settings for archive and auto-srchive are gone! It's like that function has been removed from my Outlook installation. I ran Office repair from the control panel/Programs and features, still have the problem. Running Windows 7 64bit with IE9 beta installed. Auto-archive ran last month, but its gone now.


PS- I ran Inbox repair tool on both files (outlook.pst and archive.pst) still don't have the archive function available.

Ben M. Schorr [MVP]

It appears to be a known issue with the update that came out on Tuesday - KB2412171. You can wait to see if a fix comes along or just uninstall that update and it will probably restore the archive functionality.


Hi Ben,

Thanks for this answer, I have the same problem and all my coworkers as well. Any idea when we can expect the fix? It is out of question for us to roll back an installation, it is against the procedure. Similarly we cannot change the rules for archiving. And because of the Christmas holidays many users need to archive... tomorrow :)

I don't know how to manage this situation. Any suggestion would be highly welcome!




Glad to have this answer. I was going crazy trying to find the Archive settings. Also, since the upgrade last night my Outlook 2007 has been running VERY SLOWLY. I also had to delete and recreate my Comcast email account because it would no longer connect to the server. I don't know what the update was supposed to accomplish, but it made Outlook worse.



"Shack!" (i.e. Spot on!) Thanks for the insight. Now I can quit wasting my time on something that broke 'from the inside'.

Ben M. Schorr [MVP]

O.K., I just checked and sure enough the link seems to be broken. I notified the Outlook team of the broken link and hopefully it'll be back on it's feet very soon.

Sorry about that.


Ben -

Removed KB2412171, which did fix the performance issue. However auto archive is still missing in the menus. Using Outlook Tools 2.3 I was able to get auto archive feature back, by opening in safe mode, but not safe:1-4, or usint the noextentions switch. Any ideas on how to get auto archive back without running in safe mode? Thanks.

Sam. Windows 7 64-bit, Outlook 2007
Not open for further replies.