Unable to open/preview attachments in Outlook 2010

Status
Not open for further replies.
R

roniziv

This question was asked a couple of times before but none of the solutions provided seemed to resolve my case.

Recently I have upgraded from Office 2007 to Office 2010. A short while after the upgrade I noticed that I cannot open Office attachments in Outlook or preview them. After some digging in Internet forums (this forum also) and trying various methods I came to the conclusion that Office is unable to open documents in " protected mode" . When I disabled the " protected mode" in the Trust Center settings attachments open fine but still I cannot preview them.

I saw two solutions to this problems in past forum threads:
Use dcomcnfg to correct the default authentication and default impersonation levels Use regedit to change permission on the HKLM\Software\Policies\Microsoft\Windows NT\Rpc key

I tried to follow both solutions but on my machine the dcomcnfg was already set to the suggested settings (I tried both the connect and default authentication levels) and the Rpc key does not exist.

I have a Windows 7 Enterprise machine and Office 2010 Professional Plus. Right now I'm workind with the workaround of disabling the protected mode, this enables me to open the attachments but not to preview them and is obviously a less secure mode of operation. One more note Office 2007 worked fine in the scenario, the problem only started after the upgrade to Office 2010.

Are there any other solutions to this problem?
 
H

Harry Yuan

Hi,

From your description , I understand that you cannot open/preview attachments in Outlook 2010.

Save the file / attachments locally. Right-click, select Properties, click Unblock at the bottom, and finally click OK.

Now you should be able to open the attachments as expected.

Also you can try referring to the KB article:

You may receive an " Outlook blocked access to the following potentially unsafe attachments" message in Outlook

http://support.microsoft.com/kb/829982

Sincerely,

Harry
 
R

roniziv

Hi Harry,

thanks for your reply but what you suggest is essentially the same workaround that I did. By " unblocking" the file word/excel/ppt do not attempt to open it in protected mode. As I have said I have completely disabled the protected mode and thus it is unnecessary to save the attachment and unblock it.

I'm still looking for a method to be able to open files in Office protected mode.

thanks,
Roni
 
H

Harry Yuan

Hi,

Try to set Word as Default Program.

Click the start button. You should see in the start menu for " Default Programs" . This will open the Default Programs window. Look for the " Associate a file type or protocol with a program." Click that link and you will see the Set Associations Control Panel applet. If you don't see this in your start menu, just type " Default Programs" in the Start Menu search box and it will show up in the menu above.

Once you're in the Set Associations applet, scroll through the list to find the " .doc" , " .docx" and any other file types that you want to open in Word. Select each one in the left column, click the " Change" button, and then step through the " Open With" dialogs to select Word as the default program for these file types.

You should probably include all of these for Word:

> .doc

> .docx

> .dochtml

> .docm

> .docxml

> .dot

> .dothtml

> .dotm

> .dotx

> .rtf

> .wbk

> .wiz

Sincerely,
Harry
 
R

roniziv

Hi Harry,

I tried your suggestion but it didn't solve the problem.

Regards,
Roni
 
Status
Not open for further replies.
Top