Exchange 2010 Recovery Database: WMI Problem?

Status
Not open for further replies.
U

userTP

Hi,
I am trying to create a Recovery Database using following command on Exchange Management Shell (as advised in here: http://technet.microsoft.com/en-us/library/ee332321.aspx):
New-MailboxDatabase -Recovery -Name RDB1 -Server SERVERNAME -EdbFilePath " Y:\Recovery Database\Mailbox Database1\Mailbox Database1.edb" -LogFolderPath " Y:\Recovery Database\Mailbox Database1"
It takes some time (maybe a few minutes) and then I get some error messages:
Creating a new session for implicit remoting of " New-MailboxDatabase" command...
Failed to connect to target server " SERVERNAME" . Error: WMI exception occurred on server 'SERVER.domain.com': Quota violation
+ CategoryInfo : InvalidOperation: :)) [New-MailboxDatabase], InvalidOperationException
+ FullyQualifiedErrorId : 72FFD023,Microsoft.Exchange.Management.SystemConfigurationTasks.NewMailboxDatabase
Before entering that command I restored an older version of our MailboxDatabase using Shadow Copy and copied the files into that folder (Y:\Recovery Database). I can see that the log files and also " Mailbox Database1.edb" are both on that folder (" Y:\Recovery Database\Mailbox Database1" ) I am referring with command above.
I am logged in as an Administrator and also started the Exchange Management Shell using " Run as Administrator" option.
What could be the problem? Am I doing something in the wrong way or is there maybe some problem in the syntax of that command I'm using?
I've been trying to find answer but so far haven't found anything related to those error messages. Apparently the problem must be related somehow to WMI?
We are using Microsoft Exchange 2010 Version: 14.00.0694.000.
I have tried using command " Get-WmiObject -Namespace " root\cimv2" -Class Win32_Process -Impersonation 3 -ComputerName SERVERNAME" to make WMI connection but that didn't help either (some information here: http://msdn.microsoft.com/en-us/library/ee309377(VS.85).aspx).
 
U

userTP

I am still getting the same error message:
Failed to connect to target server " SERVERNAME" . Error: WMI exception occurred on server 'SERVER.domain.com': Quota violation
+ CategoryInfo : InvalidOperation: :)) [New-MailboxDatabase], InvalidOperationException
+ FullyQualifiedErrorId : 72FFD023,Microsoft.Exchange.Management.SystemConfigurationTasks.NewMailboxDatabase

We are now using Exchange 2010 SP1 and I have managed to make other recovery databases but this one doesn't work. The problem is that those databases that I successfully created as recovery databases are too new versions so I can't restore the files needed to. Any help would be appreciated!
 
G

Gulab Mallah

Check the event id 2080 in application log and post the resultGulab | Skype: gulab.mallah
 
U

userTP

Unfortunately I couldn't find any event with id 2080. However when looking at MSExchange Management log under Applications and Services Logs I found following error that is related to this issue (event ID 6):

Genereal tab:

Cmdlet failed. Cmdlet New-MailboxDatabase, parameters {Recovery=True, Name=RDB4, Server=SERVER, EdbFilePath=Y:\RDB4\Mailbox Database1.edb, LogFolderPath=y:\RDB4}.

Details tab:

- System
- Provider
[ Name] MSExchange CmdletLogs
- EventID 6
[ Qualifiers] 49152
Level 2
Task 1
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2010-12-03T13:44:07.000000000Z
EventRecordID 47
Channel MSExchange Management
Computer SERVER
Security

- EventData
New-MailboxDatabase
{Recovery=True, Name=RDB4, Server=SERVER, EdbFilePath=Y:\RDB4\Mailbox Database1.edb, LogFolderPath=y:\RDB4}
domain/Users/Administrator
S-1-5-21-1715567821-x
S-1-5-21-1715567821-x
ServerRemoteHost-Unknown
8768

32
00:09:34.5324000
View Entire Forest: 'False', Default Scope: 'domain', Configuration Domain Controller: '<server2>.domain', Preferred Global Catalog: '<server3>.domain', Preferred Domain Controllers: '{ <server3>.domain }'
System.InvalidOperationException: Failed to connect to target server " SERVER" . Error: WMI exception occurred on server 'SERVER.domain': Quota violation
7

PS. Database is in 'Clean shutdown' state
 
Status
Not open for further replies.
Top