The export process to the .pst files very slow with New-MailboxExportRequest

Status
Not open for further replies.
P

Partyface.MSN

We are upgrading Exchange 2010 to SP1 and a new possibility export mailboxes to .pst file (without outlook) ( New-MailboxExportRequest) is very slow. After the queue checking (Get-MailboxExportRequest) we recognized the process works only 5 threads and realy very very slow. Maxthreads option does not exist.
Any help would be appreciated.
 
K

Kendisk

I have the exact same problem, been running a overnight script that queues up the mailboxes for export. When i check my logs in the morning only about 6 mailboxes export successfully.

Found this article which indicates the replication service is causing problems with mailbox moves. Wonder if there is any reason this could be slowing down or failing exports using the new sp1 commands.

http://blogs.dirteam.com/blogs/davestork/archive/2010/02/16/mailbox-replication-service-unexpectedly-quits-when-moving-mailboxes-from-other-exchange-server.aspx

If anyone else has any ideas on how to get the new sp1 exports working im all ears.

In regard to the maxthread option have a look at this article for a workaround.

http://blogs.technet.com/b/nawar/archive/2010/10/06/slow-mailbox-move-with-exchange-2010-sp1.aspx
 
B

Brian Desmond -MVP-

Hi-

There may be some settings for concurrency in the config file for the MRS - Look in the bin folder under your Exchange install for the MSExchangeMailboxReplicationService.exe.config file (might be called something slightly different). My limited experience is that this process is resource intensive and not particuarly speedy but it's also typically not something you do alot of or en-masse. Keep in mind that the storage you're writing to needs to be able to keep up and that every CAS server in the site will participate so you can get some concurrency there.

My Book - Active Directory, 4th Edition
My Blog - www.briandesmond.com
 
B

Brian Day MCITP

Are you using a CAS array that goes through any kind of hardware load balancer? If so, what make/model is it?Microsoft Premier Field Engineer, Exchange
MCSA 2000/2003, CCNA
MCITP: Enterprise Messaging Administrator 2010
Former Microsoft MVP, Exchange Server
My posts are provided "AS IS" with no guarantees, no warranties, and they confer no rights.
 
P

Partyface.MSN

Hi Brian and Brian :)
I changed MSExchangeMailboxReplicationService.exe.config values from default to:
MaxActiveMovesPerSourceMDB = " 50"
MaxActiveMovesPerTargetMDB = " 50"
MaxActiveMovesPerSourceServer = " 50"
MaxActiveMovesPerTargetServer = " 50"
MaxTotalMovesPerMRS = " 100"

but there is no change unfortunately, 5 mailboxes are in the queue. Certainly I restart mailboxreplication service.

We don't use any hardware load balancer, we are running a simple storage volume.

thank you in advance
 
B

Basti78

We also have recognized this problem.
One look at our resource monitor shows a disk queue length of 5 and higher on the target server while the export script runs. So, it seems to me this is a bottleneck of the disk i/o or in other words, the replication is not optimized for it. We also recognized that it doesn't matter which kind of disk subsystem is used. We could see this behavior on normal sata disks as well as on a RAID 6 volume with round about 1500 IOPS.
I hope someone have an idea for this. Any ideas, hints oder solutions are appreciated.

Bastian
 
B

Basti78

On further investigations, the " System" process is responsible for the high iops count. I did a complete clean installation with integrated sp1. No differences.

I will make further researches, but if someone can agree to my researches or results, please let me know.
 
Status
Not open for further replies.
Top