mapiexceptioncallfailed: unable to mount database when activate mailboxdatabase in dag

  • Thread starter ViktorIv
  • Start date Views 4,933
V

ViktorIv

I have upgraded from Exchange 2003 to exchange 2010 sp1 UR2 environment with dag. When I try activate mailboxbase on other server I see the next error:

An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExcept
ionCallFailed: Unable to mount database. (hr=0x80004005, ec=1012)
.. [Database: 333, Server: KTG-EXCH03.ktg.int]
+ CategoryInfo : InvalidOperation: (333:ADObjectId) [Move-ActiveMailboxDatabase], AmDbActionWrapperExcept
ion
+ FullyQualifiedErrorId : 855454E0,Microsoft.Exchange.Management.SystemConfigurationTasks.MoveActiveMailboxDatabas
e

after that error database has dismount state on the target server and health state on the source server. If I activate after that database on the first server database change state to mount state on the first server and health state on the second server. There is the same if i create other database or other dag. That error was on exchange 2010 rtm environment and there no effect after upgrade to sp1 ur2.
 
J

James-Luo

Quote: “If I activate after that database on the first server database change state to mount state on the first server and health state on the second server”

Do you mean that you try to perform “Move-ActiveMailboxDatabase” to activate the database copy on the first server again?

So, the issue is that the database copies can"t be activated on the second server, even with newly created database copies, right?

Quote: “after that error database has dismount state on the target server and health state on the source server”

Please check if there"s any error event in the application log on the DAG members after reproduced the issue. Also, please try to mount the database copy on the target server, and check the event log for more information

Have you put the database files on the SAN drive instead of local drive? If so, please check the result if you create the database on the local drive, and monitor the result

Please run ExBPA against the exchange servers for health check


 
V

ViktorIv

This error happened if I try to activate mailboxdatabase copy on the first server perfoming from EMC " Activate Database Copy.." command

If I try to perfom " Move-ActiveMailboxdatabase" cmdlet the error is the same except FullyQualifiedErrorId : 1D3BEF9F

Quote: So, the issue is that the database copies can"t be activated on the second server, even with newly created database copies, right?

Yes. This is the problem with copies of databases within DAG only. The database work perfect if it doesn't have a copy

There are errors from application log when I perfomed " Move-ActiveMailboxdatabase" cmdlet:

Log Name: Application
Source: MSExchangeIS Mailbox Store
Date: 23.12.2010 23:27:09
Event ID: 7202
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
The database " 333" has been copied from the server KTG-EXCH04 to the server KTG-EXCH03.
In the Exchange Management Console, indicate that the database can be overwritten by a restore, so that it can be patched.

Log Name: Application
Source: MSExchangeIS
Date: 23.12.2010 23:27:09
Event ID: 9519
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
While starting database 333, the following error occurred: 0x3f4.
Failed to configure MDB.

Log Name: Application
Source: MSExchangeIS
Date: 23.12.2010 23:27:09
Event ID: 9519
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
While starting database 333, the following error occurred: 0x3f4.
Start DB failed..

Log Name: Application
Source: ExchangeStoreDB
Date: 23.12.2010 23:27:09
Event ID: 128
Task Category: Database recovery
Level: Error
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
At '23.12.2010 23:27:09' the copy of database '333' on this server encountered an error during the mount operation. For more details about the failure, consult the Event log on the server for other " ExchangeStoreDb" or " msexchangerepl" events. The mount operation will be automatically retried.

When I try remount database on the target server I get these information events:

Log Name: Application
Source: MSExchangeRepl
Date: 23.12.2010 23:45:50
Event ID: 4114
Task Category: Service
Level: Information
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
Database redundancy health check passed.
Database copy: 333

Redundancy count: 2

Errors:
================
Summary Status
================
Name Status RealCopyQueu InspectorQue ReplayQueue CIState
e ue
---- ------ ------------ ------------ ----------- -----
333\KTG-EXCH04 Healthy 0 0 0 Healthy

333\KTG-EXCH03 Dismounted 0 0 0 Healthy
===============
Full Status
===============

Identity : 333\KTG-EXCH04
Name : 333\KTG-EXCH04
DatabaseName : 333
Status : Healthy
MailboxServer : KTG-EXCH04
ActiveDatabaseCopy : KTG-EXCH03
ActivationSuspended : False
ActionInitiator : Administrator
ErrorMessage :
ErrorEventId :
ExtendedErrorInfo :
SuspendComment :
SinglePageRestore : 0
ContentIndexState : Healthy
ContentIndexErrorMessage :
CopyQueueLength : 0
ReplayQueueLength : 0
LatestAvailableLogTime : 23.12.2010 23:27:13
LastCopyNotificationedLogTime : 23.12.2010 23:27:13
LastCopiedLogTime : 23.12.2010 23:27:13
LastInspectedLogTime : 23.12.2010 23:27:13
LastReplayedLogTime : 23.12.2010 23:27:13
LastLogGenerated : 372
LastLogCopyNotified : 372
LastLogCopied : 372
LastLogInspected : 372
LastLogReplayed : 372
LogsReplayedSinceInstanceStart : 1
LogsCopiedSinceInstanceStart : 0
LatestFullBackupTime :
LatestIncrementalBackupTime :
LatestDifferentialBackupTime :
LatestCopyBackupTime :
SnapshotBackup :
SnapshotLatestFullBackup :
SnapshotLatestIncrementalBackup :
SnapshotLatestDifferentialBackup :
SnapshotLatestCopyBackup :
LogReplayQueueIncreasing : False
LogCopyQueueIncreasing : False
OutstandingDumpsterRequests : {}
OutgoingConnections :
IncomingLogCopyingNetwork :
SeedingNetwork :
ActiveCopy : False

Identity : 333\KTG-EXCH03
Name : 333\KTG-EXCH03
DatabaseName : 333
Status : Dismounted
MailboxServer : 333\KTG-EXCH03
ActiveDatabaseCopy : ktg-exch03
ActivationSuspended : False
ActionInitiator : Service
ErrorMessage :
ErrorEventId :
ExtendedErrorInfo :
SuspendComment :
SinglePageRestore : 0
ContentIndexState : Healthy
ContentIndexErrorMessage :
CopyQueueLength : 0
ReplayQueueLength : 0
LatestAvailableLogTime :
LastCopyNotificationedLogTime :
LastCopiedLogTime :
LastInspectedLogTime :
LastReplayedLogTime :
LastLogGenerated : 0
LastLogCopyNotified : 0
LastLogCopied : 0
LastLogInspected : 0
LastLogReplayed : 0
LogsReplayedSinceInstanceStart : 0
LogsCopiedSinceInstanceStart : 0
LatestFullBackupTime :
LatestIncrementalBackupTime :
LatestDifferentialBackupTime :
LatestCopyBackupTime :
SnapshotBackup :
SnapshotLatestFullBackup :
SnapshotLatestIncrementalBackup :
SnapshotLatestDifferentialBackup :
SnapshotLatestCopyBackup :
LogReplayQueueIncreasing : False
LogCopyQueueIncreasing : False
OutstandingDumpsterRequests : {}
OutgoingConnections :
IncomingLogCopyingNetwork :
SeedingNetwork :
ActiveCopy : True
Log Name: Application
Source: MSExchangeRepl
Date: 23.12.2010 23:49:54
Event ID: 2013
Task Category: Service
Level: Information
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
Replication instance for database 333 found an invalid copy of log file C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\333\E02.log. The log file has been moved to C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\333\IgnoredLogs\E00OutofDate\2010-12-23T20-49-54E02.log. Reason: The log file generation is out of date..

Log Name: Application
Source: MSExchangeIS Mailbox Store
Date: 23.12.2010 23:49:54
Event ID: 1000
Task Category: General
Level: Information
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
Attempting to start the Information Store " 333" .

Log Name: Application
Source: MSExchangeRepl
Date: 23.12.2010 23:49:55
Event ID: 2114
Task Category: Service
Level: Information
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
The replication instance for database 333 has started copying log files. The first log file copied was generation 373.

Log Name: Application
Source: MSExchangeRepl
Date: 23.12.2010 23:50:06
Event ID: 2157
Task Category: Service
Level: Information
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
The replication instance for database 333 has copied and replayed multiple logs.

Log Name: Application
Source: MSExchange Search Indexer
Date: 23.12.2010 23:50:55
Event ID: 108
Task Category: General
Level: Information
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
Exchange Search Indexer has enabled indexing for the Mailbox Database 333 (GUID = b454f5df-4492-4250-9a1c-e03a457a45fb).

Quote: Have you put the database files on the SAN drive instead of local drive? If so, please check the result if you create the database on the local drive, and monitor the result

Yes, My exchange severs are virtual machines and so my database files are on the SAN. I tried to put VM's files on another (empty) storage without other VMs and another hosts but error was the same.

Unfortunately I can't try to put database on server's local drive because all our infrastructure is virtual (this is the enterprise policy). There is no any problem with other virtual machines that running on the same hosts and the SAN.

ExBPA doesn't show any error or warnings

Also there are running SCOM 2007R2 agents on the Exchange and DC's servers and SCOM doesn't provide additional information
 
J

James-Luo

So, let"s say, you try to activate the passive copy on KTG-EXCH03 (Target server) from KTG-EXCH04 (Source server), and the error events start to appear on KTG-EXCH03. Then, passive copy failed to be mounted

Is there any further related event after event 108?

Please compare the database size, the index files and log number between two servers


 
V

ViktorIv

Quote: Is there any further related event after event 108?

there is no related, Just only the perfomance report

Log Name: Application
Source: MSExchangeIS
Date: 23.12.2010 23:52:14
Event ID: 9826
Task Category: Performance
Level: Information
Keywords: Classic
User: N/A
Computer: ktg-exch03.ktg.int
Description:
Starting from 23.12.2010 21:52:14 service Exchange Availability Service has performed this activity on the server:
RPC Operations: 2560.
Database Pages Read: 0 (of which 0 pages preread).
Database Pages Updated: 0 (of which 0 pages reupdated).
Database Log Records Generated: 0.
Database Log Records Bytes Generated: 0.
Time in Server: 79 ms.
Time in User Mode: 79 ms.
Time in Kernel Mode: 0 ms.

and Id 2080 Topology Task

> edb files have different size (no changes are in edb file size on the server that hosted passive copy when the size of active copy base is growing),

Last log files (E0200000178.log) is the same time and number on both severs, but passive database doesn't have e02.log file

Content index folder has different number of files (52 files and 1,34 mb for active copy database, 40 files and 1,04 mb for passive copy)
 

Similar threads

Top