OOF Still Not working, Client Access\Public folder is empty in IIS.

Status
Not open for further replies.
R

RTibhold


I have tried about everything I could find on the net. I get the "Your Out of Office setting cannot be displayed, because the server is currently unavailable, Try again later." I have tried the set-publicfolders, I do have the cn=public folders when I go to ADSI edit. I have autodiscover.mydomain.com as dns and in my certificate. I have checked to see if the certificate works and it does. I have diconnected the store renamed it and reconnected, and then disconnected and renamed the old one back to the correct name and mounted again.
When I browse to the public folder in IIS there is nothing there. When I go into Public Folder Managemen Console the Public folder SCHEDULE+ FREE BUSY. It says on all the items on the front page "Not avaliable on this server".

I am at the end of my rope here. Can anyone help?
 
T

TWHarrington

What is the version of Exchange and what is the version of the client?
 
R

RTibhold



Exchange 2007 - Version: 08.02.0254.000

Outlook 2007

Server 2008
 
T

TWHarrington



So can you see the setting in OWA? OOF uses Exchange Web Services (it does not use Public folders).

Can you do the following for me and post the results?

1) Get-WebServicesVirtualDirectory | fl

2) Crtl-rightclick the outlook icon in your system tray, select Test Email AutoConfiguration, uncheck the two Guessmart box and post the results.

3) Do you have redirection set on the Default Web Site? If so, can you double check the redirection settings on the EWS virtual directory?
 
R

RTibhold



Get-WebServicesVirtualDirectory | fl

InternalNLBBypassUrl : https://myserver.enterprise.local/ews/exchan
ge.asmx
Name : EWS (Default Web Site)
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated}
BasicAuthentication : False
DigestAuthentication : False
WindowsAuthentication : True
MetabasePath : IIS://myserver.enterprise.local/W3SVC/1/ROOT
/EWS
Path : C:\Program Files\Microsoft\Exchange Server\Clie
ntAccess\exchweb\EWS
Server : EXCHANGETIB
InternalUrl : https://myserver.enterprise.local/EWS/exchan
ge.asmx
ExternalUrl : https://mail.mydomain.com/EWS/Exchange.as
mx
AdminDisplayName :
ExchangeVersion : 0.1 (8.0.535.0)
DistinguishedName : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,
CN=myserver,CN=Servers,CN=Exchange Administr
ative Group (FYDIBOHF23SPDLT),CN=Administrative
Groups,CN=enterprise,CN=Microsoft Exchange,CN=
Services,CN=Configuration,DC=enterprise,DC=loca
l
Identity : EXCHANGETIB\EWS (Default Web Site)
Guid : 9daf9c28-9e71-41d9-b4db-664c1683a3b4
ObjectCategory : enterprise.local/Configuration/Schema/ms-Exch-W
eb-Services-Virtual-Directory
ObjectClass : {top, msExchVirtualDirectory, msExchWebServices
VirtualDirectory}
WhenChanged : 8/26/2010 12:03:13 PM
WhenCreated : 5/25/2010 7:11:22 PM
OriginatingServer : myserver.enterprise.local
IsValid : True

Crtl-rightclick the outlook icon

Autoconfigureation has started, this may take up to a minute
Autoconfiguration found the following settings:
Display Name: Ron
Protocol: Exthange RPC
Server: myserver. Enterprise.local
Login Name: Ron.
Availability Service URL: https://myserver enterprise.local/EWS/exchange.asmx
OOF URL: https : //myserver. enterprise.Local/EWS/exchange.asmx
OAB URL: http://myserver..enterprise.local/OAB/f56ea376-5726-4129-98d6-7c2a76d74e67/
Unified Message Service URL: https: //myserver.enterprise.local/UnifiedMessaging/Service.asmx
Auth Package: Unspedfied
Protocol: Exchange HTTP
Server: mail.ourdomain.com
Login Name: Ron.
SSL: Yes
Mutual Authentication: Yes
Availability Service URL: https:/mail.ourdomain.com/EWS/Exchange..asmx
OOF URL: https://mail.ourdomain.con/EWS/exchange.asmx
OAB URL: http://mail.ourdomain.com/OAB/f56ea376-5726-4129-98d6-7c2a76d74e67/
Auth Package: Basic
Certificate Prindpal Name: msstd:mail.ourdomain.com

And no redirects on the EWS virtual direcorty.
 
T

TWHarrington



So is : myserver.enterprise.local (your internal URL) in your certificate?

If you are connected via Outlook Anywhere does it work? What about outside of your network? Is free/busy not working either? Do you have split DNS in place? What if you changed the internalURL to https://mail.ourdomain.com?
 
R

RTibhold



Yes we can use it in OWA with no problem. And we can use it on owa outside our network also. We can use the https://[url="https://mail.ourdomain.com</a"]mail.ourdomain.com[/url] from inside the network. I am having a user try from outside the network to see if they can get into it. Yes, myserver.enterprise.local is on the certificate, along with autodiscover.ourdomain.com.

The user can not use out of office assistant from outside the network. It works fine in OWA, inside and outside the network. And the free and busy seems to be working fine.
 
R

RTibhold



What do you think? Now I have issues downloading the address book. I dont know what is going on with exchange.
 
Status
Not open for further replies.
Top