Upgraded version of Outlook cannot open previously viewable encrypted messages.

  • Thread starter computerkungfu
  • Start date Views 692
Status
Not open for further replies.
C

computerkungfu



Hi team, this is my first post and I have to admit to being a little desperate after trying dozens of so-called 'fixes' found in different corners of the web. My issue seems to be common enough, though the resolve isn't. I am a reasonable tech but not up with Exchange and related systems. I look after the IT of a company who are running older OSs and clients but are being forced to upgrade due to a number of reasons. They use a booking system where email messages are sent to them in what I am assuming is encrypted form - the icon on the message is a small blue padlock. They currently use Outlook 2000 and the messages open fine on those machines still running that version. However, simply upgrading to Outlook 2003 (I know, but this is the version they want to use) breaks things and the error when trying to view these messages now is the dreaded "Cannot open this message. Your Digital ID Name Cannot Be Found by the Underlying Security System". The thing is, on one of their machines, the upgrade went OK and the messages open fine. Their Exchange server host sent them a certificate/key file, which I can import OK, but I'm not convinced this key has anything to do with anything because Outlook still doesn't work and when I go into the Trust centre in the options dialogue there are no keys available for this function. The certificate/key shows up in the Internet Options dialogue under certificates but as I said, I'm not sure it is the right thing I need.
As you can tell, it is the blind leading the blind. I am out of my depth and aren't even sure of the correct language to use to convey the problem. I cannot fathom why one machine upgraded to Outlook 2003 and everything works while now 3 other machines have been upgraded using the same disk and procedure but they cannot open these messages. I even took the pst file to other machines and tried three different versions of Outlook - none would open the messages, with the error given above. I have read and tried several of the suggestions given in other posts but nothing has worked and I suspect this is because I am way off track rather than the fixes not being correct. Any further guidance or help would be greatly appreciated and I thank you for your time and expertise. Dave Thompson
 
Status
Not open for further replies.
Top