After updating Exchange 2010 from RTM to SP1, OWA clients cannot move or delete emails

  • Thread starter tarquelatwork
  • Start date Views 1,987
Status
Not open for further replies.
T

tarquelatwork

Hi all

The title says it all really, in that after updating Exchange 2010 from RTM to SP1, OWA clients cannot move or delete emails any more.

When they try to do this, they get the following message:

--- Error:

The mailbox you're trying to access isn't currently available. Please try again in a few minutes.

The entire error report is listed below: Show Report

Copy error details to the clipboard

The mailbox you're trying to access isn't currently available. Please try again in a few minutes.
---Note that this was NOT the case prior to the SP1 update, and its happening to mutliple people.

If I try and do it, it works for me on their mailbox through OWA (possibly because I'm the Exchange Administrator etc] although looking at the mailbox permissions doesnt seem to show any differences between my permissions and the other users, but when they are logged into the mailbox, it gives them that message.

Its happening on multiple mailboxes also.

Anyone noticed this and any suggestions on how to fix it would be appreciated :)

Cheers
Nathan
 
G

Gen Lin

Hi,

Try to disable the mailbox and then reconnect. What's result?



 
L

LuisMol

hi

i have the same problem...

the account is already disable but nothing

the problem started after update the exchange server 2010 to SP1

more suggestions

Thank´s

isn't Iexplore versión

are permissions on Shared Mailbox, only Domain users can move/delete
 
T

tarquelatwork

Just to update on what ive tried so far, I've tried removing all the users that have access to this one specific shared mailbox - using the Exchange Management Console > Manage Full Access Permission..., thru the EMS way, and from the AD object of the shared mailbox itself (in the Security tab), and then, once done, added the users back in using the EMS to give them permissions again - both FullAccess and the Send As permissions - but the issue still occurs, although my test user that has normal user permissions (like the other users do) can move/delete emails with no problem.

However, I've only tested my user on machines using IE8, whereas the users having the issue in question are likely using IE 7.

EDIT: I've just tried logging on to OWA on the users computer i.e. under her windows AD logon, but just logging on to OWA as my test user, and i can move / delete the emails with no problem, so I dont think its anything to do with her machine etc. We also tried logging onto OWA with her using DOMAIN\username and username@domain but the result was the same unfortunately.
The only thing i havent done is clear the IE cache/cookies etc.

I'll possibly try to disconnect the mailbox and re connect it again (after exporting the mailbox to a PST file to be safe) this evening to see how that goes.

(note that so far, this is only happening on shared mailboxes, and I'm not aware of it happening on normal mailboxes that are accessed via OWA)

I wondered whether it was some weird settings on the OWA IIS directory that have taken place when the CAS server was being upgraded to SP1 possibly, as some of us recall that we had something similar initially when I set up Exchange 2010 RTM a year ago, although I dont recall what it was that I did to fix it unfortunately, and whether its the same issue or not.

Anyone else have any suggestions at all?

Cheers
Nath
 
T

tarquelatwork

Right, i'll give you the short version:

Yes, Last night, I've disconnected the mailbox, and restored it back into a completely brand new user and mailbox, adjusted the account to reflect the orignal details, and then added the permissions again like before, but I'm told by the user the same is taking place (i've not had a chance to look at her trying it to confirm this).

------------------------------Now, just to digress slightly, for a bit more info, to anyone running SP1 and wanting to disconnect a mailbox and reconnect it afterwards, take a look at:

http://technet.microsoft.com/en-us/library/ff829875.aspx

and read through Example 1.

Be aware tho (which hindered me considerably last night) that if you are importing PST's (we are due to a migration to exchange taking place throughout the organisation) in SP1, we've found that some PST that have errors in them actually cause the issue outlined here:

http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/58c53dc6-2c0a-46db-8af8-46bbca9469df/

i.e. causes the service to fail and then restart, and continue importing again, only to fail again as you can see below...

The error message is:

Event ID: 4999
--------------
Watson report about to be sent for process id: 10128, with parameters: E12, c-RTL-AMD64, 14.01.0218.015, MSExchangeMailboxReplication, M.Exchange.PST, M.E.P.Attachment..ctor, S.C.Generic.KeyNotFoundException, 2a30, 14.01.0218.005.

ErrorReportingEnabled: True
--------------
and then following it, this event:
Event ID: 1000
--------------
The Mailbox Replication service has started successfully.

Version 14.1.218.11, PID 9108.
--------------
then the import will continue by itself, and it will then do the same thing again continuously until you " remove" the request for this particular problem PST import.

Additionally, for info on this, we are running: Exchange 2010 SP1 with Rollup Hotfix 1 on Windows Server 2008 R2 servers. The roles are seperated out on seperate servers, and you'll find the above in the event viewer (its under Custom Views > Server Roles > Microsoft Exchange with Database Availabiliy Group Events) on the CAS server. I updated all our Exchange servers with all available critical (and most of the recoomended - i.e. all other than .NET Framework 4, and the SD Card update) updates as of 27th of Nov 2010.

I'll attempt to bring this up with Microsoft Support, although i dont know whether the MS Exchange Team monitors these forums at all for problems.

------------------------------Anyhow, back to the actual issue at hand....

Disconnecting this mailbox, and re-adding it to this one mailbox eventually worked, however, it seems to have lost the majority of this weeks emails. Thankfully, I ran a export to PST earlier in the day yesterday so I've got that along with a snapshot of the vol from midnight last night, so currently attempting to setup a " recovery database" using that in order to get the emails that arent there. Any one happen to know why this would be?

Any other ideas on what this weird OWA behaviour is? I find it unlikely its the mailbox now, unless the exporting it into the new user/mailbox produced the same issues somehow?

Cheers
Nath
 
Status
Not open for further replies.
Top