Problems opening the EMS and EMC - WinRM, Kerberos, Powershell

Status
Not open for further replies.
T

testrrrr

On one of our servers EMS and EMC does not open anymore:

I was renewing the VMWARE Network Adapter:
- I put " exchange sa service" to " manual" , unistalled vmware tools and shut down the server
- then I deleted the old adapter, and put in the new
- then I booted the server
- then I reainstalled the vmware tools=Driver, put in the same IP to the nic as the old one had had and put exchange sa to auto again
- after an other reboot I now get the an error him - but using a different user doesn't help

The EMC shows we followin error (translated from german):

Error connecting to " Server XY/powershell" using kerberos. Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid.
Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid.
The Troubleshooter says:

---------------------------
**********************
Start der Windows PowerShell-Aufzeichnung
Startzeit: 20101221180845
Benutzername: XXX\XXX
Computer: XXX (Microsoft Windows NT 6.1.7600.0)
**********************
AUSFÜHRLICH: Connecting to xxx.x.x Beim Verbinden mit dem Remoteserver ist folgender Fehler aufgetreten:
Der WinRM-Client kann die Anforderung nicht verarbeiten. Der Inhaltstyp der HTTP-Antwort vom Zielcomputer
kann nicht ermittelt werden. Der Inhaltstyp fehlt oder ist ungültig. Weitere Informationen finden Sie
im Hilfethema " about_Remote_Troubleshooting" .
+ CategoryInfo :
OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportException
+ FullyQualifiedErrorId : PSSessionOpenFailed
The Exchange Management Troubleshooter successfully
completed connecting to:

Server

**********************
Ende der Windows PowerShell-Aufzeichnung
Endzeit: 20101221180845
**********************
Failed to connect to any Exchange Server in the current site.
Problem found:
Looking for error...
Unknown Error

In Eventlog I found one Error concerning my Problem:

------------------------------Protokollname: Application
Quelle: ASP.NET 2.0.50727.0
Datum: 21.12.2010 17:28:19
Ereignis-ID: 1310
Aufgabenkategorie:(3)
Ebene: Warnung
Schlüsselwörter:Klassisch
Benutzer: Nicht zutreffend
Computer: Server
Beschreibung:
Event code: 3008
Event message: Es ist ein Konfigurationsfehler aufgetreten

> ...

If I put the following in the IE I get a different answer then the other servers:

----------------------------------------------------------http://servername/powershell

I get:Beschreibung: Fehler beim Verarbeiten einer Konfigurationsdatei, die für diese Anforderung erforderlich ist. Überprüfen Sie die unten angegebenen Fehlerinformationen, und ändern Sie die Konfigurationsdatei entsprechend.
Parserfehlermeldung: Die Datei oder Assembly " Microsoft.Exchange.Configuration.RedirectionModule, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" oder eine Abhängigkeit davon wurde nicht gefunden. Das System kann die angegebene Datei nicht finden.
Quellfehler:


Zeile 40: <compilation debug=" true" > Zeile 41: <assemblies> Zeile 42: <add assembly=" Microsoft.Exchange.Configuration.RedirectionModule, Version=14.0.0.0, Culture=neutral, publicKeyToken=31bf3856ad364e35" /> Zeile 43: <add assembly=" Microsoft.Exchange.Configuration.CertificateAuth, Version=14.0.0.0, Culture=neutral, publicKeyToken=31bf3856ad364e35" /> Zeile 44: <add assembly=" Microsoft.Exchange.Data, Version=14.0.0.0, Culture=neutral, publicKeyToken=31bf3856ad364e35" />

Quelldatei: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\web.config Zeile: 42
&Uuml;berwachung beim Laden der Assembly: Mit folgenden Informationen kann bestimmt werden, warum die Assembly Microsoft.Exchange.Configuration.RedirectionModule, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 nicht geladen werden konnte.


=== Zustandsinformationen vor Bindung === LOG: Benutzer = NT-AUTORIT&Auml;T\SYSTEM LOG: DisplayName = Microsoft.Exchange.Configuration.RedirectionModule, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 (Fully-specified) LOG: Appbase = file:///C:/Program Files/Microsoft/Exchange Server/V14/ClientAccess/PowerShell/ LOG: Urspr&uuml;nglicher PrivatePath = C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\bin Aufruf von Assembly : (Unknown). === LOG: Diese Bindung startet im default-Load-Kontext. LOG: Die Anwendungskonfigurationsdatei wird verwendet: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\web.config LOG: Die Hostkonfigurationsdatei wird verwendet: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Aspnet.config LOG: Die Computerkonfigurationsdatei von C:\Windows\Microsoft.NET\Framework64\v2.0.50727\config\machine.config wird verwendet. LOG: Verweis nach der Richtlinie: Microsoft.Exchange.Configuration.RedirectionModule, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 LOG: Download von neuem URL file:///%ExchangeInstallDir%bin/Microsoft.Exchange.Configuration.RedirectionModule.dll.


Versionsinformationen: Microsoft .NET Framework-Version:2.0.50727.5018; ASP.NET-Version:2.0.50727.5053
Serverfehler in der Anwendung /PowerShell. Konfigurationsfehler

The other exchange Servers in our AD are running.

I followed the 3 sugestions in Troubleshooting Exchange 2010 Management Tools startup issues what didn't help and I didn't found a solution in the Forum. Does anybody know how I can solve my Problem.
 
T

testrrrr

Thank you, but yes, I followed the sugestions in the thread you mention.
 
T

testrrrr

Thank you for your Reply.

I trieded one of the things I found in the link you suggested on an english Windows server:

I tried:

[PS] C:\Windows\system32>$Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://x.x.x/PowerShell/ -Authentication Kerberos
[x.x.x] Connecting to remote server failed with the following error message : The WinRM client cannot process
the request. It cannot determine the content type of the HTTP response from the destination computer. The content type
is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.
+ CategoryInfo : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
eption
+ FullyQualifiedErrorId : PSSessionOpenFailed
[PS] C:\Windows\system32>

When i try to connect to other exchange servers the command works.
 
Status
Not open for further replies.
Top