• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

How to configure outlook to avoid sending emails from the wrong account

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#1
Hello:

I have 2 Outlook accounts.

One uses POP3 and is for company1 (internal). The other one usess Microsoft Exchange and it's for company2 (external).

What I want to avoid is that someone from compan1 that wants to send an email to company1 employees chooses company2 email account instead erroneously.

company2 makes random email audits and if they find an email from my internal company on their mail server that was sent using their domain they may not be happy.

Is this possible?

I know that there is a way to set a default account but I want something more secure.

Thanks
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#2
The only sure way is to have two separate outlook profiles. This will also eliminate the chances that employees will accidentlly deliver email to one shared inbox and end up storing mail for company1 in company2's mailbox.
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#3
Ok so for now I am going to leave both accounts on the same profile.

I have a little problem though.

Outlook is not automatically finding the names from the Global Address List (GAL) when I type them on the "To..." box when composing a new email.

I already downloaded the OAB by connecting to the VPN and changed the address book options to "When sending mail, check names using these address lists in the following order:" to search first on the GAL.

Also "Show this address first" is set to GAL.

If I manually click on the "To.." button all the names are there.

Thanks
 
#4
Autocomplete is the "nickname cache" and is only populated after you send a message to an address.

Autoresolve will search the address book if you type part of the name - that should work since you can see the names when you click To.

If you want to populate the autocomplete cache, open a message form, add all the addresses to the message, then close it (without sending!)
http://www.outlook-tips.net/2009/286/tip-590-add-contacts-to-the-autocomplete-cache/
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#5
As I said even when all the names are there when I click To, outlook is not automatically finding them.

It can only find my contacts list which is only 8 people.

If I try to do what you said (described on the weblink as well) I get an error that too many contacts were selected.

I am talking of about 5,000 or more people on the company that I connect through Exchange.

Thanks
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#6
Ok I think that the only option would be to manually add the contacts and either send or not send the email so they are added to the autocomplete cache.

I'm sure that not all the people is going to be emailing to all the 5,000 employees from the other company.
 
#7
Oh, i misunderstood. If they aren't in the address book when you click To, your address book service is corrupt. Unfortunately, with Outlook 2007 and 2010, this means you need to make a new profile. :(

However - the autocomplete cache only holds about 2000 names by default and while you can increase the size using a reg hack, a larger file is unstable. Better would be to copy the contacts you need from the gal to the contacts folder and let Outlook resolve them as needed, at least for names you don't use often. (If you have too many similar names in autocomplete its very easy to accidently send to the wrong person.)
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#8
jejeje looks like we still have a misunderstanding.

When I click "To" all the names are on the global address list.

When I manually type the names on the "To" section Outlook does not find them.

I really doubt that an employee knows more than 2000 people from the other company.
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#9
So if yo type a partial name and tab out of the field, press Alt+k, or click send, the address doesn't resolve? is autoresolution enabled? It's a settng in tools, options - i think email options.
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#10
When I press Alt-K an address book dialog pops up meaning that it found the address but that is not what I want.

What I meant is that when you start to manually type the email address in the "To" field it does not fills it automatically just like the ones that are in my Contacts list.

I am not sure if the option "autoresolution enabled" exists.

The closest option I could found was the one that I described in post #3.

I would expect that if I start typing a name that is on the GAL (ant not on my contacts list) and has never being typed before, Outlook will automatically finds it so I don't have to manually press Alt-K or open the GAL window.

Unless that is not the way autoresolution works and the only way for Outlook to automatically fill in the "To" field is to have sent an email from a certain name at least once.

Thanks
 
#11
What I meant is that when you start to manually type the email address in the "To" field it does not fills it automatically just like the ones that are in my Contacts list.
This is because you haven't sent this person a message yet - the autocomplete cache only populates after you send a message to that person. It holds like the last 2000 or so people you emailed.

If you sent to the person yesterday and its gone when you rebooted today, the cache is corrupt - close outlook, find and delete the NK2 then restart outlook. The cache will be empty and will need to be recreated. See http://www.slipstick.com/outlook/email/understanding-outlooks-autocomplete-cache-nk2/ for more information.

The only way you can type a name from the gal and have outlook find it, is to prepopulate the autocomplete list. Otherwise, if you type a name you've never sent to before, you need to use autoresolution, where outlook searches your address book AFTER you are finished typing it.
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#12
Ok that makes sense.

Any chance you or someone else knows of a good software to design standard operating procedures (SOP's)?

I am planning on creating one with instructions (text and screenshoots from Outlook) on how to add an Exchange account to an existing POP3 one.

Thanks
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#15
Hello:

I noticed that all the draft messages are saved on the Exchange draft folder even when I am composing an email from the POP3 account.

Also everytime I send an email from the POP3 account it goes to the exchange's outbox instead of the POP3 one.

Is this a normal behavior?

Thanks
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#16
mmmmmm I am not liking this.

Seems that I have my 2 email accounts mixed.

Does this mean that the Exchange server is being used to store my POP3 emails like drafts, sent, outboox, etc.? This is exactly what I didn't want :(

I am not sure if I'm supposed to change the default folder from the "Data files" tab under Account settings.

If I try to do that I get a HUGE warning message saying that all my email messages will be removed from the Exchange server.

Thanks and help is greatly appreciated.
 
#17
Go to Tools, Accounts and select the pop account and click the change folder button - pick a pst - if you don't have a pst in the profile, add one.
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#18
There is already an Outlook.pst file associated with that account.

As previously said the drafts, deleted and outbox contents from the POP3 account are being stored in the Exchange account.

On Tools, Accounts, Data Files there are several files listed there in which the Exchange server is the default one.

Why are most of my POP3 account messages being stored on the Exchange server? It doesn't makes any sense :(
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#19
I'll double check it with 2007 - if you used 2010, the drafts, deleted, and outbox would definitely be in the same data file as the POP3's assigned inbox. I know the outbox folder was always in the default data file and its likely the same for drafts - but deleted items should go into the deleted items folder in the same pst the item was deleted from - Outlook has always done this.
 

robertin75

Senior Member
Outlook version
Outlook 2007
Email Account
POP3
#20
Ok seems like the deleted fodler is working as it should.

The problem seems to be with drafts and outbox.

Thanks for your help.