Calendar Note Font Reverting

Status
Not open for further replies.

waldner

Member
Outlook version
Outlook 2013 64 bit
Email Account
Outlook.com (as MS Exchange)
hi there,

i am hoping someone can help me figure out something that is baffling me with some of my outlook calendar entries.

for certain calendar entries, when i click in the "notes" field (which is blank) the font shows calibri 11; if i hit delete, the font becomes arial 10. for other entries, i do the same thing (hit delete in the empty notes field) and the font remains calibri 11.

why does it revert to arial 10 in some instances (which i don't want to have happen) and not in others?

potentially relevant details:

  • outlook 2007; xp sp3
  • if i go to tools -> options -> mail format -> stationery and fonts... -> personal stationery tab -
    • no theme currently selected
    • new mail messages, replying or forwarding to messages and composing and reading plain text messages all have font set to calibri 11

thank you for your help!!
 

waldner

Member
Outlook version
Outlook 2013 64 bit
Email Account
Outlook.com (as MS Exchange)
by the way, the same exact thing happens with certain (but not all) contacts - hitting delete in the empty notes field causes the font to revert to arial 10 from calibri 11...
 

waldner

Member
Outlook version
Outlook 2013 64 bit
Email Account
Outlook.com (as MS Exchange)
still hoping for a little help please...thank you
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Sorry I missed that when you first posted it. 50 lashes with a wet noodle for me. :)

Go to Format text ribbon > Change Styles button > Fonts - what is selected there? (My recommendation is to choose +Body font in the stationery and fonts dialog then set the +Body font in Change Styles. Choose a font theme then click Set as Default. This will apply to all outlook items. )

I'm guessing that the ones that are goofy are older than the ones that behave as expected?

I believe the last para is using the +Body font and was probably created before you changed the default font. See Tip 875: How to change the +Body style font in Outlook | Outlook Daily Tips for an explanation as to how the +Body font works - I'm guessing that the problem experienced with signatures applies here too.
 

waldner

Member
Outlook version
Outlook 2013 64 bit
Email Account
Outlook.com (as MS Exchange)
Thank you so much for your reply and no worries ;-)

I already have the +Body style selected in Stationery and Fonts for "New mail messages", "Replying or forwarding messages" and "Composing and reading plain text messages". When I click on Format Text Ribbon -> Change Styles button -> Fonts, what is selected is the very first item, which is:

Office

Cambria

Calibri

I'm not sure what you meant by selecting the +Body font in Change Styles, but I can tell you that when I create new item, the default font of Calibri is being used.

Yes, the ones that are acting goofy appear to be older items that have been through several versions of Outlook over the years.

So is there any solution to this goofy behavior or is it kind of just going to be the way it is?

Thanks so much again.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
When you create a new item, does the Font say "Calibri (Body)" or just "Calibri" ?

The font for the Notes field is set when the item is created and its very likely that they were created in a version where Arial was the default. There is a chance that setting the font to + Body rather than Calibri will fix the problem, but i'm not even 90% sure of that.

bodyfont.png
 

waldner

Member
Outlook version
Outlook 2013 64 bit
Email Account
Outlook.com (as MS Exchange)
Thanks again for your reply.

When I create a new calendar entry, a new contact or a new e-mail it says "Calibri (Body)".

Setting the font to +Body in a goofy-acting contact does not solve the problem.

I guess what you are saying is that the default font is somehow attached to/embedded in the object when it is created.

In other words, there is no way to fix the behavior...
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
So you are using the body format. That means that the problem items are hard coded to use the other font.

Try this - use select all the apply 'Calibri (Body)' from the Format Text font list and apply. That forces items created with other default font settings to default to the body font here. Now when I delete the text, it default to the body font, not the old font.
 

waldner

Member
Outlook version
Outlook 2013 64 bit
Email Account
Outlook.com (as MS Exchange)
Would you kindly be painfully specific in describing the steps you are suggesting?

Should I be in contacts or calendar as a starting point?

Where / how do I select all?

Etc.

Thank you!
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Use the calendar since it is where the problem is. When i tested the step earlier today, they worked in outlook 2010 but when i checked in 2007 (to get the exxact steps for you), it did not work.

As you open the appointments to edit, click in the notes field and Select All (Ctrl+A) then select a new font, choosing the one at the top called Calibri (Body). When I delete the body, that new last line break used calibri (body) in 2010, but not in 2007.

(edited to fix dropped letters - can you tell my laptop is dying. <g>)
 

waldner

Member
Outlook version
Outlook 2013 64 bit
Email Account
Outlook.com (as MS Exchange)
Unfortunately, that did not work for me.

I have experimented a little bit with a contact that was acting goofy and found the following, which I will spell out in as much detail as I can:

1) Start with a goofy acting contact that has nothing in the Notes field (the Notes field is blank). The contact is "goofy" because the default font in the Notes field is Arial 10 and I cannot seem to change this, despite the fact that a newly created contact does default to the +Body style of Calibri 11. If I manually change the font in the (blank) Notes field to Calibri 11, then hit the Delete button while in the notes field, the font jumps right back to Arial 10.

2) Select this goofy acting contact -> File -> Save As -> .vcf (saved to the desktop)

3) File -> Import and Export... -> Import a VCARD file (.vcf) -> import the file saved in step 2 above (yes this creates a duplicate contact)

4) Note the following: the duplicate contact lost the category that was assigned to the original BUT the blank Notes field now behaves properly - the default font is the +Body font!

5) HOWEVER - start with a goofy acting contact that has text in the Notes field - that is, the Notes field is NOT blank - and then follow steps 2 and 3 above. In this case, the default font problem remains - delete the text and the font jumps right back to Arial 10.

Diane, is there a way I can send you one of my misbehaving contacts for you to reference and play with?

Thanks so much again!
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
you can email me the vcf to diane at slipstick. But I think the problem is the font is set in the source code - open the vcf in notepad. The text from the note field should be wrapped in coding which includes the font.
 
Status
Not open for further replies.
Top