Rule doesn't work with both exchange and POP3 email addresses

Status
Not open for further replies.

kayache

Member
Outlook version
Outlook 2010 32 bit
Email Account
POP3
I am having a rule problem that for the life of me I cannot figure out. Any clues would be appreciated.

My setup: outlook 2010:

- one exchange account with an email address, name@exchangedomain.com, going to the Inbox of an OST data file in Outlook.

- two POP3 accounts with their email addresses, name@pop3domain1.com and name@pop3domain2.com, going to a PST data file Inbox.

I've set up two rules, Rule X and Rule Y, and I have problems with Rule Y. The following questions reference the rules and observations at the bottom:

  1. The only difference between observation 1 and 2 is that in 2, the message is sent to the exchange email address rather than the POP3 email address. How can this make a difference when Rule Y has no requirements at all on email addresses?
  2. Compare observations 2 and 3. In observation 2, why does Rule X affect messages that Rule Y is targeting? Shouldn't Rule X only affect email that is received to the name@pop3domain1.com account?
  3. See observation 4. How can removing "stop processing more rules" from rule X change the outcome for Rule Y when Rule X should only affect email sent to the name@pop3domain1.com account?
  4. Is there something I don't understand about how Rules are applied against Exchange and POP3 accounts?

--------------------------
Rule X Description: all email received by POP account name@pop3domain1.com is moved into the pst data file Inbox "domain1" subfolder. (Rule X below)
Apply this rule after the message arrives
through the name@pop3domain1.com account <-- a pop3 account.
and on this computer only
move it to the domain1 folder <-- a subfolder under the pst data file Inbox
and stop processing more rules


Rule Y Description: remaining email with "1234321" in the message header, received by POP account name@pop3domain2.com OR exchange account name@exchangedomain.com, is moved into the pst data file Inbox "1234321" subfolder.
Apply this rule after the message arrives
with '1234321' in the message header
and on this computer only
move it to the 1234321 folder <-- a subfolder under the pst data file Inbox
and stop processing more rules


Observations:

1. email sent to name@pop3domain2.com with 12345654321 in the message header, and with Rule X before Rule Y as shown above - Rule Y executes as expected.

2. email sent to email@myexchangeaddress.com with 12345654321 in the message header, and with Rule X before Rule Y as shown above - Rule Y does not execute as expected. (appears to not be applied at all)

3. email sent to email@myexchangeaddress.com with 12345654321 in the message header, and with Rule Y before Rule X - Rule Y does execute as expected. But this is not an option due to other reasons.

4. email sent to email@myexchangeaddress.com with 12345654321 in the message header, and with Rule X before Rule Y as shown above, and with "stop processing more rules" removed from Rule X - Rule Y does execute as expected. But removing this restriction is not an option.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
For starters, why are you using rules? Go to file, Account settings and select the domain1 account, then Change Folder at the bottom. Deliver mail to Domain1 folder directly.

i'm going to have to try and repro this - it should work either way, for all accounts.
 

kayache

Member
Outlook version
Outlook 2010 32 bit
Email Account
POP3
Thank you for the reply. Actually I originally had the domain1 account emails delivered directly to the desired folder, but I changed it to have rules do the move because I needed to have "stop processing more rules" applied against those emails due to additional rules beyond the first two I've mentioned in this example. But regardless, the current rules should work shouldn't it. I can't come up with any possible reason for the rules as stated to show the problems I mentioned.. Thanks again for your help.
 
Status
Not open for further replies.
Top