Rule not working

richw

Member
Outlook version
Outlook 2016 32 bit
Email Account
Exchange Server
I have Outlook 365 and about 15 rules set up to have certain emails to be moved to a specific folder when they arrive. I have set them up as they arrived over the course of a few months or so. They are all "merchant" emails from Dell, HP, Amazon, Pizza Hut, etc.. They are automatically sent to a "Merchants" folder I created. The rules all work with the exception of one that never works. It has the same "from" address each time but the email never transfers no matter where in the stack order I put it, or add special rules like "specific word in address" or such. I'm stumped :confused:. Any ideas? Thanks in advance.
 

richw

Member
Outlook version
Outlook 2016 32 bit
Email Account
Exchange Server
Yep! I think that was it. So I now added sender address contains specific words and unchecked from people or group and it now works. Thanks Diane!
 

Jaycey

Member
Outlook version
Outlook 2010 32 bit
Email Account
I have exactly the same problem - I've just created a rule today for the fourth time, for the same sender! :confused:

My rule reads:-

Apply this rule after the message arrives

from Museum Selection

move it to the Sales Mailshots folder



So what Diane is saying then, that although my rule looks exactly the same in every case, there's something in the address that is preventing it from working each time?

So, should I be ticking "with specific words in the sender's address" and putting 'Museum Selection' in that category? (I've done this before with other rules and it hasn't always worked!) If not, what exactly should I do?

Advice please - I'd love to tidy up my multiple rules! :)
 

richw

Member
Outlook version
Outlook 2016 32 bit
Email Account
Exchange Server
Jaycey...

Yes, I checked "with specific words in the sender's address" and unchecked "from" and it works now. The sender's address did have two domain names in the address. Hope this helps, and thanks again Diane.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
So, should I be ticking "with specific words in the sender's address" and putting 'Museum Selection' in that category? (I've done this before with other rules and it hasn't always worked!) If not, what exactly should I do?

Advice please - I'd love to tidy up my multiple rules! :)
Try the Museum Selection email address in the 'specific words in the senders address' rather than the display name. You can use part of the address or the entire address.
 

Top