Macros for Delegate Issues?

Status
Not open for further replies.

Britonius

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
I have document our Delegate issues in this thread - https://forums.slipstick.com/threads/91419-delegate-send-drafts-delete-items-functions-behalf-client/#post332703.

I have figured out a quick workaround by adding a Quick Step for Copying/Moving Draft Items or Deleted Items from the Delegates default folders to the Manager's default folders, but this is still quite cumbersome.

Does anyone know of any macros, add-ins, etc. that could be added to the Message window that would help?
So Basically a button, that a Delegate could click to save the Draft email in the Manager's Drafts folder, and a button to Delete the email sending it to the Manager's Deleted Items folder.​

Any Help is appreciated as our Administrative Assistants are pulling their hair out trying to deal with Microsoft's so called Delegate function compared with Lotus Notes that kept everything separate for each person.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
A macro should be able to do it - i don't have one handy that does it, but it shouldn't be long or difficult. You should only need a macro for the draft folder - not for the deleted folder, as the DelegateWastebasketStyle reg key should handle it.
 

Britonius

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Sorry for the dual posts as I did not think there were fixes for either. Thank you for the replies.

Just to follow up on the Macro request for the Drafts folder here as well, this is another workaround that may work just fine instead of a Macro:

I think I may have found another simple workaround for this issue. While you have the email open that you saved as a Draft, simply go to File, Move to Folder and select the Manager's Drafts folder (need access to it of course) and it moves it to their folder and does not leave a copy in the Delegate's folder. I think this will work OK.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Here is a macro that eliminates the step of browsing for the folder in the move to folder command - add a button to the QAT and you'll save a step.

Code:
Sub MoveDrafts()
   Dim objOutlook As Outlook.Application
   Dim objNamespace As Outlook.NameSpace
   Dim objSourceFolder As Outlook.MAPIFolder
   Dim objDestFolder As Outlook.MAPIFolder
   Dim objItem As MailItem
  
   Set objOutlook = Application
   Set objNamespace = objOutlook.GetNamespace("MAPI")
   Set objSourceFolder = objNamespace.GetDefaultFolder(olFolderDrafts)

   Set objItem = objOutlook.ActiveInspector.currentItem
        
   Set objDestFolder = objNamespace.Folders("Manager").Folders("Drafts")
   objItem.Move objDestFolder
            
   Set objDestFolder = Nothing
   
 
End Sub
 

Britonius

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
Hhhhmm, I'm not getting the macro to work. I tried as is, as well as replacing the word Manager in the macro with the managers name, alias, email address, etc. I tried running it in MS Visual Basic for Applications and it says it is not enabled. What am I missing to get this to work?
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Manager should be the account name as it appears in the folder list - this should be the name as it appears in the AD. In my test, the delegate added my mailbox to his profile and I used "Diane Poremsky" in the macro.
 

Britonius

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
OK, I did try that, but maybe it's because I am testing it on my mailbox with a mailbox I attached to with Full Admin Access rather than going through the Delegation process. So the Macro does not seem to be doing anything at all for me when I click it. I'll try it on the Delegates account and see what happens.
 

Britonius

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
OK, yes it worked once I set it up with the Delegate I was assisting. I used the Exchange Display Name as you said, which pointed it to the correct person's Drafts folder. Thank you very much.
 

Britonius

Member
Outlook version
Outlook 2010 64 bit
Email Account
Exchange Server
I believe Microsoft fixed this issue as follows, unless you are describing a different issue:

You use Outlook 2010 and are a delegate for your manager. An email message that you send on behalf of your manager is saved in your Sent Items folder not His Sent Items folder.

MS has provided a hotfix https://support.microsoft.com/kb/2181579, unfortunately this means IT has to touch each Delegate machine to get this setup properly, not a good solution as it should be part of the default Outlook Delegate setup.
 
Status
Not open for further replies.
Top