Exchange 2013 On premise set MessageRateLimit for User has no effect.

mattdean66

New Member
Outlook version
Outlook 2013 64 bit
Email Account
Exchange Server
Hi

Pulling my hair out over this one, have a small Exchange 2013 Box running hosted exchange for about 7 organizations. I need to set a MessageRateLimit for sending for one mailbox. I have used the following commands:-

New-ThrottlingPolicy -Name UPLimitPerMinute -MessageRateLimit 2
Set-Mailbox -Identity user_alias -ThrottlingPolicy UPLimitPerMinute

both command execute without error, if I subsequently run the Set-Mailbox -Identity user_alias -ThrottlingPolicy UPLimitPerMinute it says that it has executed but no changes were made indicating the initial run of the command worked.

If I run Get-ThrottlingPolicy UPLimitPerMinute |fl *limit* it shows :-

MessageRateLimiit : 2
RecipientRateLimit : Unlimited
ForwardeeLimit : Unlimiited

If I run :-

GetThrottlingPolicyAssociation user_alias | select throttlingpolicyid

ThrottlingPolicyId
------------------
UPLimitPerMinute

So all looks to be set correctly. I have restarted :- Transport Delivery, Transport Submission, RPC Client Access and Microsoft Exchange Throttling Services.

However the rate is never applied, if I use VBA to send 200 message they arrive within 3 minutes, If I use Outlook, the limit is not honoured as quick as I can type they arrive, also the same behaviour in OWA.

Any ideas as to why this is not working?


Regards

Matt
 
Top