Outlook 2016 Change location of Outlook SecureTemporary Files Folder

Kika Melo

New Member
Outlook version
Outlook 2016 32 bit
Email Account
Exchange Server
On an older forum, this issue is touched upon, but I cannot find the answer there to this specific problem. I actually entered a comment on that thread yesterday and and the day before, but my comment is never displayed when I refresh that page, so I guess it is 'disappearing' somewhere in Slipstick... I will transcribe the issue again. The same problem was mentioned on that older thread by Grant, on March 2015, and it goes like this:

I tried to modify the OLK location in the registry for Outlook 2016 but every time I open an attachment, this key gets set back to the default location (C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.Outlook\XDV8LTXK\).

I have made sure the folder location I tried to set it to (C:\Temporary Attachments) exists before changing the registry. I modified the Registry key, closed the Registry, closed Outlook, re-started Outlook, double-clicked on an attachment (.PDF, or .DOC, or .JPG, etc.), and saw that the location of that attachment is again in a \Content.Outlook\ new 6-alphanumeric subfolder. When I open the Registry, I see that my modification of the key has gone, and it points again to the default C:\User\ etc. location). I re-did the process several times, naming alternative folders in the C:\ or D:\ drive, but the result is always the same. Very, frustrating!!!

Any ideas?
 

Kika Melo

New Member
Outlook version
Outlook 2016 32 bit
Email Account
Exchange Server
Oh! I did not know about the comment not displaying whilst it is still awaiting moderation. In this case, sorry for reposting it several times...
And as to the actual issue - are you then saying that there is no way at all to point Outlook to open the attachment from another folder? Is this a lost cause? It is so annoying to have to go on scrolling all the tree in Windows Explorer to get out of that hateful 9-subfolder structure of the C:\User\etc\etc....until I find the folder I really want the attachment to be saved to! And for multiple attachments the annoyance goes beyond endurance! Why does MS "undo" something that was working well on previous versions?...
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
The Save folder is different than the securetemp folder and should be easy to switch to. If the attachment is read-only, the default save location should be Documents or the last saved location.

In any event, you should be able to jump to the folder with a click or two using the folders on the favorites folders/quick access list (pin your favorites to it if they aren't there) or click the << in the address bar to see a list of save locations at the drive level (includes cloud sync locations).

Click the > after each folder name to see a list of subfolders of that folder - not as helpful with this issue (especially if the full path isn't shown - you don't want to save it in local :) ), but it can be useful in other situations to jump to another folder in the same parent folder.

save-locations.png
 

Kika Melo

New Member
Outlook version
Outlook 2016 32 bit
Email Account
Exchange Server
Thanks, Diane!
I may not have explained it well. The issue was not to change the Save folder. This one I had already changed, by creating a key under HKCU\Software\Microsoft\Office\16.0\Outlook\Options as a DefaultPath, and pointed it to my D:\Data folder, which is the directory where I have subfolders for files associated with each type of software (\Excel, \Word\ \Acrobat \Photos, etc., etc.). Thus if , instead of left-clicking (i.e., opening the file in whichever application it defaults to), I right-click the attachment on an email message and press Save As, it goes nicely to the D:\Data directory, from where I can choose the correct sub-folder.
The problem arises when I first double-click the attachment on a message, the file opens on its program and, from there, I want to do a Save As - that is where the default location is the C:\Users\UserName\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.Outlook\XDV8LTXK\, which drives me mad. So, what I wanted to do was to change this, pointing the email attachments to open onto a D:\Temporary Attachments folder I had created specifically for this. However, it appears that this is not possible, right?
I added the D:\ to the Favorites in Windows Explorer, but it still does not help much because I still have to scroll up the window until the Favorites folder is visible. Maybe these 2 screenshots explain what I mean:
WE ScreenShot #1.jpg
WE ScreenShot #2.jpg

And, I do not have the << sign on the address bar in WE to do what you suggested. Could this be because I have Windows 7 (Pro) on this PC, rather than a newer version?
 

Attachments

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Windows Explorer is a little different between versions, but the feature is there - Click on the > in front of your user name. to see the menu. On my win7 install here, I have either >> or the black triangle depending on the program that brings up the save dialog - the one right after the folder icon shows the menu.

Depending on the Save explorer the program uses, you might be able to put your most used folders on the places bar -
Places Bar in Windows 7 & 8 - @Poremsky.com
 

Similar threads

Top