Your setup couldn't be started because of an unexpected error (mapi 0x80040604)

Status
Not open for further replies.
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
Hi there,

We are getting this error when setting up icloud. This is what happened:
  • Have been using outlook with icloud & codetwo for years, no issues
  • Ran the windows 10 auto update the other day and icloud stopped working. Was throwing an error in outlook.
  • Thought it was an add in error, so tried repairing icloud, logging out and back in, uninstall/reinstall icloud, removed office 2013 and upgraded to office 2016 on my 365 account, etc. Nothing.
  • Now we are getting the error when we try to login to iCloud....
"Your setup couldn't be started because of an unexpected error (mapi 0x80040604)"

That error comes up after it goes through all 13,000 cal entries and then after "downloading icloud" it throws that error. Maybe a timeout since so much data?

Not sure what else we can do...

See attached.

Thanks,
 

Attachments

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
You aren't alone. :( I haven't been able to repro it though. I don't think it's data - i had a client with 21000 appointments syncing. It took forever, but worked.

What do you use for antivirus?
Do you have plenty of free hard drive space? How full is your icloud?

These two come from old posts in the apple forums -
When you try to set it up, do you select the option to import from outlook? Don't sync up, only down - if possible, delete any events in the local calendar and contacts folder.
Are you using imap as your default data file? Try adding a pst to the profile and setting it as default. Does that fix it?
 
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
thanks for the reply.

using Avast free version. No issues on HDD space or icloud space (150gb free).

using default profile for calendar - not imap.

For setup question, i only see to use all or some calendars. No other alerts - where do you see that?
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
For setup question, i only see to use all or some calendars. No other alerts - where do you see that?
Always choose some then untick all.

Also, in most cases you don't want icloud to make a local copy when you sign out - you'll get everything back when you sign back in. Only exception is if you think there is a lot of stuff that didn't sync up - you can make a local copy but untick everything when you sign back in.

is there an Avast addin in outlook? If so, disable it. See if that helps.
 
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
We do not use the avast add in.

We did "some calendars" and unchecked. it worked!!!

Thank you for that idea - you're right, that's no need to upload to icloud, they are already there.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
Thanks for the update - now i know what to tell everyone else who has this problem.
 
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
you got it! The only issue now - it's taking days to update the calendar! Lol. Hopefully it finishes up soon...
 
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
We have a new issue here. I think that there may be some bad calendar event or something - it will never finish syncing when outlook is open - just freezes and craps out. I think the issue is with code two - i am getting tons of alerts on my phone from my wife's calendar adding to icloud. Checking and it is adding holidays over and over. Is there a way to clear the icloud calendar and just rely on what she had in Outlook so when I turn on iCloud & codetwo again, it will just push everything back to iCloud? Unless you have another suggestion of course...

thx
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
you can delete the icloud calendar at icloud.com - in outlook, export it to a csv or ics, or move the events to a calendar folder in a pst first.

Go to icloud.com and make a new calendar first, then click edit at the bottom of the screen and delete it.


delete-calendar.png
 
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
Did all this, but still could not get it to work. Not sure why i did not think of this before. we just turned off Code Two and turned off our default calendar. the only calendar in outlook we have showing now is iCloud, which is hooked to my phone. No real need to use the default calendar that I can see!!
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
oh, so you are just not showing it in the navigation pane. I thought you meant you deleted or otherwise disabled it. :)

Note that if you create appt from the inbox, they go on the default calendar and will need to be moved to the icloud calendar. if you always create on the phone or directly on the calendar, it won't be a problem.
 
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
No, we only create on phone or on the icloud calendar (only one showing in outlook)
 
Status
Not open for further replies.
Top