Sync Issues With My Gmail Account

srmsrm

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
I'm using Outlook 2016.

My default email account is a GMAIL account IMAP.

I can send and receive emails.

I cannot get the IMAP "All Mail" to be seen in my Gmail folder in Outlook, so I created an "All Mail" folder (Mail and Post Items) under my Gmail folder. I have looked at multiple topics but no solution seems to work for me other than creating the "All Mail" folder.

When I delete all my emails from the "All Mail" folder, I see them move to my "Trash" folder. All seems OK.

The issue is when I empty my "Trash" folder the emails then re-appear in my "All Mail" folder. The only way I can get rid of them is to go to my Gmail interface and delete them.

I have tried changing email settings in Outlook / Gmail but no configuration seems to work.

I'm guessing this has something to do with the custom "All Mail" folder, but not sure.

Any ideas?

Shawn
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
I cannot get the IMAP "All Mail" to be seen in my Gmail folder in Outlook,
This is normal - outlook & google blocked this from showing in Outlook because it created duplicate messages (in the inbox or 'label' and one in all mail)
The issue is when I empty my "Trash" folder the emails then re-appear in my "All Mail" folder. The only way I can get rid of them is to go to my Gmail interface and delete them.
In gmail.com's settings, how is it set to handle deleted items?
Gmail -
gmail-imap.png
 

srmsrm

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
Diane:

Thanks for the feedback.

In Gmail, I have it set as Auto-Expunge on which defaults to archive message for the second setting. I think I tried the settings you noted when I was trying to get it to work. I will try again and maybe I missed something during my testing.

In 2010 the All Mail folder was there. In 2016 do you recommend not showing it? Since I do move emails between acounts, they remain in the "All Mail" folder. Eventually I need to go to mail Gmail interface to remove them. My workflow is I do not keep many emails around. Maybe the setting above will help resolve what I am encountering.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
In 2010 the All Mail folder was there. In 2016 do you recommend not showing it?
Correct, it was there in early builds - they blocked in after 2013 was released and is blocked in 2013/2016. I don't recommend using it any email client - it just creates duplicates of any mail in the inbox or labels. In Outlook, this doubled the size of the data file - and created confusion when people thought they deleted mail from the inbox but found a copy there (that could be some of your issue).
 

srmsrm

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
Diane, I tried with keeping the "All Mail" folder for now. Even with the changes to the Google email, still no luck.

I know you suggested not including the "All Mail" folder, but for example when I move emails to my local PST Inbox, they are still in the "All Mail" folder on Gmail.

For my workflow, I do not keep many emails on Gmail (I move them to my local PST). Even if I do not have the "All Mail" folder in Outlook it seems like I still need to go to Gmail to remove those emails. For example, even if I remove the All Mail folder from Outlook, I still need to go to Gmail to remove them from Gmail "All Mail" folder.

With me having the "All Mail" folder I can see there are emails there that I need to act on. I still have the issue that I noted that began this thread, but I know about the emails.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
in that case, you want the option set to immediately delete mail - when you move it, it is deleted from the server. autoexpunge setting shouldn't matter, but it probably makes sense to set it to immediately too.
 

srmsrm

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
IMAP
Thanks.

To select "Immediately delete the message forever" I first need to select "Auto-Expunge off".

With "Auto-Expunge on", I cannot make any changes to the "When a message is marked as deleted..." section. Am I missing something?

1.jpg


Even with "Immediately delete the message forever" selected, when I moved a message it still ends up in "All Mail". I left clicked and dragged and right clicked and selected "Move". Results of both options is the email is moved from the Inbox but still shows up in the "All Mail".

It does look like now though when I empty items from the trash (in Outlook) they are being deleted. What was happening is when I moved the items to trash from All Mail, emptied it, the emails then reappeared in All Mail (As noted above). It now looks like when I empty the trash in Outlook, they are now deleted.

I'll keep testing but it looks like my original reason for this thread looks to be resolved. I'll keep testing,but this change looks to have fixed it. Thank you.
 

Top