Replies being sent from wrong account

astro46

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#1
Outook 2016. Win10

I have a default pop account at default@fastmail.fm, also another pop account through the same fastmail.fm account as firstalias@fastmail.fm (I guess this called an alias?) . all mail is sent and received through the default@fastmail.fm account login. In the past if I received email to firstalias@fastmail.fm, and replied to it, Outlook would automatically send the reply from default@fastmail.fm . I had to remember to change the From: field back to firstalias@fastmail.fm.

recently, I wanted to experiment with imap, deleted the pop default@fastmail.fm account and attempted to set it up as imap. I gave up on this attempt, and recreated the pop default@fastmail.fm . since then some mail that comes in to the default@fastmail.fm uses the firstalias@fastmail.fm as From when I reply. others use the correct default@fastmail.fm as From. So I get some people wondering if my email address has changed because they see the reply came from a different address (becasue I didn't change the From before sending). It all seems arbitrary. Some mail to default@fastmail.fm replies from default@fastmail.fm and some replies from firstalias@fastmail.fm.

Actually, there is a second alias address, secondalias@fastmail.fm and it is also relying from firstalias@fastmail.fm

I have tried deleting the firstalias@fastmail.fm and recreating it. doesn't make any difference.

any ideas on how to get Outlook to revert back to replying to all fastmail.fm emails from default@fastmail.fm . (or, I know maybe this can't happen, since the main account and login is under default@fastmail.fm , but get all Fastmail to reply From the address to which it was sent?
 

astro46

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#2
to make this a bit stranger. I just tried setting the "reply e-mail" name in account setup to secondalias@fastmail.fm to secondalias@fastmail.fm ( already tried setting "reply email" in the other addresses to their respective names, but it didn't make any difference when I replied).

but now, when I reply to an email sent to default@fastmail.fm or firstalias@fastmail.fm they reply From secondalias@fastmail.fm.

This is weird. I have removed addresses in the 3 accounts from the "reply email" field in account setup.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#3
all mail is sent and received through the default@fastmail.fm account login. In the past if I received email to firstalias@fastmail.fm, and replied to it, Outlook would automatically send the reply from default@fastmail.fm . I had to remember to change the From: field back to firstalias@fastmail.fm.
This is normal outlook behavior for 'catchall' accounts.

since then some mail that comes in to the default@fastmail.fm uses the firstalias@fastmail.fm as From when I reply. others use the correct default@fastmail.fm as From.
Both accounts are in Outlook as accounts? Outlook will reply using the account that downloaded the message. While you were using IMAP, the second account downloaded the mail - so the reply is from that account. You can add the Account field to the view to check my theory.

I have removed addresses in the 3 accounts from the "reply email" field in account setup.
Yeah, that fielkd is not needed, unless you always want replies to the address in that field. (It's helpful if you are changing addresses. )
 

astro46

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#4
This is normal outlook behavior for 'catchall' accounts."
exactly. that's the question. why isn't it working like that anymore, since I experimented with setting up (didn't finish the setup) the imap account? All three are Pop.


Both accounts are in Outlook as accounts? Outlook will reply using the account that downloaded the message. While you were using IMAP, the second account downloaded the mail - so the reply is from that account. You can add the Account field to the view to check my theory."
I added "email account" to the view. You are correct. All email from yesterday shows all fastmail.fm email as coming from "secondalias", which is when I tried removing and rebuilt the " secondalias" account. Messages from previous days show "default" or "firstalias". All three accounts are in Outlook. All three download through the User Name default@fastmail.fm account. It is the owner of the account. The other 2 accounts are in Outlook so that they are available for the From field when sending email.

Why is Outlook using different Fastmail.fm accounts in From, when replying? Or showing the email coming from an alias account different than the one that is the User Name account. It seems have something to do with which account was set up last, even though they all download from the same user name/account. Previously to the IMAP experiment, Outlook always used "default@fastmail.fm", which is the account that all 3 download from.

All email is in a .pst .
This is all new behavior. Something to do with an Outlook update? A registry error?

very strange. How do I get it to stop?
 
Last edited:

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#5
Outlook replies from the account that downloaded the message - so while you were messing around with the accounts, secondalias downloaded the mail.

What I would do: in send and receive settings change first and second alias to not download mail. All mail will be downloaded by the main account.

Ctrl+Alt+B to open the dialog, select the send /receive group then click Edit - don't change the first account - change the other to to send only.

2018-06-05_12-11-26.png
 

astro46

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#6
unchecking "receive mail items" from the two alias accounts seems to have fixed the problem.
I don't understand why this happened. I am pretty sure that I didn't have those options unchecked previous to trying the IMAP setup.

thanks for figuring out a bandaid solution for some screwy Outlook behavior.

Jeffrey
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#7
I don't understand why this happened. I am pretty sure that I didn't have those options unchecked previous to trying the IMAP setup.
Best guess is the first account cleared the server, so the second and third had little to no mail to download.
 

astro46

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#8
right. all 3 accounts are through the same server. all the same as last week, before the problem started. Somehow, deleting and re-establishing the default account started this. or so it seems. another Outlook mystery.

Jeffrey
 

Similar threads

Top