Greyed out checkbox in custom form

Outlook version
Outlook 2016 64 bit
Email Account
Exchange Server
#1
I have a custom form with many checkboxes. One of them is behaving such that once the form is published, the checkbox unchecked, then when I check it, instead of a black check that I can turn on/off, it's grey and I can't uncheck it. I believe there I was able to attach a screenshot of the checkbox Properties (below). Any suggestions on what I can do to make this rogue checkbox act the same way as all the other check boxes?
properties.JPG
greyed out.JPG
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#2
it's not locked... its enabled... are all the settings identical between the 4 checkboxes? Select all then right-click and choose Advanced properties - filed with (mixed) had different values. Top, Name, Tab index, and Caption should have mixed -

right click on that control alone and choose Properties - is enabled checked? Try unchecking the rechecking it.
 
Outlook version
Outlook 2016 64 bit
Email Account
Exchange Server
#3
I took a close look at the Advanced properties of a box that is functional and the problematic/greyed-out box. I didn't see any variance. The regular properties are likewise identical. Then I opened up the Value tab in the check box properties and therein lies the variance in the Type. Now I just have to figure out how to change the type since this doesn't seem to be an option from the Properties screen.

Any ideas on how to navigate to change the Type of a user defined Field?



problem identified.JPG


advanced settings - two check boxes.JPG


regular properties - checkboxes.JPG
 
Outlook version
Outlook 2016 64 bit
Email Account
Exchange Server
#4
Figured it out... a bit tricky but the field can be saved in a number of places and needs to be deleted from each of them before you're able to reset a new field with the same name but different values/properties.

From Developer > design this form >all fields tab

Locate the problematic field from "User-defined fields in this ITEM."

Delete button should be on the bottom of the screen.

THEN switch the "Select From" drop down to "User-defined fields in this FOLDER."

Once the problematic field is fully deleted from multiple locations, you can create a new one with the correct settings.
solved.JPG
 

Similar threads

Top