Prevent connection to Public Folders on Exchange?

AndrewWeb

New Member
Outlook version
Outlook 2013 32 bit
Email Account
Exchange Server
#1
I would like to avoid trying to connect to public folders in my Outlook 365 (Version 1809, Build 1082.80181 Click-to-run). I saw a way to do this in older setups, which involved creating a 0-valued HasPublicFolders key in the registry under "HKEY_CURRENT_USER\Software\Microsoft\Exchange\Setup". But it seems that this registry key is no longer around.

The autodiscover.xml that my outlook gets from the exchange server is trying to connect me to a public folder to which I don't have access, so I keep getting prompts for credentials to connect. I asked my IT team about it, and they just wanted me to make sure I didn't have an extra profile for that public folder (which I didn't). I've done repairs, uninstall/reinstall, etc., but the phantom public folder credential prompts keep coming back. Is there a way to tell outlook not to look for those folders? Worst case, I guess I could turn off autodiscover, edit that xml file to remove the reference to the public folder. Any other ideas?

Thanks!
 

AndrewWeb

New Member
Outlook version
Outlook 2013 32 bit
Email Account
Exchange Server
#2
Apologies: I meant to say that under my "Exchange Account Settings", I have "Cached Exchange Mode" checked, but have always unchecked the options for "Download shared folders" and "Download Public Folder Favorites"
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#3
As far as I know, you can't block PF in current versions. You can try adding the Setup key and adding that value to it - i tried it, but its not working. However, it might only work if you add the account after setting the key.
 
Top