Moving .OST file location unsuccessful!

Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#1
I have two Outlook.com email accounts in Outlook 16 which I had successfully managed to change the Data Files to D:\Users| Username\Documents\Outlook Files\ IMAP folder.
All steps below have been carried out with Office 16 closed and adding the email thru Control Panel > Mail > email accounts > Manually as I have to enter the Incoming and Outgoing mail servers, New Outlook Data File checked, ports etc.
I have tried to change the location for the data file location using the ForcePSTPath for a new (BT Mail) IMAP account without success, it still stored the data file in C:\Users\Username\AppData\Local\Microsoft\Outlook\email address.ost file.
2018-11-12_19-58-25.jpg
:(
I removed the IMAP account and deleted the data file saved in C:\Users\Username\AppData\Local\Microsoft\Outlook\email address.ost file.
I altered the location using the ForceOSTPath method and still the data file is saved to C:\Users\Username\AppData\Local\Microsoft\Outlook\email address.ost file.
When I started Outlook 16 it did synchronize with the server but the account pane appears as below;
2018-11-12_19-57-36.jpg
:confused:
And these XML documents are the only ones that show in Documents\Outlook\IMAP
2018-11-12_19-55-54.jpg
:confused:
I need to move the Data File for the IMAP account to D:\ drive as my SSD has a small capacity.
Any ideas on how to move the .ost file to the D:\ drive?

Any help will be most appreciated.
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#2
May I add other issues with Outlook 16 in addition to the above as I cannot find how to edit the post.
I can make the IMAP account to be the default but I cannot make the IMAP account Data File the default I get the following message;
2018-11-12_22-36-02.jpg

  1. The other issue I have come against is that the Calendar Docking icon does not work.
  2. Importing Contacts that have been exported from Outlook 2007 in CSV format do not appear in Outlook 16 Contacts. When I click to compose a new email with the IMAP account and click To the IMAP account does not appear and neither do any Contacts!:mad:
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#3
I'll start with the second message first - it's easier to answer. :)

The message about the imap not being the default data file - its because you have 2 outlook.com accounts in your profile. They are exchange accounts. If you don't need calendar & contacts syncing from both, remove one and add it as IMAP. However, i really recommend using outlook.com for calendar and contacts to prevent data loss if anything happens to a default imap ost.

If the problem is just that you want to see the imap inbox first when you open outlook, that is changed in file, options, advanced. Top of the page. Choose the Folder Outlook Starts Up In

Calendar docking: what exactly happens?

Importing contacts: were they imported into the imap data file or the default outlook.com data file? Find out of the contacts and open it, retype the address. Does it should up in the address book now? If yes, see Imported Addresses are Missing from Address Book Another cause of the To button showing an empty address book is having the wrong contacts folder as default.

See iCloud Contacts are not showing in Address Book - Outlook Tips for the steps to check and fix it. (It applies to more than icloud. :))
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#4
Moving IMAP data files: Did you use the forcepstpath or the forceostpath registry key? You mention both - the forcepstpath should be the correct one (unless they changed something since i last tested it). Add both - since you want all of the data files off the SSD.


You definitely need to remove the account and add it back after setting the key - the path is set in the registry when you first add the account. In older versions, you had to make a new profile - when i last tested this, it was not necessary in modern versions. I will retest it and see if that changed.

Alternately, you can use junction points/ symlinks to move the folder. More info is at How to move IMAP data files
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#5
My answers to Outlook forum
Seeing the imap inbox first; yes that is the preferred inbox and I shall follow your instructions here Choose the Folder Outlook Starts Up In.
As for the outlook.com accounts one is used as the Microsoft account for billing of Office 365 Personal only and the other is used for the secretary and minister to sync the calendar to his iPhone only no emails.

Calendar docking; according to Microsoft “When you point to the Calendar icon on the navigation bar, the Calendar peek shows your upcoming appointments and meetings. To always be able to see your upcoming items, dock the Calendar peek to the Outlook window.” So that the appointments show in the To-Do Bar. As I said above the outlook.com account for the minister is the only account using the Calendar. I have tried the instructions here https://support.office.com/en-us/article/keep-upcoming-appointments-and-meetings-always-in-view-0e5f30da-c44d-4b96-8fd9-ba5d10db0962 for the outlook.com account that uses the calendar and the other two accounts but nothing seems to show on the To-Do bar.
Importing contacts: I imported them to the imap account. I will try again later this evening and post back with the results, as I am unable to get to the pc at the moment.

Moving IMAP data files:
  • I removed the imap account and by default it removes the Data File too, I also deleted the .ost file from C:\Users\Username\AppData\Local\Microsoft\Outlook\email address.ost file so as I believe the imap account is no longer in Outlook.
  • I used the forcepstpath registry key.
  • Opened Control Panel > Mail > E-mail accounts > Account settings > New added the imap account and the account was added to Outlook. But the Data File was placed in C:\Users\Username\AppData\Local\Microsoft\Outlook\email address.ost file and not in the D:\Users\Username\ AppData\Local\Microsoft\Outlook\email address.ost as the screenshots show in my first post.
  • I then proceeded to remove the imap account and associations again and tried the forceostpath registry key but that did not work either.
I have research the net for a solution but your excellent explanations are the best I can find, on another forum they just said and I quote “If it's a OST file there is no need to move it just delete the file an OST file is recreated from the server unlike pst which is local” that I find difficult to believe.

What I might do in the next couple of days is to remove all tree email accounts use the both forcepstpath and forceostpath registry keys and the add the imap account first followed by the two outlook.com accounts and see if that helps.
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#6
On another issue; When I archive emails I wish to archive emails, so as to reduce the number of emails in the inbox, by date for example all 2014 in one folder, all 2015 in separate archive folder and so on. So that each year's email are archived in their respective archive folder and can archive folders name be changed.
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#7
Update:
The issue with changing the location of the Data File for the IMAP email account I have now resolved by removing the IMAP email account and deleting the Data File from C:\Users\Username\AppData\Local\Microsoft\Outlook\email address.ost. Restarting the pc adding the ForcePSTPath and the ForceOSTPath registry keys and restarting the pc again. Added the IMAP email account using the Control Panel > Mail > E-mail Accounts > New adding the IMAP account manually.
The issue with archiving emails has also been resolved.
The issue with the "peek icon" is ongoing, the icon does not work when following the instruction on this web page https://support.office.com/en-us/article/keep-upcoming-appointments-and-meetings-always-in-view-0e5f30da-c44d-4b96-8fd9-ba5d10db0962
 

Similar threads

Top