Outlook 365 ignores ForceOSTpath - how to relocate it?

ofw62

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#1
Applied ForceOSTpath before changing from POP3 to IMAP
Initially... indeed the .ost file was located in a folder that has been defined by me (N:\Outlook)
Note: "N" is not a network drive in this case.

I just checked but Outlook seemed to have decided to relocate the .ost file to C: again, ignoring the registry patch.

How to solve this?

Maybe start from scratch?
Maybe remove account, set the Outlook.pst as default, try to export rules (can they be imported into Outlook 365 via IMAP?)
reboot and create IMAP account again?

IMAP... deep sigh..

thanks.


SnagIt-02122018 090132.png


later....

found another thread titled "Moving .OST file location unsuccessful!"
Moving .OST file location unsuccessful!

will proceed likewise, see what happens.
 
Outlook version
Outlook 2016 32 bit
Email Account
Outlook.com (as MS Exchange)
#3
Hi Deep,

Could you please help me with some details?
1. May I know how many email accounts are configured in Outlook?
2. Navigate to File > Account settings > Account settings > Data file Tab > Share the screenshot.

Also, make sure you have your Outlook upto date.

Thanks,
Niks
 

ofw62

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#4
I have set up Outlook over half a dozen times, with ForceOSTPath.
Each time removing account, each time removing .ost files.
Rebooted same times.

The .ost file will be stored on C:



Capture-02122018 113320.png


registry settings before install of new account
and after.

Maybe the latest Office 365 does not allow ForceOSTPath anymore...??

Capture-02122018 113847.png
 

ofw62

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#6
Is that based on Exchange or IMAP Diane?

The below may be interesting.

Today I tried again and again... 4x
Remove account within Outlook, delete the .ost file (also the tmp ost)
Then add new account, selected IMAP, advanced, entered server settings, when done, the .ost file is on C:
Also tried ForceOSTPath as a normal key (REG_SZ) instead of REG_EXPAND_SZ, each time rebooting and removing .ost from C:


Now, here is something important, really.

It is the way how to the account is being et up ...

When selecting 'Advanced' and subsequently selecting IMAP, then by default the .ost is stored on C:\
At least, that is my experience after a dozen+ tries (really!).
Have spent hours on this.

However, I remembered that, initially, at the very first time, when starting off with Outlook 365, yesterday, at adding a new account, I simply entered my email address, password, i.e. I did not use the advanced options.

I was happy to notice that the .ost file was stored where I wanted it to be stored.

In that case, the method is Exchange, not IMAP.

My conclusion:
IMAP - .ost is stored on C:\ (the ForceOSTPath registry is ignored)
Exchange - the .ost file is stored as per ForceOSTPath registry-key.

You might ask why I want to use IMAP anyway.
That is because I am using a 3rd party spam filtering tool. I am using that tool for many, many years.
I discovered that does not support Exchange, regretfully so.

The tool marks/filters all spam, scam and even viruses and I can read mail (preview) before it is downloaded.
That is when using POP3 or IMAP. I think it is really nice software.
A very quick search on Internet shows me that probably affordable 3rd party spam filters, based on Exchange, meant for single end-users, is hardly available.
It is therefore I that I firmly tried to add an account basis IMAP, but with .ost stored in the folder I want.



2018-12-03_07-32-32.png
 
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#7
Apologies to jump in here but I had the same problem trying to move the Data File for IMAP account and I eventually managed to do so with the following steps.
I did eventually managed to move the .ost IMAP file to the D\: drive.
This is how I managed to resolve the issue of moving Data Files to the D\:Users\Username\Documents\Outlook Files\IMAP folder.
  • Removed the email account from Outlook, (the Data File will be removed by default). The email account and Data File MUST be removed before you create the ForcePSTPath key AND the ForceOSTPath!
  • Deleted the file in C:\Users\Username\AppData\Local\Microsoft\Outlook\email address.ost file.
  • Opened the Registry, navigated to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook
  • I created both the Expandable String Value:ForcePSTPath key AND the ForceOSTPath and the Value data to read “D\:\Users\Username\Documents\Outlook Files\IMAP
  • Saved Registry and powered off the pc.
  • Powered on the pc
  • Opened Control Panel > Mail > E-mail accounts > Account settings > New added the IMAP account Manually (Do not use Add new mail account within Outlook!)
  • The Data File was created the Data Path D\:Users\Username\Documents\Outlook Files\IMAP folder.
Hope this is helpful.
When the office is shut I will take some screen shots to prove the Data File was moved to the D\:Users\Username\Documents\Outlook Files\IMAP folder.
 

Diane Poremsky

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
Office 365 Exchange
#8
Is that based on Exchange or IMAP Diane?
Oh. Exchange. Try the forcepstpath with imap.

This dates back to when imap used pst files - they never changed the key when they changed the data file type.
 

ofw62

Senior Member
Outlook version
Outlook 2016 32 bit
Email Account
POP3
#10
Thanks Diane. I was using a 3rd party tool that filters/marks spam/viruses/scam based on spamblock-lists (spamhouse/spamcop)
That worked fine. Have been using more than 15 years. It works fine with POP3: mail is first filtered before it is retrieved from the mail server.
However, with IMAP and Exchange, the mail arrives in the mailbox without delay, hence filtering is not possible anymore.

IMAP for Mac had something like IMAP IDLE, Windows has no 'delayed delivery' option, AFAIK.

Anyway I have an Exchange account now.

Thanks again.
 

Similar threads

Top