Archive by receive date not working

danno

Member
Outlook version
Outlook 2010 32 bit
Email Account
IMAP
I have Outlook 2010 on Windows 7.

In my scenario, I'm trying to archive emails dated ('receive date') over 3 years from today's date (I have added the registry entry regarding 'modified date' mentioned here: AutoArchiving by Received Date in Outlook). The PST file is large (just under 50gb) and has about 280k+ items in it and after the archive operation completed, I did search on the original PST file for 'receive date' more than 3 years ago and over 73k items were still found. (!?)

  • No items are flagged (I saw a post on a online support forum that suggested that making sure items are not 'flagged')
  • I was considering creating a rule to move the messages, but I need the folder structure maintained (archiving does that, moving by rule doesn't)
  • Can't move the items from the search results, since the folder structure wouldn't be maintained

Not sure what to try here - am I stuck trying to write VBA code to accomplish this?
 

TerranceM

New Member
Outlook version
Outlook 2016 64 bit
Email Account
Exchange Server
Kindly follow below steps to make Outlook archive emails by received date or modified date.

1. Press Win + R keys simultaneously to open the Run dialog box.

2. In the Run dialog box, please type the text of Regedit into the Open box and click the OK button.

3. Now the User Account Control dialog box comes out. Please click the Yes button to go ahead.

4. Now the Registry Editor window is open. Please open the folder by below path:

Note: Above path is for Outlook 2016. If you are using Outlook 2013, please change 16.0 in above path to 15.0; for Outlook 2010, please change 16.0 to 14.0.

5. Please right click the Preference in the tree structure, select New > DWORD (32-bit) Value from the right-clicking menu, and then name the new items as ArchiveIgnoreLastModifiedTime.

6. Double click the new item to open the Edit DWOR (32-bit) value dialog box, change the value data to 1, and click the OK button.

Note: For archiving emails by received date, please change the value data to 1; for archiving emails by modified date, please change the value data to 0.

7. Close the Registry Editor window.

From now one, emails will be archived by received date (or modified date) if AutoArchive is enabled or you apply File > Info > Tools > Clean Up old Items manually.

Note: Unfinished flagged emails won’t be archived even if their received dates or modified dates are earlier than the specified archiving date.

--
Terrance
 

danno

Member
Outlook version
Outlook 2010 32 bit
Email Account
IMAP
Kindly follow below steps to make Outlook archive emails by received date or modified date.

1. Press Win + R keys simultaneously to open the Run dialog box.

2. In the Run dialog box, please type the text of Regedit into the Open box and click the OK button.

3. Now the User Account Control dialog box comes out. Please click the Yes button to go ahead.

4. Now the Registry Editor window is open. Please open the folder by below path:

Note: Above path is for Outlook 2016. If you are using Outlook 2013, please change 16.0 in above path to 15.0; for Outlook 2010, please change 16.0 to 14.0.

5. Please right click the Preference in the tree structure, select New > DWORD (32-bit) Value from the right-clicking menu, and then name the new items as ArchiveIgnoreLastModifiedTime.

6. Double click the new item to open the Edit DWOR (32-bit) value dialog box, change the value data to 1, and click the OK button.

Note: For archiving emails by received date, please change the value data to 1; for archiving emails by modified date, please change the value data to 0.

7. Close the Registry Editor window.

From now one, emails will be archived by received date (or modified date) if AutoArchive is enabled or you apply File > Info > Tools > Clean Up old Items manually.

Note: Unfinished flagged emails won’t be archived even if their received dates or modified dates are earlier than the specified archiving date.

--
Terrance
Looks like you didn't read my post and just copy/pasted. I HAD ALREADY DONE that registry edit as I had clearly stated in my original post and even gave a link to the source.
 
Top