MaxMessagesPerConnection in Exchange 2007

  • Thread starter Richard Sobey
  • Start date Views 1,359
R

Richard Sobey

Dear all

In Exchange 2003, under the SMTP Virtual Server proprties, there was a

setting to control the MaxMessagesPerConnection value. We had this set

at 10, as dictated by the use of our exim smarthost.

We now need to find an equivalent setting, or workaround, for Exchange

2007. It seems that the only rate limiting options are for

Connections, or ReceiveConnectors. By not being able to fix

MaxMessagesPerConnection value at 10, Exchange 2007 is opening a

connection to exim and then bundling any number of messages down it,

after 10 have been sent exim will delay the delivery of those

messages, and we don't really want it to do that.

Before we start trying to find workarounds in exim, I'd really like to

fix it at the source, i.e. our HT servers.

Config: 5 x mailbox servers, 4 x quad Xeon each.

2 x HT servers, 2 x quad Xeon each.

Any suggestions welcome!

Cheers

Richard
 
M

Muhammad Irfan Sadiq

Richard

This could be accomplished by using a custom Windows PowerShell Script on HT

Server within that script you can set the value of MaxMessagesPerConnection

to 10. Hope This helps.

Thanks & Enjoy Your Day!.

Muhammad Irfan Sadiq

Systems Engineer

"Richard Sobey" wrote:


> Dear all

> In Exchange 2003, under the SMTP Virtual Server proprties, there was a
> setting to control the MaxMessagesPerConnection value. We had this set
> at 10, as dictated by the use of our exim smarthost.

> We now need to find an equivalent setting, or workaround, for Exchange
> 2007. It seems that the only rate limiting options are for
> Connections, or ReceiveConnectors. By not being able to fix
> MaxMessagesPerConnection value at 10, Exchange 2007 is opening a
> connection to exim and then bundling any number of messages down it,
> after 10 have been sent exim will delay the delivery of those
> messages, and we don't really want it to do that.

> Before we start trying to find workarounds in exim, I'd really like to
> fix it at the source, i.e. our HT servers.

> Config: 5 x mailbox servers, 4 x quad Xeon each.
> 2 x HT servers, 2 x quad Xeon each.

> Any suggestions welcome!

> Cheers

> Richard
>
 
M

Muhammad Irfan Sadiq

FYI.

Thanks & Enjoy Your Day!.

Muhammad Irfan Sadiq

Systems Engineer

"Muhammad Irfan Sadiq" wrote:

Richard

This could be accomplished by Creating a New Recieve Connector Using

customise Windows PowerShell Script on HT Server, within that script you can

set the value of MaxMessagesPerConnection to 10. Hope This helps if not

Please Advise me i can get you more info on it.

Thanks & Enjoy Your Day!.

Muhammad Irfan Sadiq

Systems Engineer


> "Richard Sobey" wrote:
>
> > Dear all
> > In Exchange 2003, under the SMTP Virtual Server proprties, there was a
> > setting to control the MaxMessagesPerConnection value. We had this set
> > at 10, as dictated by the use of our exim smarthost.
> > We now need to find an equivalent setting, or workaround, for Exchange
> > 2007. It seems that the only rate limiting options are for
> > Connections, or ReceiveConnectors. By not being able to fix
> > MaxMessagesPerConnection value at 10, Exchange 2007 is opening a
> > connection to exim and then bundling any number of messages down it,
> > after 10 have been sent exim will delay the delivery of those
> > messages, and we don't really want it to do that.
> > Before we start trying to find workarounds in exim, I'd really like to
> > fix it at the source, i.e. our HT servers.
> > Config: 5 x mailbox servers, 4 x quad Xeon each.
> > 2 x HT servers, 2 x quad Xeon each.
> > Any suggestions welcome!
> > Cheers
> > Richard
> >
 
R

Richard Sobey

On Mon, 6 Jul 2009 21:35:01 -0700, Muhammad Irfan Sadiq

<mirfansadiq@gmail.com> wrote:


> This could be accomplished by Creating a New Recieve Connector Using
> customise Windows PowerShell Script on HT Server, within that script you can
> set the value of MaxMessagesPerConnection to 10. Hope This helps if not
> Please Advise me i can get you more info on it.


Thanks for the reply Muhammad. Unfortunately (I wasn't clear) I am

talking about Exchange sending mail, not receiving it.

Regards

Richard
 

Top