Exchange 2007 down after moving some critical Mailboxes on it and

  • Thread starter Diego Castelli
  • Start date Views 1,274
D

Diego Castelli

Hi all,

i'm in big troubles seriously:

i had a problem with a corrupted VM that hosts Exch 2007, this after moving

some critical mb on it from our exchange 2003.

I am able to restore the very near status just before moving the mailboxes

and the trans. logs from the newest status.

i am not able to play logs forward with eseutil 'cause i miss restore.env

file (tried to create it manually - following the example here:

http://support.microsoft.com/kb/253914, but it tells me is corrupted).

I obviously can't see the mb in "disconnected" state in no server.

here they don't have a consistent backup of the mailboxes... surprise...

please help....
 
L

Lanwench [MVP - Exchange]

Diego Castelli <DiegoCastelli> wrote:
> Hi all,
> i'm in big troubles seriously:

> i had a problem with a corrupted VM that hosts Exch 2007, this after
> moving some critical mb on it from our exchange 2003.

> I am able to restore the very near status just before moving the
> mailboxes and the trans. logs from the newest status.

> i am not able to play logs forward with eseutil 'cause i miss
> restore.env file (tried to create it manually - following the example
> here: http://support.microsoft.com/kb/253914, but it tells me is
> corrupted).

> I obviously can't see the mb in "disconnected" state in no server.
> here they don't have a consistent backup of the mailboxes...
> surprise...

> please help....


I'd be calling PSS at this point if it were me, honestly.
 
D

Diego Castelli

Re: Exchange 2007 down after moving some critical Mailboxes on it

Posting here to help people in the future:

if you have ALL the logs in the folder starting from E00....001, you can

replay them in the DB doing so:

DELETE the DB

DELETE the Exx.chk file

Mount the DB and wait.

Exchange is going to recreate the DB and filling it with the content of the

logs (everything, guys...).

At the end you'll have the DB filled with your data and operational.

hope this can help someone in the future.

Bye

"Lanwench [MVP - Exchange]" wrote:


> Diego Castelli <DiegoCastelli> wrote:
> > Hi all,
> > i'm in big troubles seriously:
> > i had a problem with a corrupted VM that hosts Exch 2007, this after
> > moving some critical mb on it from our exchange 2003.
> > I am able to restore the very near status just before moving the
> > mailboxes and the trans. logs from the newest status.
> > i am not able to play logs forward with eseutil 'cause i miss
> > restore.env file (tried to create it manually - following the example
> > here: http://support.microsoft.com/kb/253914, but it tells me is
> > corrupted).
> > I obviously can't see the mb in "disconnected" state in no server.
> > here they don't have a consistent backup of the mailboxes...
> > surprise...
> > please help....


> I'd be calling PSS at this point if it were me, honestly.

>
 
D

Diego Castelli

Re: Exchange 2007 down after moving some critical Mailboxes on it

Please keep in mind that calendar and other stuff not related to messages

aren't probably in the logs so you can loose some data with this procedure....

"Diego Castelli" wrote:


> Posting here to help people in the future:

> if you have ALL the logs in the folder starting from E00....001, you can
> replay them in the DB doing so:

> DELETE the DB
> DELETE the Exx.chk file

> Mount the DB and wait.

> Exchange is going to recreate the DB and filling it with the content of the
> logs (everything, guys...).

> At the end you'll have the DB filled with your data and operational.

> hope this can help someone in the future.

> Bye
> "Lanwench [MVP - Exchange]" wrote:
>
> > Diego Castelli <DiegoCastelli> wrote:
> > > Hi all,
> > > i'm in big troubles seriously:
> > > > i had a problem with a corrupted VM that hosts Exch 2007, this after
> > > moving some critical mb on it from our exchange 2003.
> > > > I am able to restore the very near status just before moving the
> > > mailboxes and the trans. logs from the newest status.
> > > > > i am not able to play logs forward with eseutil 'cause i miss
> > > restore.env file (tried to create it manually - following the example
> > > here: http://support.microsoft.com/kb/253914, but it tells me is
> > > corrupted).
> > > > I obviously can't see the mb in "disconnected" state in no server.
> > > here they don't have a consistent backup of the mailboxes...
> > > surprise...
> > > > please help....

> > I'd be calling PSS at this point if it were me, honestly.
> >
 
Top