SP2 seems to break desktop alerts in outlook 2007

  • Thread starter bmllbWll
  • Start date Views 5,422
Status
Not open for further replies.

Brian Tillman

Senior Member
"D L S" <DLS> wrote in message

news:D1E2B462-BA9E-42A5-8CC7-0678D6B42099@microsoft.com...


> I installed the Office 2007 SP2 last week and since then desktop alert does
> not work.


I can attest that it's not systeminc in Outlook. I, too, installed SP2 on by

XP and Vista and my Desktop Alerts work.

--
 
Q

QW5kaQ

I have Vista and Outlook2007 Sp2.

Desktop Alerts is not working too.

my solution: run outlook one time as admin.

klick on preview desktop alert button-> work now!

close outlook

start outlook normal

"niemie" wrote:


> I just downloaded SP2 for office - i was happy to read about the improvements
> in stability to outlook. I think I found a bug though as SP2 seems to kill
> the desktop alert feature altogether. It stopped working for me and then I
> created a new rule for it which doesn't work either. I even went into tools
> / options and the preview desktop alert button did nothing - it's dead.
 
M

Milhouse Van Houten

And you've tested running it normally how many times? I think you'll find

that it was just a coincidence.

"Andi" <Andi> wrote in message

news:1FE8DC29-AE36-466F-ADB3-E2C60AA94AFC@microsoft.com...
> I have Vista and Outlook2007 Sp2.
> Desktop Alerts is not working too.
> my solution: run outlook one time as admin.
> klick on preview desktop alert button-> work now!
> close outlook
> start outlook normal

> "niemie" wrote:
>
> > I just downloaded SP2 for office - i was happy to read about the
> > improvements
> > in stability to outlook. I think I found a bug though as SP2 seems to
> > kill
> > the desktop alert feature altogether. It stopped working for me and then
> > I
> > created a new rule for it which doesn't work either. I even went into
> > tools
> > / options and the preview desktop alert button did nothing - it's dead.
 
Q

QW5kaQ

i must run outlook "as administrator" one time, but EVERY DAY wenn boot up

the computer

"Milhouse Van Houten" wrote:


> And you've tested running it normally how many times? I think you'll find
> that it was just a coincidence.

> "Andi" <Andi> wrote in message
> news:1FE8DC29-AE36-466F-ADB3-E2C60AA94AFC@microsoft.com...
> > I have Vista and Outlook2007 Sp2.
> > Desktop Alerts is not working too.
> > my solution: run outlook one time as admin.
> > klick on preview desktop alert button-> work now!
> > close outlook
> > start outlook normal
> > "niemie" wrote:
> >
> >> I just downloaded SP2 for office - i was happy to read about the
> >> improvements
> >> in stability to outlook. I think I found a bug though as SP2 seems to
> >> kill
> >> the desktop alert feature altogether. It stopped working for me and then
> >> I
> >> created a new rule for it which doesn't work either. I even went into
> >> tools
> >> / options and the preview desktop alert button did nothing - it's dead.


>
 
M

Milhouse Van Houten

Consider the following scenario:

The desktop alert issue has been a problem not merely since SP2, but SP2's

antecedent: the mega Outlook patch that came out a couple months ago. Then,

on April 30th, MS released a hotfix for Outlook fixing myriad issues. And

guess which one is not among them?

Or at least it doesn't mention it. Perhaps someone can try it.

http://support.microsoft.com/kb/968858
 
Z

ZHRnVkE

I too have the same problem as many of you. Desktop Alterts not functioning

properly after SP2 installation. This is what I have observed when trying to

troubleshoot this problem:

When first opening Outlook 2007, if I have incoming new mail, the desktop

alert does not display. Nor will it provide a preview of the desktop alerts

in the Avanced options section of Email options from the Tool menu. On exit

of Outlook, the new grayed out icon that displays when closing Outlook takes

a long time to completely close or does not go away at all until a reboot.

If there is no new mail upon opening Outlook, the desktop alert will display

any new mail AFTER that initial check of mail on startup. On exit, Outlook

shutdowns properly without the grayed out icon hanging.

I have been able to consistently recreate this scenario over the past two

days. It would be good to find out if anyone else can duplicate my findings.

BTW, Office 2007 Smaill Business SP2 and Vista Home Premium SP1

Regards,

David

"blueskyjason" wrote:


> I just wanted to throw in my two cents that SP2 broke my Desktop Alerts as
> well. I did a Repair and that fixed them for a day. Now they are broken
> again. Hitting "preview desktop alert" in the advanced mail configuration
> proves that desktop alerts are simply broken. I am on Vista SP1.

> "Diane Poremsky [MVP]" wrote:
>
> > It could be related to the windows beta. Do you see a difference in
> > behavior if you have windows maximized?
> > > >

> > > > > >

> > > > > > > > "Milhouse Van Houten" <btvs@myrealbox.com> wrote in message
> > news:#FhClsayJHA.1380@TK2MSFTNGP05.phx.gbl...
> > > Here I'm somewhere in between: it doesn't work, maybe, 1 out of 3 times I
> > > run Outlook. Restarting Outlook proves necessary (rebooting the machine is
> > > overkill, though I've done that many times since installing SP2).
> > > > Note that when it doesn't work, even the 'test alert' feature hidden in
> > > Tools/Options doesn't work, so it's truly dead, Jim, and has nothing to do
> > > with Rules, etc.
> > > > It's hard to believe this could have slipped by the "largest" Office SP
> > > test in history, since surely someone there would have had the
> > > configuration necessary to make this show up.
> > > > I run POP3/IMAP, not Exchange, if it matters. Win7 RC, which may.
> > > > "Christof" <Christof> wrote in message
> > > news:FB205B5B-8FAE-4738-816B-F3CADB1F3850@microsoft.com...
> > >> That does not solve it here (on both of my machines). Desktop Alert is
> > >> gone.
> > >> I can reboot as much as I want :-(
> > >
> > >
> > >> "Diane Poremsky [MVP]" wrote:
> > >
> > >>> A forced reboot is not always required, so for some people it's only one
> > >>> reboot, but yeah, I've noticed that sometimes a user-initiated reboot
> > >>> makes
> > >>> a difference. I have no idea what it does differently, only that it
> > >>> works.
> > >>
> > >>> > > >>>

> > >>
> > >>
> > >>
> > >>>

> > >> > >>
> > >>>

> > >> > >>
> > >> > >>> or point
> > >>> your
> > >> > >>
> > >>
> > >>> "niemie" <niemie> wrote in message
> > >>> news:B0F45533-C479-4384-9516-50DCE48135AB@microsoft.com...
> > >>> > Ok I rebooted and it works now - I wouldn't have thought of that
> > >>> > because
> > >>> > the
> > >>> > system rebooted automatically after SP2 install.....
> > >>> > >>> > Thanks for the help.
> > >>> > >>> > "Diane Poremsky [MVP]" wrote:
> > >>> > >>> >> Did you reboot? It works here, so its not a direct bug - but its
> > >>> >> possible
> > >>> >> an add-in or something is interacting with it.
> > >>> >
> > >>> >> > > >>> >>

> > >>> >> > > >>> >> > > >>> >
> > >>> >>

> > >>> >> > > >>> >
> > >>> >> > > >>> >> > > >>> >
> > >>> >
> > >>> >
> > >>> >
> > >>> > > >>> >> or point
> > >>> >> your
> > >>> > > >>> >
> > >>> >
> > >>> >> "niemie" <niemie> wrote in message
> > >>> >> news:8597DD9D-DA01-45A5-8B1B-DEFC4F1EEB83@microsoft.com...
> > >>> >> > I just downloaded SP2 for office - i was happy to read about the
> > >>> >> > improvements
> > >>> >> > in stability to outlook. I think I found a bug though as SP2 seems
> > >>> >> > to
> > >>> >> > kill
> > >>> >> > the desktop alert feature altogether. It stopped working for me
> > >>> >> > and
> > >>> >> > then
> > >>> >> > I
> > >>> >> > created a new rule for it which doesn't work either. I even went
> > >>> >> > into
> > >>> >> > tools
> > >>> >> > / options and the preview desktop alert button did nothing - it's
> > >>> >> > dead.
> > >>> >
> > >>> >
> > >>>

> >
 
U

Um9nZXIgTGVl

I added a registry dword that told outlook 2007 to put the desktop alert in

the bottom right ("Corner"=dword:00000003). Copy paste the stuff between the

borders below to a notepad, save as name.reg and run. Works so far...

~~~~~~~~~~

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\DesktopAlerts]

"Opacity"=dword:000000d4

"TimeOn"=dword:00006978

"XOffset"=dword:00000005

"YOffset"=dword:00000005

"Corner"=dword:00000003

~~~~~~~~~~
 
U

Um9nZXIgTGVl

Confirmed. Adding the registry entry "Corner"=dword:00000003 fixes the

problem. I rebooted and desktop alerts are definitely working. Perhaps SP2

deleted the reg entry? Anyone have a pre SP2 installation?

-R. Lee

"Roger Lee" wrote:


> I added a registry dword that told outlook 2007 to put the desktop alert in
> the bottom right ("Corner"=dword:00000003). Copy paste the stuff between the
> borders below to a notepad, save as name.reg and run. Works so far...
> ~~~~~~~~~~

> REGEDIT4

> [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\DesktopAlerts]
> "Opacity"=dword:000000d4
> "TimeOn"=dword:00006978
> "XOffset"=dword:00000005
> "YOffset"=dword:00000005
> "Corner"=dword:00000003

> ~~~~~~~~~~
 
J

James

On May 26, 11:12 pm, Roger Lee <Roger...
wrote:
> Confirmed.  Adding the registry entry "Corner"=dword:00000003 fixes the
> problem.  I rebooted and desktop alerts are definitely working.  Perhaps SP2
> deleted the reg entry?  Anyone have a pre SP2 installation?

> -R. Lee

> "Roger Lee" wrote:
> > I added a registry dword that told outlook 2007 to put the desktop alert in
> > the bottom right ("Corner"=dword:00000003).  Copy paste the stuff between the
> > borders below to a notepad, save as name.reg and run. Works so far...
> > ~~~~~~~~~~

>
> > REGEDIT4

>
> > [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\DesktopAlerts]
> > "Opacity"=dword:000000d4
> > "TimeOn"=dword:00006978
> > "XOffset"=dword:00000005
> > "YOffset"=dword:00000005
> > "Corner"=dword:00000003

>
> > ~~~~~~~~~~


Thanks guys, been waiting for someone to solve this "problem" that

Microsoft hasn't seemed to acknowledge.
 
R

R1o

Hello Roger,

I have had the same problem and wanted to use your temporary fix.

When I go into my regedit and find the HKey, how do I add the stuff between

the borders into the key or do I create a new one? If I am to add it to the

existing key, how do I do that? Do I copy and paste? I am not sure it allows

me to that and that is why my question about creating a new key.

BTW, the only value that I see under that key on my regedit is the opacity.

It does not showTimeon, Xoffset and YOffset so all these will be new addition

to my regeditl

I sure apreciatte your help and response on this. I am running Vista

Ultimate 64 SP2 together with MSOffice 2007 Ultimate SP@.

Thanks!!

GZ

"Roger Lee" wrote:


> I added a registry dword that told outlook 2007 to put the desktop alert in
> the bottom right ("Corner"=dword:00000003). Copy paste the stuff between the
> borders below to a notepad, save as name.reg and run. Works so far...
> ~~~~~~~~~~

> REGEDIT4

> [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\DesktopAlerts]
> "Opacity"=dword:000000d4
> "TimeOn"=dword:00006978
> "XOffset"=dword:00000005
> "YOffset"=dword:00000005
> "Corner"=dword:00000003

> ~~~~~~~~~~
 
R

RGF2aWQgVUs

This worked for me!

First off lets get Outlook up and running, then go to the system tray and

you will see the Outlook Icon, right click the icon then uncheck the "Show

New Mail Desktop Alert" then restart Outlook, once Outlook has re-started

re-check "Show New Mail Desktop Alert" and your desktop alerts should be

reinstated!

Hope it works for you as it did for me!!!

"niemie" wrote:


> I just downloaded SP2 for office - i was happy to read about the improvements
> in stability to outlook. I think I found a bug though as SP2 seems to kill
> the desktop alert feature altogether. It stopped working for me and then I
> created a new rule for it which doesn't work either. I even went into tools
> / options and the preview desktop alert button did nothing - it's dead.
 
M

Milhouse Van Houten

Where did you get that from? It does appear to work.

"David UK" <DavidUK> wrote in message

news:F89B92DD-A9DE-41A8-A79F-56B43209F2C5@microsoft.com...
> This worked for me!

> First off lets get Outlook up and running, then go to the system tray and
> you will see the Outlook Icon, right click the icon then uncheck the "Show
> New Mail Desktop Alert" then restart Outlook, once Outlook has re-started
> re-check "Show New Mail Desktop Alert" and your desktop alerts should be
> reinstated!

> Hope it works for you as it did for me!!!

> "niemie" wrote:
>
> > I just downloaded SP2 for office - i was happy to read about the
> > improvements
> > in stability to outlook. I think I found a bug though as SP2 seems to
> > kill
> > the desktop alert feature altogether. It stopped working for me and then
> > I
> > created a new rule for it which doesn't work either. I even went into
> > tools
> > / options and the preview desktop alert button did nothing - it's dead.
 
M

Milhouse Van Houten

But there has to be more to it than that, since it sometimes worked even

without Corner.

The entire DesktopAlerts section doesn't exist in SP1 (and probably SP2)

unless (and this is the part I haven't confirmed) you customize your desktop

alerts (duration, opacity, etc). Then I bet it appears. Whether Corner is

there too I don't know.

But I bet this explains why so few people have seen the problem -- few

people ever customize desktop alerts. And if that section doesn't exist, you

may be immune to the problem.

I didn't use the Corner workaround, however, but rather the one elsewhere in

this thread:


> First off lets get Outlook up and running, then go to the system tray and
> you will see the Outlook Icon, right click the icon then uncheck the "Show
> New Mail Desktop Alert" then restart Outlook, once Outlook has re-started
> re-check "Show New Mail Desktop Alert" and your desktop alerts should be
> reinstated!


It doesn't modify the DesktopAlerts section at all, which seems to indicate

that the "Corner" fix is incidental.

"Roger Lee" <RogerLee> wrote in message

news:498FF94A-6220-43DA-9B29-00DAC3152FFD@microsoft.com...
> Confirmed. Adding the registry entry "Corner"=dword:00000003 fixes the
> problem. I rebooted and desktop alerts are definitely working. Perhaps
> SP2
> deleted the reg entry? Anyone have a pre SP2 installation?

> -R. Lee

> "Roger Lee" wrote:
>
> > I added a registry dword that told outlook 2007 to put the desktop alert
> > in
> > the bottom right ("Corner"=dword:00000003). Copy paste the stuff between
> > the
> > borders below to a notepad, save as name.reg and run. Works so far...
> > ~~~~~~~~~~
>

>> REGEDIT4
>

>> [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\DesktopAlerts]
> > "Opacity"=dword:000000d4
> > "TimeOn"=dword:00006978
> > "XOffset"=dword:00000005
> > "YOffset"=dword:00000005
> > "Corner"=dword:00000003
>

>> ~~~~~~~~~~
 
Y

yasmina.ezzat@gmail.com

I am having the same problem, since SP2 the new mail envelope

notification icon, the sound alert, desktop alert all stopped working,

although the preview is working for me. I tried everything suggested

in the previous posts, restarting, run as administrator, the corner

issue, nothing worked for me.

This is very annoying I always thought that service packs are supposed

to fix bugs and not add ones.
 
S

Stuart Sweet - Redlands for Obama Data Manager

On May 30, 1:46 pm, yasmina.ez...@gmail.com wrote:
> I am having the same problem, since SP2 the new mail envelope
> notification icon, the sound alert, desktop alert all stopped working,
> although the preview is working for me. I tried everything suggested
> in the previous posts, restarting, run as administrator, the corner
> issue, nothing worked for me.
> This is very annoying I always thought that service packs are supposed
> to fix bugs and not add ones.


Neither of those two fixes worked for me after the second round of

opening/closing.
 
M

Milhouse Van Houten

To be clear, since there are so many fixes floating around, you tried the

"Corner" fix and the "Show new mail desktop alert" ones, right? Those are

the two that actually work for people, though apparently not everyone (I'm

not counting the guy who had a laundry list of related problems, since that

must be some other issue above and beyond this one).

Perhaps try deleting the DesktopAlerts registry branch entirely, as it's not

there by default in a given installation (not until alerts are customized by

the user). I suspect that those without that branch have never seen the

problem in the first place.

Then, if necessary, redo the "Show new mail desktop alert" solution again.

"Stuart Sweet - Redlands for Obama Data Manager"

<middle.aged.hack@gmail.com> wrote in message news:b8a305c6-d70b-421b-a8d6->
> Neither of those two fixes worked for me after the second round of
> opening/closing.
 
S

Stuart Sweet - Redlands for Obama Data Manager

It works until I put the PC in standby, and then it doesn't work.
 
M

Milhouse Van Houten

Did you see my previous message?

I tested the uncheck/check one, and though it worked for numerous Outlook

runs, it eventually stopped working. Perhaps it was the reboot that I did

for an unrelated matter.

I'm now testing "Corner" to see if it's more permanent.

"Stuart Sweet - Redlands for Obama Data Manager"

<middle.aged.hack@gmail.com> wrote in message

news:0a5251d6-9447-4379-86ec-61f1e2eb8629@f16g2000vbf.googlegroups.com...
> It works until I put the PC in standby, and then it doesn't work.
 
R

RGF2aWQgVUs

I had tried everything else and worked from scratch to see what worked!

Has it done the job for you?

"Milhouse Van Houten" wrote:


> Where did you get that from? It does appear to work.

> "David UK" <DavidUK> wrote in message
> news:F89B92DD-A9DE-41A8-A79F-56B43209F2C5@microsoft.com...
> > This worked for me!
> > First off lets get Outlook up and running, then go to the system tray and
> > you will see the Outlook Icon, right click the icon then uncheck the "Show
> > New Mail Desktop Alert" then restart Outlook, once Outlook has re-started
> > re-check "Show New Mail Desktop Alert" and your desktop alerts should be
> > reinstated!
> > Hope it works for you as it did for me!!!
> > "niemie" wrote:
> >
> >> I just downloaded SP2 for office - i was happy to read about the
> >> improvements
> >> in stability to outlook. I think I found a bug though as SP2 seems to
> >> kill
> >> the desktop alert feature altogether. It stopped working for me and then
> >> I
> >> created a new rule for it which doesn't work either. I even went into
> >> tools
> >> / options and the preview desktop alert button did nothing - it's dead.


>
 
M

Milhouse Van Houten

Only temporarily.

Adding the "Corner" item into the below location was also an impermanent fix

here.

Entirely deleting the key below seems to have done the trick, however. You

do lose any alerts customization (longevity, transparency) you might have

made, but that's a small price to pay. I think this dovetails perfectly with

why so few people have this problem: only a minority every customized alerts

in the first place, and those that didn't don't have this Registry key.

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\DesktopAlerts

"David UK" <DavidUK> wrote in message

news:B10888B7-2AC1-48E1-9512-3887D15F6179@microsoft.com...
> I had tried everything else and worked from scratch to see what worked!

> Has it done the job for you?

> "Milhouse Van Houten" wrote:
>
> > Where did you get that from? It does appear to work.
>

>> "David UK" <DavidUK> wrote in message
> > news:F89B92DD-A9DE-41A8-A79F-56B43209F2C5@microsoft.com...
> > > This worked for me!
> >> > First off lets get Outlook up and running, then go to the system tray
> > > and
> > > you will see the Outlook Icon, right click the icon then uncheck the
> > > "Show
> > > New Mail Desktop Alert" then restart Outlook, once Outlook has
> > > re-started
> > > re-check "Show New Mail Desktop Alert" and your desktop alerts should
> > > be
> > > reinstated!
> >> > Hope it works for you as it did for me!!!
> >>> > "niemie" wrote:
> >> >> I just downloaded SP2 for office - i was happy to read about the
> > >> improvements
> > >> in stability to outlook. I think I found a bug though as SP2 seems to
> > >> kill
> > >> the desktop alert feature altogether. It stopped working for me and
> > >> then
> > >> I
> > >> created a new rule for it which doesn't work either. I even went into
> > >> tools
> > >> / options and the preview desktop alert button did nothing - it's
> > >> dead.

>

>>
 
Status
Not open for further replies.

Top